Frage von Asker0932, 71

Excel Tabelle Funktion - Hilfe?

Hallo,

ich scheitere bei einer komplexen Funktion, die ich brauche. Folgendes:

In der linken Spalte (A) steht immer X oder Y untereinander, per Hand eingetragen. Rechts daneben in der Spalte B jeweils eine dazugehörige Zahl (z.B. 2,1). Ich bräuchte nun eine Formel die in einem Feld immer folgendes rechnet:

Wenn links X, rechte Zahl mal 10

Wenn links Y, rechte Zahl außer Acht lassen, einfach -10

Und das dann für alle Einträge untereinander addieren bzw halt auch subtrahieren, so dass eine gesamte Summe in einem Feld raus kommt.

Expertenantwort
von Ninombre, Community-Experte für Excel, 27
=SUMMENPRODUKT((A1:A100="X")*(B1:B100)*10)-(ZÄHLENWENN(A1:A100;"Y")*10)

oder

=SUMMENPRODUKT((A1:A100="X")*(B1:B100)*10)-SUMMENPRODUKT((A1:A100="Y")*10)

Die anderen Ansätze gehen mit einer Hilfsspalte, also wenn du

=WENN(A1="x";B1*10;-10)

in eine neue Spalte und bis zum Ende der Liste kopieren. Darüber die Summe. Mit Summenprodukt geht es mit einer Zelle.

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 42
=10*(SUMMENPRODUKT((B:B)*(A:A="X")-(A:A="Y")))

(ungetestet)

Kommentar von Funfroc ,

so gehts auch... getestet :-)

Kommentar von Suboptimierer ,

Habs versucht, noch ein bisschen zu optimieren. Geht hoffentlich immer noch.

Kommentar von Asker0932 ,

Vielen Dank. So in der Art müsste es eigentlich hinhauen, leider #Wert

Kommentar von Asker0932 ,

Habe meinen Fehler bemerkt, danke haut hin!!!

Kommentar von Suboptimierer ,

Bitteschön!

Kommentar von Funfroc ,

jetzt komme ich gar nicht mehr mit. Das ist also richtig... meins aber nicht?

Die Funktionen machen beide das gleiche, nur mit unterschliedlichen Ansätzen.

Kommentar von Asker0932 ,

Hey, tut mir Leid, deins haut auch hin, siehe Kommentar bei deiner Antwort. Auch dir: Herzlichen Dank

Antwort
von Funfroc, 40

Hallo,

soweit ich dich verstehe... so:

=(SUMMEWENN(A:A;"X";B:B)*10)-(ZÄHLENWENN(A:A;"Y")*10)

LG, Chris

Kommentar von Asker0932 ,

Hallo, vielen Dank, die Formel funktioniert zwar. Aber du hast mich etwas missverstanden. Bei jedem Y soll einfach -10 subtrahiert werden, nicht alle Y's zusammen mit mal zehn abziehen. Kannst du das vielleicht noch anpassen? Vielen Dank schonmal!!

Kommentar von Funfroc ,

Sorry, mit der Fomulierung komme ich jetzt nicht mit.

Bei jedem Y soll -10 gerechnet werden. Wenn ich in Zeile A2, A4 und A6 ein Y stehen habe soll also für A2, A4, und A6 jeweils -10 gerechnet werden. Das sind ergo -30.

Genau das macht meine Funktion.

Oder willst du das Ergebnis immer nur bis zu der jeweiligen Zeile haben?

Dann so:

=(SUMMEWENN(A$1:A1;"X";B$1:B1)*10)-(ZÄHLENWENN(A$1:A1;"Y")*10)
Kommentar von Asker0932 ,

Hallo, tut mir Leid, war ein Denkfehler meinerseits, weil ich es direkt an einer komplexen Tabelle versucht habe. Funktioniert aber: also vielen vielen Dank!!

Kommentar von Funfroc ,

ok, Denkfehler kommen vor... bei jedem.

Als Tipp:

Lege dir für sowas immer schnell eine separate Testtabelle mit wenigen Werten an, wo du das gewünschte Ergebnis schnell per Hand ausrechnen kannst.

Dann siehst du, ob die Formel das errechnete Ergebnis bringt. Kurz Querprüfen, ob bei Änderungen das Ergebnis immer noch stimmt.

Wenn alles passt kann man die Formel für die "richtige" Tabelle nehmen.

LG, Chris

Kommentar von Suboptimierer ,
Bei jedem Y soll einfach -10 subtrahiert werden, nicht alle Y's zusammen mit mal zehn abziehen.

Wo ist der Unterschied?

n * (-10) = ∑ -10, i=1..n 

Antwort
von LeroyJenkins87, 54

=WENN(A1="x";B1*10;-10)

Kommentar von Asker0932 ,

Danke, aber soll ja nicht nur für A1 und B1 sein sondern für alle A's und B's

Kommentar von LeroyJenkins87 ,

Das kannst du dann einfach runterziehen und dann ganz unten

=SUMME(C1:C??)

 

Keine passende Antwort gefunden?

Fragen Sie die Community