Frage von MaKa86, 68

Excel Tabelle >Formel in Spalten übertragen<?

Hallo Zusammen,

ich hoffe das Ihr mir helfen könnt. Bin jetzt nicht so der Excel Spezi in der Hinsicht.

Folgende Frage.

Ich habe 4 Spalten.

A  B  C   D

3822 B Küche 1

3823 B Küche 1

3824 B Küche 1

3825 B Küche 1

3826 B Küche 2

3827 B Küche 2

3828 B Küche 2

3829 B Küche 2

Und zwar soll in der Spalte A ein Wert von 3822 u.max. 3825 sein. Ist von mir aus schon vorgegeben. Ist dies der Fall, soll dann automatisch in Spalte D eine 1 stehen.

Selbe Spiel mit den von mir vorgegeben Werten 3826-3829. Da soll wiederum in der Spalte D eine 2 stehen usw.

Ich hoffe mal, das ich es nicht so kompliziert beschrieben habe. Schon mal vielen lieben Dank für eure Hilfe :-)

Expertenantwort
von schmiddi1967, Community-Experte für Excel, 68

OK, ich gehe jetzt davon aus das alle Zeilen in Spalte A gefüllt sind und das du bei A1 die erste Zahl hast, dann diese Formel in D1 und runterziehen:

=SVERWEIS(A1;{3822.1;3826.2};2;1)

Hast du auch leere Zeilen dazwischen musst du diese nehmen:

=WENN(A1<>"";SVERWEIS(A1;{3822.1;3826.2};2;1);"")

Die Formeln kannst du einfach erweitern (den Fett markierten Bereich), weil du oben was von usw. geschreiben hast.

Hilft dir das so weiter ?

Expertenantwort
von DeeDee07, Community-Experte für Excel, 41

Soll immer für je vier aufeinanderfolgende Zahlen ein gemeinsamer Wert ausgegeben werden?

Dann kannst du auch die Formel

=GANZZAHL((A1-3822)/4)+1

verwenden und runterkopieren.

Kommentar von schmiddi1967 ,

DH! Den Gedanken hatte ich auch zuerst, bin aber davon weg gegangen :))

Seine Antwort zeigte mir dann das er auch größere Zwischenräume hat, dewegen habe ich das gar nicht in betracht gezogen.

Kommentar von Iamiam ,

Lücken dürften doch hier gar nicht stören (aber A$1 müsste es m.E. schon sein)? und die Zahlen dürften auch durcheinander stehen? (zB nach umsortieren)

Oder sehe ich i'was nicht?.

Kommentar von DeeDee07 ,

Warum A$1? Das Ergebnis in D soll aufgrund der Zahl in A ermittelt werden, somit soll sich auch die Zeile ändern beim Runterkopieren.

Kommentar von Iamiam ,

Du hast recht mit

=GANZZAHL((A1-3822)/4)+1

Ich schreibe normalerweise keine Zahlen in die Formel und versuche, sie so allgemein wie möglich zu halten, weshalb ich gedanklich A$1 einer Referenz und 3822 einer Laufzahl zugeordnet habe. (hätte dann aber eine negative Zahl ergeben). Mein Fehler!


Antwort
von MaKa86, 53

Das hat schon mal super geklappt!!!!!!!!!!

Jetzt hätte ich dazu noch eine Frage. Was muss ich bei der Formel noch eintragen da Sie ja weiter geht?

Wäre das fett gedruckte so richtig?

=SVERWEIS(A1;{3822.1;3826.2;3840.3};3;2;1)
Kommentar von schmiddi1967 ,

Nein, einfach nur so. Ganz hinten nichts ändern, nur das Fettgedruckte:

=SVERWEIS(A1;{3822.1;3826.2;3840.3};2;1)

Am besten immer direkt auf meine Antwort anworten, sonst bekomme ich nicht mit das du was geschrieben hast. Das war jetzt eher Zufall das ich hier wieder rein geschaut habe:)))

Kommentar von Iamiam ,

zum Verständnis: Bei einer angegebenen {Matrix} charakterisiert der Semicolon untereinander stehende, der Punkt nebeneinander stehende Zellen.

{3822.1;3826.2;3840.3}

charakterisiert also eine dreizeilige, zweispaltige Matrix. SVgl sucht nun in der ersten Spalte nach A1 und gibt den Wert aus der 2. Spalte wieder, wenn als drittes Argument ;2; (also nicht 3, 3 gibt es nicht!) dasteht. Der Vergleichsoperator 1 (WAHR) liefert bei Nichtfindung den Eintrag zum SpaltenWert davor, braucht aber (WAHR-)geordnete, steigende Listen.

Bei wenigen Einträgen ist diese Formel hier mit einiger Übung besser nachvollziehbar, bei vielen wäre sie zu mühsam (und i'wo begrenzt), dann DeeDees Formel.


Kommentar von Iamiam ,

natürlich nicht SVgl, sondern SVw !

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten