Frage von CheonSongyi, 94

EXCEL? SVERWEIS? Wie soll das funktionieren?

Okay, ich muss das schaffen xD Aber ich habe keine Ahnung wie. Kann mir jemand die Formel verraten?

Expertenantwort
von Ninombre, Community-Experte für Excel, 33

Die richtige Formel wurde ja genannt...Du brauchst allerdings mehr als einen SVERWEIS

Um Dir nicht die Chance zu nehmen, die Formel tatsächlich zu verstehen, zunächst mal eine grundlegende Erklärung anschauen (gibt auch diverse andere Seiten zum lesen oder Videos, wem das mehr liegt):

https://support.office.com/de-de/article/SVERWEIS-Funktion-0bbc8083-26fe-4963-8a...

Dann für den ersten Fahrer in G12 die Ermittlung des Kraftstoffs:

=SVERWEIS(D12;H$4:I$9;2;FALSCH)

Das FALSCH hier steht für "ungefähre Übereinstimmung = NEIN" sprich es soll nach einem genauen Treffer gesucht werden.

Die $ Zeichen dienen dazu, dass der Zellbezug nicht verändert wird, wenn Du die Formel für die anderen Fahrer kopierst (die Zwischentabelle mit Fahrzeug, Kraftstoff und Verbrauch soll ja nicht mitrutschen)

Für Deine Berechnung musst Du du in eine Gesamtformel neben dem genannten SVERWEIS zur Ermittlung Kraftstoffart noch SVERWEIS für Verbrauch und SVERWEIS für Preis verbinden.

Kommentar von CheonSongyi ,

Danke, es kommt aber irgendwie nicht wirklich etwas heraus...Zum Verstehen bleibt mir keine Zeit mehr gerade. Wenn ich das geschafft hätte, hätte ich jetzt einen 1er xD

Kommentar von Ninombre ,
=SVERWEIS(SVERWEIS(D12;H$4:I$9;2;FALSCH);C$4:D$7;2;FALSCH)*SVERWEIS(D12;$H4:J$9;3;FALSCH)/100*F12

Dann solltest Du halt rückwirkend versuchen, die Formel zu verstehen, ansonsten ist es ja für den Eimer wenn hier einfach die fertige Lösung steht.

=SVERWEIS(SVERWEIS(D12;H$4:I$9;2;FALSCH);C$4:D$7;2;FALSCH)*SVERWEIS(D12;$H4:J$9;3;FALSCH)/100*F12

Das fett gedruckte sucht die Automarke aus D12 in der ersten Spalte der Tabelle H4:I9 (also in H) und liefert das Ergebnis aus der 2. Spalte (also aus I). Damit hat man "Benzin" ermittelt.

Dieser SVERWEIS ist nun der Suchbegriff für den kursiv geschriebenen. Du suchst in der Tabelle C4:D7 in der 1. Spalte (C) nach Benzin und nimmst den Preis aus der 2. Spalte (D)

Der dritte, normal geschriebene SVERWEIS ermittelt wieder über die Marke in D12 aus der Tabelle H4:J9 (hier ist die Matrix nicht H4:I4, sondern um eine Spalte erweitert) den Verbraucht

Antwort
von Jackie251, 33

zunächst muss aus der Automarke der Treibstofftyp ermittelt werden.

also ein Sverweis = suche Automarke in Fahrzeugtabelle und geben den Wert in der Spalte Treibstoff zurück.

Mit diesem Wert wird dann der Preis des Treibstoffs ermittelt.

Treibstoffpreis x Treibstoffmenge sind dann die Kosten. Die verbrauchte Menge ermittelt sich wiederrum aus der Automarke und der Km Zahl

Antwort
von hankey, 40

Da hat sich aber jemand eine komplizierte Formel ausgedacht. Du sollst also anhand aller Daten nur in den Zellen G12 bis G21 die Spritkosten herausfinden und dabei noch ne SVERWEIS-Formel benutzen?

Lässt sich so frei aus dem Kopf nur schwer sagen, das müsst ich nachstellen.

Antwort
von azmd108, 41
=(SVERWEIS(B11;F2:H7;3)*SVERWEIS(SVERWEIS(B11;F2:G7;2);A1:B4;2)*C11)/100

A1 bis B4 = Preistabelle
F2 bis H7 = Fahrzeugtabelle
B11 bis C20 = Tabelle mit Daten (bei mir nur Hersteller und KMstand)

Is natürlich nur ein Beispiel, geht vllt auch etwas eleganter oder einfacherer. Wenn du die Formel runterziehen willst, natürlich entsprechend mit $ sperren.

Kommentar von CheonSongyi ,

Wie...Sperren? xD

Kommentar von azmd108 ,

$ vor dem Buchstaben bedeutet, dass beim ziehen der Formel, die Spalte unverändert bleiben soll. $ vor der Zahl bedeutet, dass beim "ziehen" der Formel die Zeile unverändert bleiben soll. Du willst immer nur, dass sich das suchkriterium dynamisch anpasst, der rest bekommt nen $-davor z.B:

$F$2:$H$7
Kommentar von Ninombre ,

Mit dem $ vor eine Spalte und / oder Zeile verhindert man, dass dieser Wert beim Kopieren der Formel verändert wird.

Wenn die erste Formel in G12 steht und Du sie in G13, G14 etc. kopierst, werden die Zellbezüge in der Formel normalerweise automatisch angepasst. Wenn in G12 z.B. B11 auftaucht, erhöht sich das auf B12, B13...

Das muss man für die Zwischentabellen H4:J9 und C4:D7 verhindern - die Tabellen bleiben ja am gleichen Platz stehen. Daher H$4:J$9

Antwort
von iMPerFekTioN, 27

Hallo :)
Für den Treibstoff brauchst du diese Formel:

=SVERWEIS(D12;H4:J9;2;0)

Für den Verbrauch dann diese hier:

=SVERWEIS(D12;H4:J9;3;0)

Für den Spritpreis dann diese hier:

=SVERWEIS(G12;C4:D7;2;0)

Die erste Formel tippst du in "G12" ein, die Zweite dann in "H12" die dritte in "I12"

Dann hast du die Übersicht über Verbrauch, Treibstoff und den Spritpreis.


Grüße,


Philip


P.s.

In einer Formel wäre es dann so:

=SVERWEIS(D12;H4:J9;3;0)*F12*SVERWEIS(SVERWEIS(D12;H4;J9;2;0);C4:D7;2;0)/100


Kommentar von CheonSongyi ,

Danke, funktioniert bei mir aber nicht :(

Kommentar von iMPerFekTioN ,

Hab mich vertippt, Sorry :c

versuch es mit dieser Formel in G12

=SVERWEIS(D12;H4:J9;3;0)*F12*SVERWEIS(SVERWEIS(D12;H4:J9;2;0);C4:D7;2;0)/100
Kommentar von CheonSongyi ,

Nein, auch nicht :( Da kommt nur #NW

Kommentar von iMPerFekTioN ,

Kopiere die Formel bitte nochmal raus und versuch es, bei mir klappt es auch.

Vielleicht ist beim einfügen was verrutscht

Kommentar von CheonSongyi ,

Danke, habe den Fehler gefunden!

Kommentar von iMPerFekTioN ,

Ist also etwas verrutscht?:)
Freut mich für dich :D

Ist zwar eher sinnlos eine Formel einfach zu kopieren, aber gut :)
Vielleicht machst du dir ja noch die Mühe die Formel zu verstehen oder dir die Anleitung von Ninombre durchzulesen

Danke an dieser Stelle an dich @Ninombre

Kommentar von CheonSongyi ,

Ja werde ich. Aber es ging gerade darum, ob ich einen 1er bekomme und da sind mir dann alle Mittel recht, haha! Außerdem hatte ich nur noch 5 Minuten Zeit ;)

Kommentar von iMPerFekTioN ,

Also hat meine Formel jetzt funktioniert? Oder nicht?:D

Keine passende Antwort gefunden?

Fragen Sie die Community