Excel SVerweis mehrere Einträge in eine Zelle?

... komplette Frage anzeigen

3 Antworten

Ich kann bei dem Beispiel noch nicht erkennen, wo der Sverweis ins Spiel kommt, aber das Verketten von Inhalten ist mit & schon richtig, allerdings ohne das +

Also =A1 & " " & C1 & " " & B1

(ich hab unterstellt, dass da noch Leerzeichen dazwischen sollen). Du kannst auch das Ergebnis von Formeln auf die Weise verketten, wenn also Anrede, Vorname, Name über SVERWEIS ermittelt werden, dann ist es halt
=sverweis(....) & " " & sverweis(....) etc.

Was Du Dir auch anschauen könntest wäre Serienbrief in Word - Excel als Datenbasis aber den eigentlichen Brief in Word, was hinsichtlich Texte formatieren natürlich wesentlich komfortabler ist.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von jurist87
03.03.2016, 15:15

Super, es hat funktioniert. Gibt es eine Möglichkeit einen Leerzeichen zwischen B1 und C1 einzufügen. Jetzt steht nämlich "VornameNachname" im Briefkopf.

0

Um meine Frage etwas zu konkretisieren, lade ich mal Screenshots hoch. Ich würde gerne in C16 bei Rechnung sowohl den Vor- als auch den Nachnamen aus den Spalten D und E einfügen.
Derzeit kann ich ja nur den Vornamen bei C16 und den Nachnamen bei D16 einfügen.

=WENN(F21="";"";SVERWEIS(F21;Kunden;4;FALSCH))

So ist mein SVerweis stuktusiert. Ich habe bereits folgende Varianten versucht:

=WENN(F21="";"";SVERWEIS(F21;Kunden;4&5;FALSCH))

=WENN(F21="";"";SVERWEIS(F21;Kunden;4+5;FALSCH))

=WENN(F21="";"";SVERWEIS(F21;Kunden;4;5;FALSCH))

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
03.03.2016, 16:04

mit sverweis kannst Du leider nur einen Wert übernehmen. Du kannst aber mehrere sverweis-Ergebnisse verketten und mit &" "& auch noch ein Leerzeichen dazwischen

=WENN(F21="";"";SVERWEIS(F21;Kunden;4;FALSCH)&" "&SVERWEIS(F21;Kunden;5;FALSCH))
0

kannst du vlt versuchen genauer zu erklären wie du das meinst ich blick nicht ganz durch :D aber in excel war ich eig ganz gut :D

Antwort bewerten Vielen Dank für Deine Bewertung