Frage von breekachu, 69

Excel Summierung: Text = Wert?

Ich habe in einer Tabelle. In der Spalte F und G stehen jeweils eine Zahl und Text aus einer Dropdownliste (z.B. "2 abc"/"3 cdef", zwischen 5-50 Zeilen, kann auch teilweise leer sein), die in B (4 Zeilen: Text) vorkommen. Spalte C (auch 4 Zeilen: Zahl) repräsentieren dabei den Wert von B. Nun will ich eine Summierung in F und G durchführen (mit den Werten, die in C stehen), wobei der größere Wert von F oder G als Summierungswert übernommen werden soll. Wie funktioniert das oder Welche Formeln benötige ich?

Expertenantwort
von Ninombre, Community-Experte für Excel, 26

ehrlich gesagt wird das Beispiel mit Zahlen und ausgeschriebenen Zahlen nicht unbedingt einfacher nachzuvollziehen.

Du vergleichst die Texte zwischen TabA!F:F und TabB!B:B und summierst bei Übereinstimmung des jeweils höheren Wert der Zeile aus TabA!G:G bzw. TabB!C:C.

Dafür ist Summenprodukt aus meiner Sicht der Lösungsweg, allerdings komme ich nicht auf eine Lösung den höheren Wert je Zeile ohne Hilfsspalte zu ermitteln.

=SUMMENPRODUKT(((F1:F10)=(TabB!B1:B10))*H1:H10)
wenn diese Formel auf TabA steht und in Spalte H als Hilfsspalte
=max(G1:TabB!C1)


Kommentar von Ninombre ,

geht auch ohne Hilfspalte, aber dann als Matrixformel

=SUMMENPRODUKT(((F1:F10)=(TabB!B1:B10))*WENN((G1:G10)>=(TabB!C1:C10);(G1:G10);(TabB!C1:C10)))

Nach der Eingabe die Zelle mit STRG+SHIFT+Enter verlassen, dann entstehen noch die { } um die Formel

Kommentar von breekachu ,

Leider habe ich in Excel noch nicht mit Matrizen gearbeitet und wusste nicht dass es bei Excel sowas gibt. Leider funktioniert auch deine Antwort nicht auf meine Tabelle, siehe meine Kommentar. Ist auch sehr doof erklärt von mir...

Kommentar von breekachu ,

Danke für die Antwort, aber Leider geht das mit Summenprodukt glaube ich nicht, da die Werte in TabA!F:F nicht gleich TabB!B:B und TabB!C:C sind. Es ist echt ein wenig kompliziert wie ich das erklärt habe...

Ich versuche die Erklärung nochmal... Ich habe in TabA!F und TabA!G (kann je 5-50 Spalten sein, sind aber gleich groß) eine Dropdownliste mit Werten, die in TabB!B (nur 4 Werte) stehen. Ein Zahlenwert, der den Wert in TabB!B repräsentiert ist in TabB!C hinterlegt.

Nun will ich eine Summierung der Werte in  F und G, wobei der höhere Wert ausgewählt werden soll.

Meine Idee wäre es, die Werte in F und G jeweils mit B vergleichen und 2 neue Arrays mit den zu repräsentierenden Zahlenwerts, der in C gespeichert ist, zu hinterlegen. Danach den größeren Wert der beiden F und G Spalten in ein neues Array zu schreiben und die Werte summieren. Das ist aber nur die Sicht eines Programmierers... Aber wie lässt sich das nun in Excel umsetzen?

Kommentar von Ninombre ,

ohne Bilder bin ich nicht sicher, ob ich jetzt die Sache wirklich verstehe. Mal als Anfang mit einer Hilfsspalte:

=MAX(SVERWEIS(A1;F:G;2;FALSCH);SVERWEIS(B1;F:G;2;FALSCH))

Ich kann wie gesagt nicht sicher sagen, ob der Aufbau zu Deiner Tabelle passt. SVERWEIS geht nun auf jeden Fall, auch den höheren Wert aus zwei SVERWEISEN. Im einfachsten Fall kannst Du diese neue Spalte aufsummieren

Kommentar von breekachu ,

SVERWEIS ist der Ansatz den ich gebraucht habe. Damit lässt es sich rechnen :) Vielen Dank! Wenn das jetzt auch noch ohne Hilfsmatrix gehen würde, dann kann ich auch noch besser schlafen :D

Expertenantwort
von Iamiam, Community-Experte für Excel, 29

Du willst also unterscheiden zwischen Text- und Zahlenwerten?

Bis 9 kannst Du das über die entsprechenden Codewerte machen:

=Code(0), zu Zahl =Zeichen(Code(0))*1 (etwas umständlich)

Oder Du schaltest eine =istzahl(Bezug)-Abfrage vor.

Meinst du mit entsprechende die Zeile oder die Zahl

Und wovon die größte, da ist doch immer nur eine, oder meinst Du die höchste Zeile. Sollst Du aus einer anderen Spalte dazu irgendwas auslesen?

Kommentar von breekachu ,

Nicht unbedingt. Aber ein Text repräsentiert ein Zahlenwert. Dabei ist der Text z.B. gegeben als: "2 ★★☆" oder "1 ★☆☆". und die Werte sollen eben summiert werden. SUMME funktioniert leider nicht, da es als Text erkannt wird.

Kommentar von Iamiam ,

ich blick zwar nach wie vor nicht durch, aber für nur einstellige (oder nur zweistellige etc) kannst Du die Matrixformel so erhalten:

{=MAX(LINKS(INDEX((A1:A11);VERGLEICH(LINKS(A9;1)*1;LINKS(A1:A11;1)*1;0);1))*1)}

(das wandelt also 5xx zu 5 und findet die 5 auch. Vllt ist da mal zuviel des Guten drin mit *1, aber es geht so. wobei ich die Such-(=Vergleichs-)spalte und die Finde=Auslesespalte hier gleich hab, was man aber auch differenzieren kann: geht nur ums Prinzip!

Davon zwei oder mehrere Summanden addieren.

Vllt kommst Du mit dieser Anregung schon zurecht!

Kommentar von breekachu ,

das mit =Links... *1 ist auch etwas was mir auch sehr weiterhilft. Bei dem Versuch ohne *1, kam leider beim Rechnen immer 0 raus. Mit *1 funktioniert das.

Ich habe aber jetzt eine Alternative mit SVERWEIS geschafft. Ist allgemeiner wenn ich den Text mal ändern will.

Kommentar von Iamiam ,

Danke für die Rückmeldung!

WAHR und FALSCH sind Texte, ebenso Links(...). Mit i'einer Rechenoperation wandelt xl das -wenn möglich- in eine Zahl um.

Geht auch mit "27.9.16"*1 oder "27.09.2016 13:27"*1

Das = erfüllt manchmal dieselbe Funktion, aber bei >,< braucht man das unbedingt!

Im übrigen halte ich die Kombi index/Vergleich für wesentlich flexibler als den SVerweis, man muss sich nur erst mal umstellen!

Antwort
von Funfroc, 33

Hallo,

sorry, die Fragestellung ist mir etwas zu wirr.

Grundsätzlich klingt das nach Summewenn, Summewenns oder Summenprodukt.

Wenn du dazu vielleicht mal ein Beispielbild posten könntest, wäre das sicher hilfreich.

LG, Chris

Kommentar von breekachu ,

Ich versuche die Erklärung nochmal... Ich habe in TabA!F und TabA!G (kann je 5-50 Spalten sein, sind aber gleich groß) eine Dropdownliste mit Werten, die in TabB!B (nur 4 Werte) stehen. Ein Zahlenwert, der den Wert in TabB!B repräsentiert ist in TabB!C hinterlegt.
Also grob:

F und G: Enthält Dropdownliste mit einem Text, die in B stehen (anzahl variiert zwischen 5 und 50, aber F und G sind immer gleich groß oder in einem steht etwas und in dem anderen nicht)
B: irgendein Text (4 Texte)
C: Eine Zahl die den Text in B repräsentiert (also auch 4 Werte)

Nun soll (F und G) mit B verglichen werden und die Zahl in C als Wert nehmen. Dann soll F und G miteinander verglichen werden und die größere Zahl übernommen werden. Zum Schluss sollen die Werte Summiert werden.

Ich hoffe das ist jetzt verständlicher

Keine passende Antwort gefunden?

Fragen Sie die Community