Frage von Postifus, 62

Excel: Summewenns mit Teil-Funktion?

Hallo,

mein Problem ist, dass ich die Teil-Funktion nicht in die Summewenns-Funktion eingebaut bekomme. Excel zeigt mir wenn ich es versuche immer den Wert 0 an.

=SUMMEWENNS(C1:C7;D1:D7;TEIL(D1:D7;2;1)=2;B1:B7;">500")

  1. Position1 |17454| |0,2| |100|
  2. Position2 | 21 | |0,6| |121|
  3. Position3 |7519| |0,5| |120|
  4. Position4 |74| |0,8| |120|
  5. Position5 |658| |0,02| |21|
  6. Position6 |784| |0,3 |221|
  7. Position7 |365| |0,4| |120|

Und zwar soll Excel die Werte in der dritten Spalte addieren, wenn in der zweiten Spalte der Wert über 500 ist und in der vierten Spalte die Zahl in der Mitte eine 2 enthält.

Vielen Dank im vorraus

Expertenantwort
von Oubyi, Community-Experte für Excel, 47

Teste mal:

=SUMMENPRODUKT((B1:B7>500)*(TEIL(D1:D7;2;1)="2")*(C1:C7))

Ich denke mit SUMMEWENNS bekommt man das mit dem TEIL nicht geregelt. Ich ziehe aber Lösungen mit SUMMENPRODUKT sowieso vor, da sie imho übersichtlicher sind.

Habe ich Dich richtig verstanden?
Klappt es?

P.S.:
TEIL gibt immer einen String zurück, daher muss man aus "2" abfragen, nicht auf 2.


Kommentar von Postifus ,

Vielen vielen Dank! 

Auf die Idee bin ich und wäre ich nicht gekommen. 

Kommentar von Oubyi ,

Gern geschehen ☼

Kommentar von Iamiam ,

meinerseits verkehrt

Expertenantwort
von Iamiam, Community-Experte für Excel, 30

In Oubyis AW wird Position 5 D=21 ignoriert, weil Teil(21;2;1) ja 1 ist und nicht 2.

Das könnte so gewollt sein, ich vermute aber eher nicht.

Wenn nicht, also immer die Zehnerstelle eine 2 sein soll, dann:

=SUMMENPRODUKT((C1:C7)*(GANZZAHL(D1:D7/10)-GANZZAHL(D1:D7/100)*10=2)*(B1:B7>500))

Kommentar von Oubyi ,

Da könntest Du recht haben.
Ich hatte mich an der Formel des FS orientiert:
...TEIL(D1:D7;2;1)...
und seiner Beschreibung.
Aber die 21 ist wirklich ein Problem:
Alternativer Lösungsweg, wenn 21 zählen soll und die Werte immer <=999 sind:

=SUMMENPRODUKT((B1:B7>500)*(TEIL(TEXT(D1:D7;"000");2;1)="2")*(C1:C7))

Kommentar von Iamiam ,

die (un)genaue Formulierung war sogar noch weiter: "die Zahl in der Mitte eine 2 enthält": ja, wo ist die Mitte von 21 ?

Diese winzigen Ungenauigkeiten sind es, was zwar die Beantwortung oft erschwert, andererseits aber immer wieder interessante Überlegungen herausfordern!

Ein Lob den Ungenauigkeiten in unseren Sprachen, auch sie treiben die Entwicklung an- die eigene wie die der Wissenschaften!

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten