Frage von herved, 42

Excel: Summenbildung anhand eines Datums - wie kann ich dies auf einfache Weise lösen?

Ich möchte in einer Excel-Tabelle eine Summe bilden, indem ich einen Zellbereich mit Datumsangaben durch Angabe des Start-und Enddatumms markiere..Ich habe hierzu ein Tabellenblatt wie beigefügt: Spalte B "Datum" und Ergebniswerte in den Spalten G,H,I.In der Kopfzeile gebe ich das Start-und Enddatum ein und möchte in den Zellen G:2 oder H2 oder I2 das Ergebnis als Summe haben, im Beispiel für den Zellenbereich B:13-B:32.Wie kann ich dies auf eingfache Weise lösen?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, Mathe, Mathematik, 30
=SUMMEWENNS($I$10:I36;$B$10:B36;">="&D2;$B$10:B36;"<="&D3)
Kommentar von Suboptimierer ,

Zu beachten ist, dass wenn du die Summen in derselben Spalte stehen hast wie die zu summierenden Zeiten, du die Summen evtl. mehrfach einrechnest. Entweder darf in Spalte B vor einer Bereichssumme kein Datum stehen oder du musst die Zwischensummen verrücken.

netto und brutto würde ich auch in der Spalte versetzen.

Expertenantwort
von Iamiam, Community-Experte für Excel, 17

solltest du noch ein altes xl haben, das SummewennS nicht kennt, dann gehts auch so:

=SUMMEWENN($B$10:B36;">="&D2;$I$10:I36)
-SUMMEWENN($B$10:B36;"<="&D3;$I$10:I36)


mit ">=" und "<=" werden die Grenzdatümer
miteinbezogen,
birgt in anderen Zusammenhängen
die Gefahr von Doppel
zählungen, normalerweise
lässt man
bei einem der beiden das = weg

Kommentar von herved ,

Entschuldigung, ich wurde falsch verstanden: Der Bereich, von dem die Summe zu bilden ist, wird nur durch die Angabe des Start-und des Enddatums definiert und unter Angabe der Spalte, aus der die Summe zu bilden ist. Einfacher wäre doch gleich die Summe über "Auto-Summe" zu bilden.

Kommentar von Iamiam ,

Die Formel macht nichts anderes: D2 Startdatum (älteres=kleinere Tageszahl), D3 Enddatum.

Anstatt i10:i36 kannst Du auch i4:i436 o.ä schreiben, dann kannst Du eine ganze Jahresliste erfassen und der Bereich wird automatisch erweitert, wenn Du über Zeile 10 (unterhalb von Zeile 4) neue Zeilen einfügst.

Da Du Deine sonstigen Summen (wenn überhaupt noch erforderlich nicht neben einem Datum stehen hat,. werden sie auch nicht mitsummiert.

Was nicht geht: i:i, weil die Summe selbst in Spalte i gebildet wird, das ergäbe Zirkelbezug

Keine passende Antwort gefunden?

Fragen Sie die Community