Frage von Pylo89, 57

Excel Summen aus variabler Datenmenge auflisten?

Hallo, ich habe eine Datenmenge, die von einer Zelle mittels Formel bestimmt wird. Ich möchte mir jetzt die Summe der Datenmenge auflisten lassen. Dabei soll der Zahlenwert der Formel vor dieser Summe stehen.

Kann Excel quasi im Hintergrund die von mir angebeben Werte in die bestimmende Zelle einsetzen und mir dann die Summe dafür ausgeben? Ich möchte nicht alle Zahlen immer wieder in die bestimmende Zelle einsetzen, die Summe kopieren und in meine Liste kopieren.

Danke im Voraus.

Antwort
von Funfroc, 29

Hallo,

klingt für mich grundsätzlich erst mal nach SUMMEWENNS oder SUMMENPRODUKT.

Bitte mal etwas genauer Schildern, was steht in welchem Bereich. Was ist Grundlage der Berechnungen. Am besten wäre ein Screenshot eines manuell erzeugten Sollzustandes.

LG, Chris

Antwort
von Pylo89, 17

Danke für eure Antworten, konnte noch keine testen. Mache ich sobald wie möglich.

Möchte euch noch ein Bild hochladen, damit meine Fragestellung klarer wird.

Mein x in B3 bestimmt meine Datenmenge (A4:C6). Darunter bilde ich die Summe. Jetzt trage ich jede Summe in meine Tabelle rechts ein. Dafür muss ich aber immer mein x händisch ändern.

Ich möchte diesen Schritt automatisieren, mein x also anpassen und den Wert der Summe direkt in die Tabelle eintragen lassen.

Danke!

Kommentar von Ninombre ,

Nach welcher Logik bildest Du denn die Summen? Bei X=3 werden alle Zahlen summiert, die Werte für X=1 und X=2 konnte ich aber nicht nachvollziehen.

Kommentar von Pylo89 ,

Soll einfach summiert werden (=Summe(A4:C6). Habe wohl einen falschen Screenshot benutzt. Habe die Werte von x=1 und x=2 nicht angepasst. 

Kommentar von Ninombre ,

Je nach Wert von x ändern sich also die Zahlen im Bereich A4:C6?  Ich verstehe weiterhin nicht den Unterschied zwischen x1, x2 usw. Wenn sich nicht die Art der Berechnung ändert, müssen die Zahlen unterschiedlich sein, sonst kommt ja immer das gleiche Ergebnis. Wie kommen die Zahlen zustande, die summiert werden sollen? 

Kommentar von Pylo89 ,

Ja genau, je nach Wert von x ändern sich die Zahlen im Bereich A4:C6. Ich bilde hier im Beispiel das Produkt aus x und einer willkürlichen Zahl. Mir geht es ja letzlich nur um die Summe des ausgewählten Bereiches. 

In meiner richtigen Exceldatei sind diese Zahlen Pixelzusammensetzungen eines Bildes und x ist die Nummer des Bildes. Je nach Bildnummer ändert sich die Pixelzusammensetzung.

Ich versuche euch einfach mal einen Befehl aufzuschreiben, wie ich ihn theoretisch bräuchte:

=Summe( A4:C6 , wenn B3=(5) )

Ich hoffe das ist verständlich. Danke für eure Geduld!

Expertenantwort
von Ninombre, Community-Experte für Excel, 30

Ohne konkrete Angaben ist es mit genauer Antwort schwierig.

Du kannst das Ergebnis von zwei Formeln in der Anzeige miteinander verketten

=SUMME(A1:A2)&"---"&PRODUKT(A1:A2)
wenn A1 und A2 jeweils 1 sind, gibt das als Anzeige: 2---1

Ist der Bereich, der summiert werden soll, denn auch variabel? Dann müsstest Du die Logik der bisherigen Formel auch für die summe verwenden.

Kommentar von Pylo89 ,

Danke für die Mühe, ich habe mich wohl etwas undeutlich ausgedrückt und als Antwort nochmal ein Bild hochgeladen, mit dem meine Fragestellung hoffentlich deutlicher wird.

Expertenantwort
von Iamiam, Community-Experte für Excel, 31

Weiß nicht, ob ich Dich richtig verstanden habe, versuchs mal mit =Summe(indirekt("Bereich"))

(also den Bereich als Adresse "Erste:letzteZelle" in Anf-Zeichen)

War es das? ansonsten melde Dich nochmal!

Kommentar von Iamiam ,

Da Du die Liste vermutlich in einer anderen Tabelle stehen hast, muss ins indirekt noch der Blattname rein, damit es auch in einem anderen Blatt noch stimmt:

=Summe(indirekt("Blatt1!"&"Bereich"))

die Formel ist absolut, wird also durch kopieren nicht verändert.

Hast Du die Liste in einer anderen Datei, dann

=Summe(indirekt("'[Quelldatei]Blatt1'!"&"Bereich")

die beiden Hochkommata vor [ und vor ! nicht vergessen!

alles darstellen: =obige Formel &" ausBereich" oder eben die komplizierteren mit Blatt- und ggf Dateiname

Kommentar von Iamiam ,

Fürs letzteres hab ich auch mal eine Makroformel gemacht (bezieht sich auf zB links daneben), die stellt das dann zB so dar:

134=SUMME(INDIREKT("Tabelle1!"&"AH4:AH8"))

Wenn Du den Umgang mit einfachen Makros kannst/lernen willst, dann diese µ-Formel:

Function AuchFormelAnzeigenDE(Zelle As Range)
Application.Volatile
AuchFormelAnzeigenDE = Zelle.Value & Zelle.FormulaLocal
End Function

oder englische Formel (aud deutscher):

Function AuchFormelAnzeigenEN(Zelle As Range)
Application.Volatile
AuchFormelAnzeigenEN = Zelle.Value & Zelle.Formula
End Function 'für Übersetzung DE=>EN

Kommentar von Pylo89 ,

Danke für die Mühe, ich habe mich wohl etwas undeutlich ausgedrückt und als Antwort nochmal ein Bild hochgeladen, mit dem meine Fragestellung hoffentlich deutlicher wird.

Kommentar von Iamiam ,

Dein Bild:

wenn die erste Zahl schon 75 ist, weiß ich nicht, wie Du auf eine Summe von 49,2 kommen kannst.

Die Anzahl der Zahleneinträge in einem Bereich bekommt man mit =Anzahl(Bereich), die Anzahl ALLER Einträge  mit =Anzahl2(Bereich)

Kommentar von Pylo89 ,

Nicht =Anzahl, sonder =Summe !

Kommentar von Iamiam ,

schon verstanden, aber Dein x ist doch eine (irgendwie-) Anzahl?

Und Du erklärst nicht, wie Du auf Summe=49,2 kommenkannst, wenn der erste Eintrag schon 75 ist!

Ach Du meine Güte, lese grade Deinen Kommentar zu Ninombres AW:

Auf die Idee, dass x ein gesetzter Faktor ist und kein (ggf Zwischen-)Ergebnis, das ermittelt werden soll, bin ich ebensowenig gekommen wie alle anderen Beantworter!

Expertenantwort
von Oubyi, Community-Experte für Excel, 28

Sorry, aber ich komme leider mit Deiner hochgestochenen Ausdrucksweise nicht klar.
(Ich habe in einer Zelle z.B. nur einen Wert/ ein Ergebnis, keine "Datenmenge" und DAS entspricht dem "Zahlenwert der Formel")
Kannst Du das - für mich - nochmal an einem einfachen Beispiel erklären.
Auch die Formel auf die Du Dich beziehst wäre interessant, falls sie nicht geheim ist.

Kommentar von Pylo89 ,

Danke für die Mühe, ich habe mich wohl etwas undeutlich ausgedrückt und als Antwort nochmal ein Bild hochgeladen, mit dem meine Fragestellung hoffentlich deutlicher wird.

Kommentar von Oubyi ,

Ich schließe mich Ninombres Fragestellung an.

Kommentar von Pylo89 ,

Soll einfach summiert werden (=Summe(A4:C6). Habe wohl einen falschen Screenshot benutzt. Habe die Werte von x=1 und x=2 nicht angepasst. 

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten