Frage von Smilyangel,

Excel Stunden berechnen

HAllo Leute,

ich mal ne Frage zu Excel. Ich müsste Stunden ausgerechnet haben. Aber die Zeiten sind dann z.b von heute 7:00 (A1) bis morgen um 07:00 (A2)..oder von 22:00 (A1) bis 6:00 (A2) wie kann ich das über excel ausrechnen ohne das Datum eingeben zu müssen? das Ergebnis soll in der Zelle A3 erscheinen

kann mir da wer helfen???

Expertenantwort
von Oubyi, Community-Experte für Excel,

Eine Alternative zu Ragnars Idee:
=WENN(UND(A1<>"";B1<>"";A1<>B1);REST(B1-A1;1);1)
Vorteil, denke ich:
Du kannst/ musst die Ergebniszelle als Zeit, also benutzerdefiniert als:

[h]:mm  

formatieren, und kannst dann damit als Zeit weiter rechnen, was bei einer Formatierung als Zahl nicht so ohne weiteres geht.

Antwort
von Ragnar12983,

Schreib mal als Formel:

=WENN(B1-A1<0;B1-A1+1;B1-A1)

Gruß Ragnar

Kommentar von Smilyangel ,

aber der zeigt dann nicht 24 Stunden an.. bie 07:00 bis 07:00.. muss ich das noch speziell formatieren??

Kommentar von Ragnar12983 ,

Zeitangaben gehen halt nur bis 23:59:59 - 24:00 gibt es nicht. Wenn du in Stunden und nicht in Zeitangaben rechnen willst, musst du schreiben

=WENN(B1-A1<=0;B1-A1+1;B1-A1)*24

und die Spalte als Zahl formatieren. Aber auch dann ist bei 24 Stunden Schluss - wenn du 25 Stunden arbeitest, musst du das Datum mit angeben.

Kommentar von Smilyangel ,

bis 24 brauche ich nur.. aba das problem ist, dass der immer nur 00:00 anzeigt. Kann ich das wegbekommen?

Kommentar von Ragnar12983 ,

Wie geschrieben: Nimm die obige Formel und formatiere die Spalte als Zahl.

Kommentar von Smilyangel ,

Danke.. es hat funktioniert ^^

Keine passende Antwort gefunden?

Fragen Sie die Community