Frage von sergnant, 44

Excel Spalte anhand bereits vorhandener Spalte einfügen?

Hallo, folgendes Problem in Excel: Ich habe eine erste Spalte mit aufsteigenden Werten von 1-600. In einer Zweiten Spalte sind zu diesen Werten weitere Informationen hinterlegt. Nun möchte ich in eine dritte Spalte wieder ähnliche Werte von 1-600 einfügen, mit dem Unterschied das diese nicht komplett sind. Gibt es eine Funktion in Excel, dass ich diese Werte anhand der ersten Spalte einfügen kann? D.h. ist beispielsweise der Wert "3" nicht vorhanden, wird eine Zeile freigelassen, nur bei gleichen Werten werden die Informationen eingefügt. Ich hoffe ich konnte mich halbwegs deutlich ausdrücken. M.f.G.

Expertenantwort
von Oubyi, Community-Experte für Excel, 21

Mal sehen, ob ich Dich richtig verstehe.
Angenommen in A1:A600 stehen die Zahlen von 1 bis 600 und in Spalte B daneben stehen Informationen dazu.
In z.B. F1:F50 stehen willkürlich Zahlen zwischen 1 und 600  und in G1:G50 stehen weitere Informationen dazu.
Schreib in C1 diese Formel und kopiere sie runter bis C600:

=WENNFEHLER(INDEX($G$1:$G$50;VERGLEICH(A1;$F$1:$F$50;0));"")

Jetzt werden die Werte aus G in die entsprechenden Zeilen in C eingefügt, die in A die Zahlen aufweisen, die in F stehen.
War das so gemeint?

Wenn nicht, versuche es nochmal zu erklären, vielleicht auf ähnliche Weise, wie ich das Szenario beschrieben habe.

Kommentar von Iamiam ,

vllt zum Verständnis noch ergänzen:

die Zahlen brauchen ja im Ergebnis nicht doppelt aufgeführt zu sein, Hauptsache beide Infospalten beziehen sich auf dieselbe Zahl.die ja schon in A steht.

Hinterher kann die Spalte C kopiert werdren und die Formelergebnisse als WERTE gesammelt eingefügt werden, so dass die Zuordnungen fixiert bleiben.

Wenn Du aber neue Nummern hast, wirds komplizierter!

Kommentar von sergnant ,

Vielen Dank! Genau so war es gemeint und so funktioniert es auch!

Kommentar von Oubyi ,

Freut mich, dass ich helfen konnte ☼

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 31

Du kannst mit ZEILE die Zeilennummer abfragen.
Existenz kannst du mit ZÄHLENWENN(...)>0 prüfen.
Die Abfrage, ob die Zeile frei gelassen werden soll, gestaltest du mit WENN: =WENN(ZÄHLENWENN(...)>0;...;"")

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten