Frage von SirRob, 46

Excel Sheet Problem! Hilfe?

Hey Leute,

ich habe ein Excel Sheet, das wie im Bild aussieht. Nun möchte ich das ganze in ein anderes Excel Sheet mit dem gleichen Layout etc. übernehmen allerdings sollen nun, sobald mehrmals der gleiche Username auftaucht (untereinander, da es sortiert ist), dass die Rolle bei z.B. PSR "CB" und die Rolle bei PH1 "CD" im nächsten Excel Sheet insgesamt in einer Zeile stehen. Natürlich bei dem Usernamen der für diese gilt.

Ich habe das ganze schon mit SVERWEIS probiert, allerdings nimmt dies immer nur den ersten Treffer des Usernamen.

Wäre nett wenn mir jemand helfen könnte =)

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 23

Kannst du den Rollen IDs zuweisen? CD=1, CB=2,...

Dann könntest du die Tabelle auf ein neues Blatt kopieren, alle FALSCH durch 0 ersetzen (Strg + h), alle CD durch 1, CB durch 2,...

Oder per Formel mit dem VERGLEICH: =WENNFEHLER(VERGLEICH(B3;{"CD";"CB";"XY";"ZZ"};0);0)

____

Im nächsten Schritt kannst du mit Datenkonsolidierung spielen (Maximum) oder du legst eine Datenverbindung an. Daten → Verbindungen → Hinzufügen → Nach weiteren Elementen suchen → *.xlsx → aktuelle Arbeitsmappe auswählen → Quelltabelle auswählen (am besten benamter Bereich)

Achte darauf, ob die Überschriften mit kommen. Wenn nicht, musst du in der Verbindungszeichenfolge HDR=NO eintragen.

Schließe die Dialoge. Im Excelsheet wählst du Daten → Vorhandene Verbindungen → Verbindungen in dieser Arbeitsmappe → <die gerade angelegte Verbindung>

Auf der eingefügten Tabelle machst du einen Rechtsklick und fügst eine SQL-Abfrage unter Tabelle → Abfrage bearbeiten ein.

Muster:

select f1, max(f2) as Titel1, max(f3) as Titel2, max(f4) as Titel3, count(*) from unkumuliert group by f1

Wenn du willst, kannst du jetzt die Rollen rückübersetzen. Du kannst die Tabelle auch unter Rechtsklick → Tabelle → In Bereich konvertieren fixieren.

Kommentar von SirRob ,

Danke erstmal für deine ausführliche Antwort, leider sind die "FALSCH" durch eine Funktion erzeugt und können somit nicht mit strg+h ersetzt werden (findet keine Ergebnisse). "CD" "CB" etc. sind ebenfalls mittels dieser Funktion von einem anderen Sheet geholt und können so auch nicht ersetzt werden ...

Kommentar von Suboptimierer ,

In einer Kopie der Daten könntest du sie ersetzen oder in einer Umlenkungsformel (=MachWasMit(Original!A1)).

Kommentar von SirRob ,

Sorry für die doofe Frage, aber wie erstelle ich eine Kopie, die die Funktionen nicht mitnimmt? Strg+c und dann strg+v übernimmt immer die Funktionen.

Kommentar von Suboptimierer ,

Inhalte einfügen... → Werte

Kommentar von SirRob ,

Muss ich an der Abfrage noch etwas ändern? Bekomme eine Fehlermeldung: Die Abfrage oder das Öffnen der Tabelle konnte nicht ausgeführt werden.

Kommentar von Suboptimierer ,

Erstmal super, dass du es bis dahin geschafft hast. Der Rest ist Feintuning.

Versuch es erstmal mit select * from unkumuliert

Keine passende Antwort gefunden?

Fragen Sie die Community