Excel Schaltfläche zur Unterscheidung bei Berechnung?

... komplette Frage anzeigen

4 Antworten

Du musst nicht unbedingt programmieren. Du könntest ein Makro aufzeichnen und dies an eine einzufügende Schaltfläche koppeln.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von himmel200
06.02.2016, 14:59

Kannst du das genauer erklären, wie konkret ich da vorgehen muss?

0
Kommentar von himmel200
20.05.2016, 19:23

Du hast zwar nicht geantwortet aber du bekommst trotzdem die Auszeichnung. Ich habe es nämlich so gemacht.

1

Du verknüpft zB ein Kontrollkästen mit einer Zelle (den Inhalt kann man ja sonst auch so formatieren das diese Hilfzelle nicht stört.

Das Kästchen bekommt den Titel "Zeilen 1+2 einschließen"
Nehmen wir an die zu Summierenden Zahlen stehen in A1:A5
Die Hilfszelle, (angenommen C1) nimmt bei Aktiviertem Kästchen den Wert Wahr an und bei deaktiviertem Falsch.

Dann noch die Summenformel 

=SUMME(A1:A2)*C1+SUMME(A3:A5)

an beliebige Stelle und fertig..

Für andere Anwendungen sind ggf andere Schalter sinniger.

Antwort bewerten Vielen Dank für Deine Bewertung

warum so umständlich? richte einfach eine zweite summenzelle mit der alternativen summierung ein. mehr als mit der maus hin- und herzuspringen anstatt auf einen button, ist das auch nicht.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von himmel200
06.02.2016, 14:59

ja das würde zum gleichen ergebnis führe, aber die aufgabenstellung ist nur repräsentativ für mein problem, ich möchte die programmierung auf jeden fall machen, dass ich sie übergreifend anwenden kann verstehst du?

0

Was möchtest Du wissen?