Frage von himmel200, 62

Excel quasi dynamische Summe, die sich bei Eintrag verschiebt?

Hallo,

ich trage bei Excel laufend meine Ausgaben ein. Ich möchte dass immer 2 Zeilen unter meinem letzten Eintrag die Summe steht, wenn ich jedoch in die leere Zeile zwischen letztem Eintrag und Summe einen neuen Eintrag mache, soll die Summe automatisch wieder eine Zeile nach unten rutschen, sodass immer Abstand von einer Zeile bleibt.

Danke schonmal

Expertenantwort
von Oubyi, Community-Experte für Excel, 45

Wenn es unbedingt SO sein muss, dann beachte Jackies Antwort.
ICH mache es bei solchen Tabellen immer so, dass ich die Summe zwei Zellen ÜBER der Aufstellung anzeigen lasse.
Dann reicht ein einfaches =SUMME(A3:A1000) und außerdem hat man diese Summe immer sofort im Blick, ohne runter scrollen zu müssen.

Kommentar von Iamiam ,

dem kann ich mich nur anschließen.

Wer's noch nicht kennt: man kann einige Titelzeilen fixieren ("einfrieren"): erste Scrollzeile als ganzes (am Zeilenkopf) markieren, Menü Ansicht, Fenster einfrieren (nicht das große neben Zoom -weiß ohnehin nicht, wozu das gut sein soll-, sondern) das kleine daneben, das mit dem kleinen ▼ zum Aufklappen, da drin nochmals Fenster einfrieren anklicken. Die Titrelzeilen sind dann fixiert.

Antwort
von Jackie251, 46

Jede Zelle in Excel kann eine Eingabe oder eine Verarbeitungs/Ausgabe Zelle sein. Dabei können Zellen zwar Daten aus anderen Zellen abfragen jedoch anderen Zellen keine Anweisungen geben, das diese machen sollen.

Von daher ist dein Wunsch so nicht vorgesehen.

Optisch liese sich der EIndruck zb erreichen, wenn in allen Zellen unter deine Eingabe die Summe berechnet wird, jedoch der Zelleninhalt ausgeblendet wird, wenn es sich nicht 2 zellen vorher leer sind.
Oder das die Summe eben nur gebildet wird wenn, diese Bedingung erfüllt ist.
Nachteil ist, dass man auf diese Weise mit neuen Eingaben dann immer die Formel überschreibt (man braucht sie dann dort ja auch nicht mehr).
Ansonsten sind natürlich auch VBA Lösungen möglich - vollautomatisch wird aber schwer.

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 31

Schreibe in die Spalte unter deiner letzten Eingabe (z. B. C5)

=WENN(UND(C3<>"";C4="");SUMME($C$2:C3);"")

(ungetestet)

Zieh die Formel so weit nach unten, wie du dir sicher bist, niemals anzukommen.

Keine passende Antwort gefunden?

Fragen Sie die Community