Excel Programmierung Text in Klammern erkennen?

... komplette Frage anzeigen

2 Antworten

Kein Problem.
Angenommen, Deine Texte stehen in Spalte A, ab A1, dann in B1 diese Formel und runterkopieren

=TEIL(A1;FINDEN("(";A1)+1;FINDEN(")";A1)-FINDEN("(";A1)-1)

Anschließend kannst Du, wenn Du willst, Spalte B markieren, Kopieren und sofort wieder über Rechtsklick/ Inhalte einfügen--> Werte, die Formeln durch den reinen Text ersetzen. Danach kannst Du Spalte A komplett löschen und hast nur noch den Klammertext übrig.
Wenn noch etwas unklar ist, frage gezielt nach, dann helfe ich gerne weiter.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Sophieleli
23.10.2016, 13:45

Vielen Dank! Kann ich das auch über die Formel Wennfehler machen? Was muss ich dann bei Wert und Wert_falls_Fehler eingeben? Danke! 

0
=WENNFEHLER(TEIL(A1;FINDEN("(";A1)+1;FINDEN(")";A1)-FINDEN("(";A1)-1);"")

das heißt aber, dass bei Inhalten ohne () gar nichts angezeigt wird. Soll das so sein?

Mit FINDEN kann man die Position bestimmen, wo ( bzw. ) stehen.
Mit TEIL nimmt man dann den Text ab ( bis )
Mit +1 und -1 wird verhindert, dass ( bzw. ) auch angezeigt werden.
Bei Fragen / Unklarheiten einfach nachhaken, denn wenn Du damit weiterarbeiten willst, solltest Du die Formel nachvollziehen können.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
22.10.2016, 18:49

DH!
Schon wieder bist Du schneller als ich.
Und natürlich mit der gleichen Formel wie ich (plus dem WENNFEHLER())

2
Kommentar von Iamiam
22.10.2016, 19:15

und es kann so nur die erste Klammer ausgewertet werden, falls es mehrere gibt (könnte durch unüberlegte Formlierung verloren gegangen sein).

Falls zwei Klammern auftreten wirds deutlich länger:

=WENNFEHLER(TEIL(A1;FINDEN("(";A1)+1;FINDEN(")";A1)-FINDEN("(";A1)-1);"")&WENNFEHLER(TEIL(A1;FINDEN("(";WECHSELN(A1;"(";"_";1))+1;
FINDEN(")";WECHSELN(A1;")";"_";1))-FINDEN("(";WECHSELN(A1;"(";"_";1))-1);"")

"_" ist dabei lediglich ein Platzhalter, damit die Länge gleich bleibt.

Für noch mehr Klammern muss man die Lösung nochmals anders aufbauen (2. und 3. Auftreten durch andere Zeichen ersetzen und dann danach suchen), geht, aber mach ich jetzt nicht mehr.

5
Kommentar von Sophieleli
23.10.2016, 13:47

Vielen Dank! Kann ich das auch über die Formel Wennfehler machen? Was muss ich dann bei Wert und Wert_falls_Fehler eingeben? Danke! 

0