Frage von visitar, 57

EXCEL, Problem mit Funktion =ZÄHLENWENNS?

Liebe EXCELperten, ich nutze die Funktion =ZÄHLENWENNS um im Bereich A3:A1514 zu ermitteln, wie oft eine bestimmte ZEITDAUER [hh:mm:ss] auftaucht, die größer als "A" und kleiner als "B" ist.

Die Funktion arbeitet perfekt wenn sie so geschrieben ist: =ZÄHLENWENNS($A$3:$A$1514;">01:05:59";$A$3:$A$1514;"<01:07:00")

Da ich diese Formel aber mit ca 500 verschiedenen ">" / "<" - Werten benötige, ist die Erstellung von Hand natürlich sehr mühsam. In den Spalten "F" und "G" habe ich mir die ">" / "<" - Werte automatisch anlegen lassen und die obige Formel folgendermaßen umgeschrieben:

=ZÄHLENWENNS($A$3:$A$1514;>F3;$A$3:$A$1514;(F3);$A$3:$A$1514;<(G3)) oder =ZÄHLENWENNS($A$3:$A$1514;">F3";$A$3:$A$1514;"<G3") oder =ZÄHLENWENNS($A$3:$A$1514;">(F3)";$A$3:$A$1514;"<(G3)")

Diese Formeln werden aber als FEHLERHAFT von Excel zurückgewiesen oder liefern ein falsches Ergebnis: "0"

Nun zur Frage: Wie muss die Formel geschrieben werden, damit EXCEL die Bedingungen aus den Spalten F und G in der Formel akzeptiert ?
Alle Zeitangaben sind als [hh:mm:ss] formatiert (Zellen formatieren, Benutzerdefiniert)

Vielen Dank für Eure Mühe !

Antwort
von visitar, 26

Die Lösung des Problems ist simpel und war (etwas versteckt) in der Excel-Online-Hilfe zu finden.


Die Bedingung mit Zellbezug muss zum Beispiel folgende Syntax haben:

">"&F3

- Der Vergleichsoperator steht in Anführungszeichen "<" ">" "="

- Dem Zellbezug steht ein -> & <- voran, dann erkennt Excel, dass es sich um einen Zellbezug handelt

Die Formel lautet also vollständig:
=ZÄHLENWENNS($A$3:$A$1514;">"&F3;$A$3:$A$1514;"<"&G3)

Die Funktionsformel sucht im Bereich "A3 bis A1514" nach der Häufigkeit des Auftretens eines Eintrages, der größer ist als der Wert in "Zelle F3" und kleiner als der Wert in "Zelle G3"

Antwort
von 486teraccount, 40

sorry hab mist geschrieben...

Zellen formatieren wahrscheinlich liegts daran

Kommentar von visitar ,

Sorry ! NEIN !
Aus der EXCEL-Hilfe:

"Syntax

ZÄHLENWENNS(Kriterienbereich1;Kriterien1;[Kriterienbereich2; Kriterien2]…)

Die Syntax der Funktion ZÄHLENWENNS weist die folgenden Argumente auf:

Kriterienbereich1    Erforderlich. Der erste Bereich, in dem die zugehörigen Kriterien ausgewertet werden sollen.

Kriterien1    Erforderlich. Die Kriterien in Form einer Zahl, eines Ausdrucks, Zellbezugs oder Texts, mit denen definiert wird, welche Zellen gezählt werden. Kriterien können beispielsweise als 32, ">32", B4, "Äpfel" oder "32" angegeben werden.

Kriterienbereich2;Kriterien2; ...    Optional. Zusätzliche Bereiche und deren zugehörige Kriterien. Es sind bis zu 127 Bereich/Kriterien-Paare zulässig.

Wichtig : Jeder zusätzliche Bereich muss dieselbe Anzahl von Zeilen und Spalten wie das Argument Kriterienbereich1 haben. Die Bereiche müssen nicht direkt nebeneinander liegen."

Kommentar von visitar ,

Sorry:

hab meinen Kommentar (Auszug aus der Excel-Hilfe) löschen wollen weil Du deinen Irrtum schneller gesehen hast als ich antworten konnte.
Leider war die Zeit zum Bearbeiten zu schnell abgelaufen ! Sorry !

Die Formatierung werde ich prüfen und auch mal einen Test mit simplem Text und Zellbezug machen

Kommentar von visitar ,

Versuch mit neuer Tabelle:
=ZÄHLENWENNS($J$5:$J$21;">0";$J$5:$J$21;"<2")
ergibt ein fehlerloses Ergebnis.

=ZÄHLENWENNS($J$5:$J$21;M5)
(M5 ist ein Zellbezug) ergibt ein fehlerloses Ergebnis

=ZÄHLENWENNS($J$5:$J$21;>M5)
wird jedoch als fehlerhafte Formel zurückgewiesen

EXCEL nimmt bei Zellbezügen die Vergleichsoperatoren "<" ">" "=" scheinbar nicht an.

Jetzt  wäre ein WORKAROUND hilfreich.

Kommentar von Oubyi ,

Dann "hänge ich mich mal kurz rein".
Ich habe jetzt nur Diesen Kommentar gelesen.
Die letzte Formel würde SO funktionieren:

=ZÄHLENWENNS($J$5:$J$21;">"&M5)

Hilft Dir das weiter?

Kommentar von visitar ,

Danke Oubyi !
"Dummerweise" sehe ich Deinen Kommentar erst jetzt, nachdem ich diese Lösung eben durch aufmerksames Studieren der Online-Hilfe selbst erkannt habe.
DANKE dennoch für Deine Hilfe ! Deine Antwort war perfekt !

Kommentar von Oubyi ,

Gern geschehen ☼
Danke für die Rückmeldung.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten