Frage von Dennis71, 63

Excel Namen zählen wenn Zahlenwert eingetragen wird?

Hallo, ich möchte in Excel eine Übersicht erstellen, wo aus einem Bestimmten Bereich ermittelt wird wie oft ein Name vorkommt, die Besonderheit ist, dass der Name erst gezählt werden soll sobald ich einen Zahlen Wert über 1 eingetragen habe.

BSP: A1: Name B1: Einkaufswert 10 C1: Verkaufswert (leer) D1: Gewinn (leer) A2: Name B2: Einkaufswert 10 C2: Verkaufswert 15 D2: Gewinn 5 A3: Name B3: Einkaufswert 10 C3: Verkaufswert (leer) D3: Gewinn (leer) A4: Name B4: Einkaufswert 10 C4: Verkaufswert (leer) D4: Gewinn (leer) A5: Name B5: Einkaufswert 10 C5: Verkaufswert 15 D5: Gewinn 5

Nun sieht man das Name zwei mal in dem Bereich einen Wert über 1 erreicht hat und das möchte ich mit Excel automatisch machen.

Kann mir jemand helfen ?

Danke im Voraus.

Expertenantwort
von DeeDee07, Community-Experte für Excel, 48

Das kannst du mit ZÄHLENWENNS machen. Du schreibst nicht, in welchem Bereich die Zahl größer 1 sein muss, um das Vorkommen des Namens zu zählen, deshalb mal ein Beispiel:

=ZÄHLENWENNS(A:A;"Name";B:B;">1")

Diese Formel zählt alle Einträge, bei denen in Spalte A "Name" UND in Spalte B ein Wert größer als 1 steht.

Kommentar von Dennis71 ,

Das ist die Lösung! Danke! Nun noch eine Frage, gibt es die Möglichkeit sich eine TOP 10 anzeigen zu lassen ? Da ich im Bereich Name verschiedene habe wäre es interessant für mich zu sehen das z.b. Sammy 10 mal über 1 hat und Kathie nur 2 mal

Kommentar von Iamiam ,

Entferne aus der Zahlenspalte(D?) ALLE TEXTEinträge (auch Überschriften:mach diese ggf in ein Textfeld oder in die Spalte daneben so, dass der Eintrag in die Zahlenspalte hineinragt, konkret: schreibe in C1 Verkaufswert____Gewinn mit so vielen __, dass Gewinn optisch in Spalte D steht.

Mach Hilfsspalten mit der Formel (ich hoffe, Spalten K:M sind frei):

in K2: =WENNFEHLER(WENN(ZÄHLENWENN(A$1:A2;A2)=1;SUMMENPRODUKT((A:A=A2)*D:D)+ZEILE(A2)/1000000000;0);0)

runterziehen über gesamte Listenlänge (wenn Du die Formel erklärt haben willst, frag nach, hab im Moment keine Zeit dafür)

In L1: =KGRÖSSTE(K:K;ZEILE())

in M1: =INDEX(A:A;VERGLEICH(L1;K:K;0))

L1 und M1 gemeinsam runterziehen, das sind die größten Beträge und die zugehörigen Namen. Bei gleichen Beträgen erscheint der aus der höheren Zeilennummer zuerst,.


Kommentar von Iamiam ,

ich hab vergessen, in meine Formeln die Bedingung >1 einzuarbeiten, bin ich heute aber zu müde dazu, vllt reicht ja auch die un-bedingte Summierung

Kommentar von Iamiam ,

Geht ganz einfach, lediglich Summenprodukt um den Faktor (d:d>=1) erweitern!
in K2: =Wennfehler(Wenn(Zählenwenn(A$1:A2;A2)=1;Summenprodukt((A:A=A2)*(d:d>=1)*D:D)+Zeile(A2)/1000000000;0);0)

Expertenantwort
von Iamiam, Community-Experte für Excel, 31

Formal, damit es eine Hilfreichste geben kann!

Kommentar von DeeDee07 ,

Wobei hier diese Antwort ausgezeichnet werden sollte. Dein Beitrag geht weit über meinen hinaus.

Kommentar von Iamiam ,

danke, ich bin aber dafür, dass die AW ausgezeichnet wird, in der die brauchbarste Lösung steht, für jeden, der später mal in der Frage nachschaut. (auch wenn das wenig genutzt wird). Und Punkte brauch ich nicht.

Keine passende Antwort gefunden?

Fragen Sie die Community