Frage von Skyfall2013, 54

Excel namen rausschreiben per 0/1?

ich habe eine Exceltabelle mit vielen namen und in der spalte neben den rahmen steht eine 1 oder eine 0. Ich will jetzt jeden Namen mit einer 1 in eine neue Zelle kopieren. ist das möglich? Es muss automatisch geschehen denn die Nullen und Einsen sind abhängig von anderen faktoren.

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Oubyi, Community-Experte für Excel, 17

Angenommen in Spalte A stehen Deine Namen und in Spalte B steht 1 oder 0 (als Zahl), dann schreibe z.B. in D1 diese Formel und kopiere sie runter, soweit wie nötig:

{=WENNFEHLER(INDEX($A$1:$A$1000;KKLEINSTE(WENN($B$1:$B$1000=1;ZEILE($B$1:$B$1000));ZEILE(A1)));"")}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Klappt es?


Kommentar von Oubyi ,

Danke fürs

Expertenantwort
von Ninombre, Community-Experte für Excel, 25

Pivot Tabelle wäre eine Variante, aber nicht unbedingt ideal wenn die Daten noch weiter verarbeitet werden sollen. 

Antwort
von ernkie, 21

Eine Wenn-Formel löst Dein Problem. Siehe Lösung in Grafik

Kommentar von Jackie251 ,

das funktioniert nie sauber, wie man schon am ergebnis sieht.

Bei automatischer Übernahme in eine neue Liste würden wie hier zu sehen, immer lücken entstehen. man müsste händisch nacharbeiten und damit sind nachträglichere änderungen kaum möglich

oubyi zeigt die richtige lösung

Antwort
von CreeperStyle, 30

Dies müsste möglich sein in dem Du in der Zelle in der der Name stehen soll einen Befehl anwendet der nach einer 1 oder 0 in der entsprechenden anderen Zelle sucht und somit einsortiert oder nicht.
ZB. WENN([Zelle1]=1;[Zelle 1];" ")
So ähnlich.

Antwort
von CrEdo85, 21

Am einfachsten ist es per vba lösen: mit einer for-schleife alle namem durchgehen, per if-bedingung prüfen, ob zelle nebendran eine 1 hat, wenn ja - kopieren.

Kommentar von Oubyi ,

Das "einfachste" ist das imho NICHT!

Kommentar von Jackie251 ,

es ist nicht nur nicht am einfachsten, spätestens seit der Formatänderung mit den 2007er Versionen sind in der Geschäftswelt Makro Dateien noch schwieriger geworden. Natürlich innerhalb eines Bereiches kann man damit viel machen. In Kontakt mit anderen verbreiten aber *.xlsm Dateien irgendwas zwischen Verwirrung und Panik. Daher sollte man VBA auf Anwendungen beschränken wo es unumgänglich ist.

Keine passende Antwort gefunden?

Fragen Sie die Community