Excel: Mittelwert errechnen von Zellen, in denen bereits eine Wenn-Funktion ist?

... komplette Frage anzeigen

1 Antwort

Das sollte normalerweise funktionieren.

Schlägt auch =MITTELWERT(B5) fehl?

Hast du ein Beispiel für eine WENN-Funktion in Spalte B?
Irgendwelche Matrixfunktionen in B5:B11?
Hast du Filter oder Ähnliches gesetzt?

In welche Zelle schreibst du die MITTELWERT-Funktion?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von nothing1990
10.03.2016, 14:24

Ja, =MITTELWERT(B5) schlägt auch fehl.

Ich füge mal die ganze Formel ein, die ich jeder der Zellen B5:B11 eingefügt habe mit entsprechender Zelländerung:

=WENN(UND(C5>=28;C5<=30);"1";WENN(UND(C5>=24;C5<=27);"2"; WENN(UND(C5>=20;C5<=23);"3";WENN(UND(C5>=15;C5<=19);"4";WENN(UND(C5>=9;C5<=14);"5";WENN(UND(C5>=1;C5<=8);"6";"-"))))))

Die MITTELWERT-Funktion schreibe ich in C14.

0
Kommentar von Ghanasoccer
10.03.2016, 14:26

Microsoft Excel zeigt den Fehler "#DIV/0!" an, wenn eine Zahl durch Null (0) geteilt werden soll. Dies geschieht, wenn Sie eine einfache Formel, wie =5/0, eingeben oder wenn eine Formel auf eine Zelle mit dem Wert 0 oder eine leere Zelle verweist.

Also

=WENNFEHLER(B2=0;"") irgendwo halt anpassen.

0

Was möchtest Du wissen?