Excel, Mehrere Wenn-Verknüpfungen mit mehreren Werten?

... komplette Frage anzeigen

4 Antworten

Vor der Frage immer erst drüber nachdenken, wie die genaue Aufgabenstellung ist. Hier haben sich einige Leute sinnlos einen Kopf gemacht.

Wie ich in einem Kommentar jetzt lese, soll im Endeffekt nur gerüft werden, ob die letzte befüllte Zelle in Spalte B ein "X" enthält oder etwas anderes.

Dann so... als Matrixformel, also ohne {} und abschließen mit STRG + Shift + Enter.

{=WENN(INDEX(B2:B999;MAX((B2:B999<>"")*ZEILE(1:998)))="X";0;1)}
Antwort bewerten Vielen Dank für Deine Bewertung

Was soll denn in B1 stehen, wenn die Zellen darunter weder leer sind, noch dass irgendwo dort "x" oder "Text" seht?
Was soll in B1 stehen, wenn in B2 "Text" steht und in B3 "X", also was soll bei Bedingungskollision passieren.

Grundsätzlich kannst du mit WENN und ZÄHLENWENN arbeiten.

=WENN(ODER(ZÄHLENWENN(B2:B1000;"X")>0;...);0;1)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Stoffn
16.06.2016, 13:13

In B1 soll entweder 0 oder 1 stehen. Wenn die Zellen unterhalb "Text" beinhalten oder leer sind (also nix drin steht), dann 1. Wird allerdings in eine Zelle ein x geschrieben, soll es wieder auf 0 gehen. Das x hebt sozusagen den "Text" auf. Und standardmäßig (also falls die Zellen leer sind) soll eben eine 1 da stehen.

0
=WENN(ZÄHLENWENN(B2:B99;"X")>0;0;1)
Antwort bewerten Vielen Dank für Deine Bewertung

Da nur 0 oder 1 ausgegeben werden sollen, kann man sich sogar das WENN... sparen:

=(ZÄHLENWENN(B2:B1000;"x")=0)*1

Antwort bewerten Vielen Dank für Deine Bewertung