Frage von NiXeroZ, 28

Excel Makro/Formel von Tabelle auf andere Seite kopieren?

Hallo Community

Ich bräuchte ein bisschen Hilfe in Excel. Folgende Situation:

2 Blätter: Ein Blatt mit einer Tabelle/Liste und ein Blatt als Blatt mit A4 Format (zum ausdrucken) Siehe Bilder

Nun möchte ich, wenn ich auf dem A4 Blatt "Übersicht" bei "Auftragsnummer" eine Nummer angebe, welches in der Liste ist, z.B. "20160905-1234", dass sich die restlichen Zellen ("Datum, Kosten, Käufer , Verkäufer) automatisch mit den entsprechenden Daten von der Tabelle ergänzen. So das ich jeweils nur die Auftragsnummer eingeben muss und sich der Rest automatisch vervollständigt, damit man es ausdrucken könnte, ohne dabei immer alles abzuschreiben.

Würde das irgendwie mit Formeln oder Makros gehen? Ich kenne nur die Basics von Excel und leider nicht solche komplizierten Abläufe ^^

Ich hoffe ich konnte es verständlich erklären :) Vielen Dank für eure Hilfe

Grüsse

NiXeroZ

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 28

Das ist ein Fall für sverweis. Die Bilder hängen leider nicht an der Frage, daher kann ich keine konkrete Formel nennen. Das ganze Thema sverweis ist aber bspw. hier gut erläutert:

http://www.online-excel.de/excel/singsel.php?f=9

Kommentar von NiXeroZ ,

Upps... Ich habe noch dran gedacht und schon wieder vergessen.... sry lade es gleich hoch

Kommentar von Ninombre ,

ok, Bild ist da - aber da fehlen zwei entscheidende Dinge: Wie dieses Tabellenblatt heißt und die Spaltenüberschriften. Den Namen des auszudruckenden Blatts hast Du genannt (der ist aber nicht relevant).

Ist egal, ich nehme einfach bestimmte Werte an, die Du dann änderst:

=SVERWEIS(B3;Übersicht!A:E;2;FALSCH)

D6 ist die Zelle auf der Seite zum Ausdrucken, in der die Auftragsnummer steht

Übersicht ist der Name der Tabelle auf dem Screenshot, wo also Name, Datum, Preis etc. stehen

Sverweis sucht nach dem Wert in B3 - es wird in Spalte A gesucht. Mit der fettgedruckten Zahl legst Du fest, aus welche Spalte das Ergebnis genommen wird. 2 wäre die 2. Spalte aus dem definierten Bereich A:E, also Spalte B. Das liefert bei Deinem Beispiel das Datum. Machst Du aus der 2 eine 4 kommt das Ergebnis aus Spalte D, also der Käufer.
Das ist also die einzige Änderung die Du in der Formel vornehmen musst, um die unterschiedlichen Angaben zu bekommen.

Kommentar von NiXeroZ ,

Das Blatt mit der Tabelle heisst "Liste" und das Blatt mit der Übersicht "Blatt"

D6 ist die Zelle auf der Seite zum Ausdrucken, in der die Auftragsnummer steht

Wo kommt D6 hin (In der Formel)?

Kommentar von NiXeroZ ,

Hier hätte ich jetzt nochmal ein Screenshot mit den Namen + Spaltenüberschriften: http://imgur.com/a/oGN8W

Sorry, bin ein bisschen müde und verpeilt

Entschuldigung für die ganzen Umständen

Kommentar von NiXeroZ ,

Wie in der Frage beschrieben, funktioniert mit sverweis, dass ich in der Übersicht neben "Auftragsnummer", manuell die Nummer eingeben kann (z.B. wenn man sehr viele Daten in der Tabelle hat und so einfacher suchen kann) und dann eben die restlichen Daten aus der gleichen Zeile der Tabelle automatisch nach der Eingabe (oder per Knopf) in die Übersicht einfügt?

Kommentar von NiXeroZ ,

Diesen Kommentar kannst du ignorieren, ich habe den geschrieben, während du die Antwort geschrieben bzw. abgeschickt hast ^^

Kommentar von Ninombre ,

D6 kannst Du vergessen, das hatte ich geschrieben als völlig frei erfundenes Beispiel, weil zu dem Zeitpunkt das zweite Bild noch nicht da war. B4 ist ja die Zelle auf dem Tabellenblatt "Übersicht" wo die Auftragsnummer steht. Die musst Du schon manuell eintragen.

In die anderen Zellen auf "Übersicht" kannst Du die sverweis-Formel verwenden.

=SVERWEIS(B4;Liste!A:E;2;FALSCH)

und jeweils diese 2 erhöhen auf 3, 4, 5

An dieser Stelle aber ein ganz anderer Ansatz: Sollen alle die Datensätze aus "Liste" gedruckt werden? Das wäre mit einem Serienbrief in Word mit Datenbasis in Excel einfacher erledigt. Sagt Dir das Stichwort was?

Kommentar von DeeDee07 ,

DH!

Kommentar von NiXeroZ ,

Nein, es ist halt eher für den Übersicht gedacht, damit man z.B. Ende Monat sehen könnte wie viel ausgeben wurde und notfalls die Details von einem Auftrag sehen könnte Vielen Dank für deine Hilfe

Antwort
von NiXeroZ, 17

Hier die Bilder, sry ich habe die direkt wieder vergessen... 

Keine passende Antwort gefunden?

Fragen Sie die Community