Excel Lösung: gleichen Wert aus anderer Tabelle erkennen und zugehörigen Wert nutzen?

... komplette Frage anzeigen

4 Antworten

Wozu brauchst du da ein Pivottable?
Der Rechenweg ist doch klar. Ein Pivotable ist nur für ergebnisorientierte Lösungen mit unbekanntem Rechenweg sinnig.

Du brauchst nichts weiter also deine Liste mit den Läufern und die Anzahl der gelaufenen Runden

= Zählewenn("Liste mit Runden";Nummer dieses Läufers)

Schon hast du in deiner Übersicht zu jeder Läufernummer und Name und Spende je Runde, die Anzahl der Runden. Damit die Spende berechnen ist dann trivial ;-)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
22.03.2017, 18:39

Danke für den Stern

0

Ich würde es anders machen.

Ein Tabellenblatt1, wo du immer die Startnummer einträgst, die gerade eine Runde gelaufen hat (in meinem Beispiel stehen sie alle untereinander in Spalte A)

Zweites Tabellenblatt2, wo die Eigentliche Übersicht zu sehen ist:

Liste jede Startnummer untereinander auf, mach eine Spalte mit Namen "Rundenanzahl" eine Spalte mit Namen "Betrag pro Runde" und eine Spalte "Spendenbetrag"

Die Datei, wo der "Betrag pro Runde" steht heißt bei mir jetzt "BetragproRunde.xlsx". In Spalte A steht die Startnummer, in Spalte B der Betrag

So sieht dann deine Übersichtsseite aus, für Zeile 1. Formeln einfach runterziehen und links die Startnummern ergänzen.

Startnummer  Rundenanzahl                            Betrag pro Runde                                                                                Spendenbetrag
1 =ZÄHLENWENN(Tabelle1!$A:$A;Tabelle2!A2) =INDEX([BetragproRunde.xlsx]Tabelle1!$B:$B;VERGLEICH(A2;[BetragproRunde.xlsx]Tabelle1!$A:$A;0)) =A1*B1

So würde ich es machen.

Über Zählenwenn (Rundenanzahl) erhälst du die Anzahl, wie oft die Startnummer auf Tabelle1 eingetragen wurde (Rundeanzahl eben)

Über Index und Vergleich, (du kannst, wie zu sehen, auf ein anderes Arbeitsblatt verweisen) bekommst du dann den Betrag pro Runde für die jeweilige Startnummer.

Antwort bewerten Vielen Dank für Deine Bewertung

Klar geht das.

Gehe mit der Formel "Zählenwenns" vor und lass die Kriterien zusammen zählen.

Dann dieses Ergebnis mit der Spendensumme pro Runde multiplizieren und du hast das gesamt gespendete Geld.

Antwort bewerten Vielen Dank für Deine Bewertung

Danke, so hat es funktioniert. Klasse

Antwort bewerten Vielen Dank für Deine Bewertung