Frage von Kalive, 47

Excel-Liste: wie sortiere ich mehrere Zeilen nach einem Wert?

Bitte angehängtes Bild beachten: Mir liegt eine solche Liste vor mit mehr als 4.000 Datensätzen. Eine Farbe = eine Firma. Die Liste soll nach Umsatz sortiert werden, dabei dürfen die Ansprechpartner nicht verschwinden und logischerweise sollen pro Firma alle dazugehörigen Zeilen in einem "Block" stehen.

Zellen verbinden ist nicht, da verschwinden die Werte. Ich habe keinen Ansatz und Inet hilft auch nicht. Wer kennt sich aus?

Expertenantwort
von Ninombre, Community-Experte für Excel, 11

bild wäre wirklich hilfreich... nun musst Du halt prüfen, ob mein Bild auch Deiner Tabelle entspricht.

Ich würde zwei Hilfsspalte zum Sortieren verwenden, wenn Du nicht nur nach Umsatz sortieren, sondern auch die Reihenfolge innerhalb einer Firma beibehalten willst.

Sortierspalte 1 =WENN(A2<>A1;B2;D1) und runterziehen

Sortierspalte 2 =WENN(A2<>A1;A2&"_"&ZEILE(A2);E1&"_"&ZEILE(A2))

Das ganze kopieren, als Werte einfügen. Dann über das benutzerdefinierte Sortieren erst nach Sortierspalte 1, dann nach Sortierspalte 2

Antwort
von ErsterSchnee, 38

Oben auf eine Spalte klicken (also A, B, C usw.), dann oben rechts auf "sortieren von A-Z" und dann auf "Markierung erweitern".

Antwort
von noname68, 39

du markierst alle zeilen und wählst dann "benutzerdefiniertes sortieren". dort kannst du nach allen spalten sortieren, z.b. nach dem umsatz (auf- oder absteigend) oder alphabetisch nach namen usw.

alle zeilen- und zelleninhalte bleiben dabei erhalten


Kommentar von Kalive ,

Wenn ich nach Umsatz sortiere gehen aber die Zeilen mit den Ansprechpartnern, wo als Umsatz "0" hinterlegt ist, verloren

Kommentar von noname68 ,

nein, wenn du sortierst, wird nur sortiert und nichts gelöscht. die zeilen mut null umsatz stehen dann nur am unteren ende; oder oben, je nachdem, ob du auf- oder absteigend sortieren lässt.

wichtig ist, dass du zuerst alle zeilen (!) markierst, sonst geraten die zellen- oder zeileninhalte durcheinander. klicke dazu mit der maus auf die linke zeilennummern-spalte und ziehe die maus dann mit gedrückter linker taste so weit nach unten, wie du sortieren willst.

Kommentar von Kalive ,

ja, und genau das ist das Problem. Die firmeninternen Inhalte, also jede Zeile mit und ohne Umsatz, müssen untereinander stehen. Ansonsten macht das keinen Sinn. Ich muss die Firmen nach Umsatz sortieren und trotzdem alle Ansprechpartner untereinander stehen haben.

Antwort
von Funfroc, 15

Hallo,

offensichtlich ist die andere Frage gelöscht wurden, obwohl hier wieder das gleiche steht und auch ohne Bild...

Also nochmal hier: Lege eine Hilfsspalte an, in der du mit Summewennfunktion bei jedem Ansprechpartner den Gesamtumsatz der Firma hinterlegst.

Dann kannst du die Sortierung nach dieser Hilfsspalte durchführen.

LG, Chris

Edit: wenn du jetzt noch ein Bild hochlädst, kann man dir vielleicht auch bei der Summewennformel helfen :-)

Antwort
von augsburgchris, 17

Da wirst du um eine Hilfsspalte nicht herumkommen.

Keine passende Antwort gefunden?

Fragen Sie die Community