Frage von mathsfan, 67

Excel: kleinste noch nicht vorkommende Zahl?

Hallo, Ich möchte bei Excel fragen, welches die kleinste Zahl ist, die in dieser Reihe/Spalte noch nicht vorgekommen ist. Wie geht das?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Iamiam, Community-Experte für Excel, 31

Solltest du eine Lücke in einer Auflistung von natürlichen Zahlen meinen:

in EINER Formel hab ichs nicht hingekriegt (obwohls einfach aussieht, aber vllt steh ich ja auf dem Schlauch), aber wenn die Auflistung in einer Spalte(A) ist, dann rechts daneben (in B1) die Formel:

=Wennfehler(1/(1/Wennfehler(Vergleich(A1+1;$A$1:$A$14;0)*0;A1+1));"-")

und in C1: =Min(C1:C14)

wichtig: das "-" muss ein Text sein, da in xl Text>alle Zahlen.

Du könntest natürlich auch zB 1E99 schreiben, aber das stört die Optik.

Kommentar von Iamiam ,

jetzt hab ich doch noch eine {Matrix}formel draus ableiten können:

{=MIN(WENNFEHLER(1/(1/WENNFEHLER(VERGLEICH(A1A14+1;$A$1:$A$14;0)*0;A1:A14+1));"-"))}

Bei negativen Zahlen wird die kleinste fehlende Zahl angezeigt, (die ohne -Zeichen also die Größte wäre)

in beiden Fällen: sollte jedoch die Null fehlen: die kann so nicht erfasst werden, da 1/0 ebenfalls Fehler ergibt. 0 müsste man ganz speziell separat suchen, sie kann auch nur mit Zusatzformeln von leeren Zellen unterschieden werden.

=Summenprodukt(istzahl(A1:A14)*(A1:A14=0)) müsste eine 1 ergeben, wenn 0 vorhanden.

Achtung: Die obere Formel ist eine Matrixformel! Die geschweiften {Klammern} NICHT miteingeben, sondern die Formel anstatt mit einfachem Enter mit der Kombination (gleichzeitig) Strg+Shift+Enter abschließen (nach jeder Neubearbeitung wieder!). Die {Klammern} entstehen dann automatisch.

Schreibtechnisch nimmst Du am besten die rechte Strg- und Umschalttaste, dann gehts mit einer Hand und lässt sich auch leichter merken!  - - -

Noch ein Tipp: Wenn Du in der Bearbeitungszeile einen selbständigen Formelteil markierst und F9 drückst, erhältst Du ein(e) Ergebnis{liste}. Allerdings dann die Zelle mit Esc verlassen (oder rückgängig machen), Enter würde das gezeigte Ergebnis festschreiben! Vorläufig kurze Bereiche festlegen! (mindestens 2 Zellen markieren, Strg+h, ... ersetzen durch ...) --

Kommentar von mathsfan ,

nja, also der Plan ist, ne Tabelle zu haben... Ich wähle eine beliebige zelle aus, und dort steht der kleinstmögliche wert, der weder darüber noch links davon bereits vorkommt. (Die bereiche müssen natürlich schon ausgefüllt sein) Negative Zahlen müssen nicht inkludiert werden, gesucht sind nur nichtnegative zahlen, also alles ab 0 aufwärts! Aber deine Vorschläge sind schon mal produktiv! Danke!

Kommentar von Iamiam ,

ich denke, die Matrixformel ist genau das, was Du brauchst (mit Ausnahme 0 und nur für eine Spalte). Probiers doch einfach aus mit angepassten Adressen, und nochmal: Strg+Shift+Enter nicht vergessen!

Kommentar von Iamiam ,

Oder suchst du die Position der Lücke?

Direkt in die Lücke rein geht nicht, das gäbe Zirkelbezug, egal, wie die Formel lautet! (und würde im Moment der Anzeige schon nicht mehr stimmen!)

Kommentar von Iamiam ,

wenn es mehr als eine Spalte sein soll (zB ein flächiger Bereich, könnte man vllt was mit Zählenwenn anstatt Vergleich machen, aber die Sache ist und bleibt schwierig. (die Ausarbeitung hat mich mehrere Stunden beansprucht, bis alles gestimmt hat!)

Kommentar von Iamiam ,

danke für den * !

Antwort
von PWolff, 40

Wenn du die kleinste ganze Zahl meinst, die größer ist als die höchste bisher eingetragene Zahl:

Für Spalte C und Zelle C6 würde das so aussehen:

=MAX(C$1:C5)+1

Expertenantwort
von Ninombre, Community-Experte für Excel, 36

ich rate mit: Kleinste ganze Zahl, quasi kleinste gefundene Zahl - 1?  Das funktioniert so aber nur wenn auch nur ganze Zahlen in der Spalte stehen.

=WENN(MIN(B:B)-1>0;MIN(B:B)-1;"Kein gültiges Ergebnis")

Kommentar von Ortogonn ,

Kleine Verkürzung, wenn die Frage auf natürliche Zahlen N abzielt (hierbei Unterstellung, dass auch nur solche vorkommen). Falls 0 enthalten ist, wird diese als FALSCH interpretiert.

=WENN(MIN(B:B);MIN(B:B)-1;"Kein gültiges Ergebnis")

Antwort
von ernkie, 24

Nimm die Formel =MIN(Dein Bereich)-1. zB in Zelle A1 für den Bereich A1:A10

=MIN(A1:A10)-1

Dies gilt für Ganzzahlen. Kann natürlich auch -0,1 sein

Antwort
von Tron1701, 8

Hallo,

im folgenden Beispiel wäre der Auswahlbereich A1 bis A5, natürlich kannst Du die Auswahl beliebig verändern, jedoch die Formel außerhalb der Auswahl positionieren.

Formel in B1 (z. B.)   =KKLEINSTE(A1:A5;1)-1

Wäre es z. B. die komplette Spalte A, dann   =KKLEINSTE(A:A;1)-1

Wäre es z. B. die komplette Zeile 1, dann folgende Formel (Formel hier nicht in B1 positionieren.   =KKLEINSTE(1:1;1)-1

Leider kannst Du nicht die komplette Tabelle auswählen, da sich deine Formel in der Auswahl befindet und somit ein Zirkelbezug entstehen würde.

Gruß Tron

Antwort
von mathsfan, 42

Oh sorry... Ich suche immer die kleinste nicht negative zahl (also ist der Bereich 0 bis ∞ gemeint)

Antwort
von Ortogonn, 42

Die Antwort ist stets: -∞
Denn es gibt immer eine Zahl, die kleiner ist.

Oder soll Excel mit irgendeiner Liste vergleichen? Oder ...

Bitte mehr Informationen ...

Kommentar von mathsfan ,

Oh sorry... Ich suche immer die kleinste nicht negative zahl (also ist der Bereich 0 bis ∞ gemeint)

Kommentar von Ortogonn ,

Natürliche Zahlen ? Positive rationale Zahlen ? Positive reelle Zahlen ?

Beschreib doch bitte mal genau, was du machen möchtest und zeig deinen Lösungsansatz.

Keine passende Antwort gefunden?

Fragen Sie die Community