Frage von Dayman1, 35

Excel Kalkulation, wie leeres Feld mit einbeziehen?

Hallo Leute,

ich habe wie im Anhang zu sehen eine Kalkulation aufgestellt.

http://fs5.directupload.net/images/160705/ymqgbfvm.jpg

Mein Problem ist, dass in der Rechnung in Zelle C5 nur Zellen aus der Spalte Netto J einbezogen werden sollen, in deren Zeilen eine Belegnummer in Spalte E eingetragen ist.

Ansonsten sollen diese nicht berücksichtigt werden.

Beste Grüße,

Christian

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 19

Probiere es mit SUMMEWENNS und füge als Bedingung NICHT(ISTLEER(E13:E53)) hinzu.

Kommentar von Dayman1 ,

Danke!

Würdest du mir noch die komplette Formel schreiben? Bei mir wird immer der #Wert Fehler angezeigt

Kommentar von Suboptimierer ,

Upps, beim Testen habe ich gerade festgestellt, dass man mit SUMMEWENN schlecht auf Texte ungleich leer abfragen kann. Also muss die Universal-Allzweckformel SUMMENPRODUKT herhalten.

=SUMMENPRODUKT(J13:J53*(B13:B53=B5)*(NICHT(ISTLEER(E13:E53))))

Sorry für die Verwirrung.

Man kann auch <>"" abfragen, NICHT(ISTLEER(...)) finde ich aber excelliker ;P.

Antwort
von Funfroc, 17

Hallo,

=SUMMEWENN(E13:E33;"<>";J13:J33)

Bereiche musst du natürlich noch anpassen.

LG, Chris

Kommentar von TimeWasting ,

Wollte es gerade posten ;-)

Keine passende Antwort gefunden?

Fragen Sie die Community