Frage von DesbaTop, 146

Excel Hintergrundfarbe zählen?

Hi Leute,

ich habe mit Excel 2010 eine Liste zusammengestellt. In Spalte A Stehen alle Leute, die auf einer Internetseite registriert sind. In Spalte B stehen alle Leute, die sich noch nie auf der Seite angemeldet haben.

Mit einer Bedingten Formatierung (Doppelte Werte) habe ich alle aus Spalte A, welche auch in Spalte B zu finden sind mit rotem Hintergrund versehen. Oder anders gesagt: Alle Leute aus Spalte A, welche sich nie Eingeloggt haben sind jetzt mit rotem Hintergrund.

Da ich den Prozentualen Wert der Logins ermitteln möchte und keine Lust habe alle zu zählen (Sind enorm viele) wollte ich, dass Excel die Zellen mit rotem Hintergrund für mich zählt.

Hat da jemand eine Formel für mich? :/

Danke schonmal im Voraus :)

Expertenantwort
von Ninombre, Community-Experte für Excel, 130

Den Ansatz mit Zählenwenn konkretisiert: In eine Spalte Deiner Wahl diese Formel:
=ZÄHLENWENN(B:B;A1)

entsprechend der Anzahl Einträge runterkopieren. Über diese Spalte kannst Du dann die Summe bilden. Gezählt werden die Werte in Spalte A, die auch in B enthalten sind - so hatte ich die Anforderung verstanden.

Die Farben, die über Bedingte Formatierung entstanden sind, kann man leider nicht direkt abfragen - es ist keine Eigenschaft der Zellformatierung selbst, daher muss man quasi die Prüfung der bedingten Formatierung nachstellen.

Antwort
von safur, 114

Du könntest die ZähleWenn-Fkt versuchen.
Was steht denn bei deinen roten Feldern?
Alternativ: Selektier deine roten Felder und vergib ein neues Kriterium in Spalte C oder D oder E.
Nun setzt du dort durchgängig ein "x" und summierst später die Spalte.

Keine passende Antwort gefunden?

Fragen Sie die Community