Frage von hayla44, 27

Excel hilfe- wenn dann funktionen bedingungen verknüpfen und text prüfen?

Excel hilfe- wenn dann funktionen bedingungen verknüpfen und text prüfen?

Hallo ihr Lieben,

Anbei seht ihr meine Excel Tabelle als Bild angehängt. Könnte mir bitte jemand netterweise bei folgendem weiterhelfen:

Die Formel die ich Suche ist für die Zeile 17. Ich möchte dass Zeile 17 TRUE/FALSE wiedergibt, und zwar abhängig von den Zeilen 6 & 7 & 16.

Also es soll geprüft werden ob in zeilen 6&7 das Wort "kaufen" ODER "verkaufen" (als ganzes separates wort) vorkommt, dann soll geprüft werden, ob die %zahl in Zeile 16 grösser als 0% (im falle von "kaufen") bzw. ob die %zahl in Zeile 16 kleiner als 0% (im falle von "verkaufen") ist UND eins davon der fall ist, soll TRUE wiedergegeben werden, sonst FALSE.

Ist das verständlich? Ich möchte gerne über längere zeit verfolgen ob die prognosen richtig liegen... Hoffe ihr könnt kurz helfen.

Vielen Dank.

Expertenantwort
von Oubyi, Community-Experte für Excel, 9

Teste mal in C17:

=WENN(ODER(UND(ZÄHLENWENN(C6:C7;"kaufen")>0;C16>0);UND(ZÄHLENWENN(C6:C7;"verkaufen")>0;C16<0));"TRUE";"FALSE")

[Ich habe "
"als ganzes separates wort) vorkommt"
so verstanden, das nur "kaufen" oder "verkaufen" in der Zelle steht.
Falls da auch "kaufen alles" oder Ähnliches stehen kann, sag Bescheid, dann wird es etwas komplizierter.]

Je nachdem wozu 0% zählen soll, musst Du noch auf <= oder >= erweitern.
Und es muss ausgeschlossen sein, das sowohl kaufen als auch verkaufen in den Zellen steht.

Klappt es?

Kommentar von hayla44 ,

hi danke! also es soll geschaut werden ob wörter "kaufen" "verkaufen" im text irgendwie vorkommen. Also das erfüllt auch die Bedingung "das werden wir verkaufen" -> hier wäre "verkaufen" ja auch drin als ein String... beide wörter müssen nicht alleine dastehen. gibts da auch eine Lösung? Dankeschön. und deine bisherige lösung funktioniert, ja.

Kommentar von Iamiam ,

wie ich in meiner AW schon schrieb: Zwei Leerzeichen sind das Kennzeichen für ein einzelnes Wort, wenn das am Ende steht, fehlt eines der beiden, am Anfang auch, aber das andere

Ich hab das immer wieder mit Erfolg so gelöst:

=Nicht(istfehler(Suchen(" "&"Wort"&" ";" "&Findezelle&" ";1)))

Kennt jemand was besseres?

Kommentar von Oubyi ,

Da fällt mir doch gerade ein - und ich meine, ich habe das mal von Dir gelernt, lamiam - dass ZÄHLENWENN auch Wildcards akzeptiert.
Also sollte ganz einfach:

=WENN(ODER(UND(ZÄHLENWENN(C6:C7;"*kaufen*")>0;C16>0);UND(ZÄHLENWENN(C6:C7;"*verkaufen*")>0;C16<0));"TRUE";"FALSE")

funktionieren.

Oder?

Expertenantwort
von Iamiam, Community-Experte für Excel, 9
  1. Da kaufen und verkaufen deutsch ist, Du aber true und False suchst, gehe ich davon aus, dass Du ein englisches xl mit deutschen Wörtern benützt, dass also Dein xl True oder False direkt liefert (und nicht WAHR/FALSCH). (Würde sich auch auf die zu verwendenden Trennzeichen auswirken!)
  2. Da in Zeile 6 (ver)kaufen nicht als einzelnes Wort steht, dürfte die Bedingung wohl sein, dass es ENTWEDER alleine steht ODER ein Leerzeichen davor ist, dass also zB abkaufen nicht zählt. Zwei Leerzeichen sind das Kennzeichen für ein einzelnes Wort, wenn das am Ende steht, fehlt eines der beiden, am Anfang auch, aber das andere. Das ist eine sehr schwierig zu fassende Bedingung, die aber prinzipiell lösbar ist.
  3. Schreib bitte noch, ob das so gemeint war, sonst mach ich Klimmzüge, die nicht nötig sind! (und obendrein schwer nachvollziehbar)

Kommentar von hayla44 ,

Hallo, danke! Ich habe eine komplett deutsche Excelversion und verwende nur bei zahlen amerikansiche dezimaltrennung.

Kommentar von Iamiam ,

also ich hab das jetzt doch mal durchexerziert:

=UND(ODER(NICHT(ISTFEHLER(SUCHEN(" kaufen ";" "&AC6&" ";1)));NICHT(ISTFEHLER(SUCHEN(" verkaufen ";" "&AC6&" ";1))));ODER(AC7="kaufen";AC7="verkaufen");ODER(UND(NICHT(ISTFEHLER(SUCHEN(" kaufen ";" "&AC6&" ";1)));AC16>0);UND(NICHT(ISTFEHLER(SUCHEN(" verkaufen ";" "&AC6&" ";1)));AC16<0)))

blickst Du durch? ich nicht! Ausserdem liefert sie auch WAHR, wenn in C6 kaufen steht und in C7 verkaufen oder umgekehrt, wenn sich die Teile also widersprechen (hast Du ja auch nicht explizit ausgeschlossen ;) (ich weiß, sowas ist fies)  Prüfung >0, <0  richtet sich im Moment nur nach Zeile 6).

Ich schlage vor, Zwischenergebnisse in Hilfszellen unterhalb zu generieren, dann kann man sie gezielt verbessern, wird kompliziert genug! Also:

C19:  =ODER(NICHT(ISTFEHLER(SUCHEN(" kaufen ";" "&AC6&" ";1)));NICHT(ISTFEHLER(SUCHEN(" verkaufen ";" "&AC6&" ";1))))

C20: =ODER(AC7="kaufen";AC7="verkaufen")

C21: =ODER(UND(NICHT(ISTFEHLER(SUCHEN(" kaufen ";" "&AC6&" ";1)));AC16>0);UND(NICHT(ISTFEHLER(SUCHEN(" verkaufen ";" "&AC6&" ";1)));AC16<0))

Jetzt kannst Du kurz und bündig schreiben:

C17: =UND(AC19;AC20;AC21)

(wenn Dich die leere Zelle in C18 stört, kannst Du drei Zellen darunter ja hochschieben)

Der o.g.mögliche Widerspruch ist aber noch nicht beseitigt, das wäre aber auch kein Drama mehr, wenn nötig. Melde Dich ggf nochmals.

Kommentar von Iamiam ,

dann musst Du C17 erweitern zu

=Wechseln(Wechseln(UND(AC19;AC20;AC21);"WAHR";"True");"FALSCH";"False")

WAHR und FALSCH sind ersetzbare Texte, die nur durch Rechenoperationen zu 1, 0 umgewandelt werden.

Wenn ich das von vornherein gewusst hätte, hätte ich die UND- bzw ODER-Formeln als Logikketten aufgebaut und nur in der letzten Ausgabe in C17 das =UND(...) verwendet, welches WAHR bzw FALSCH liefert. Ein greoßer Unterschied wärs aber nicht gewesen.

Kommentar von Iamiam ,

ich hab die Formel in AC erstellt, richte sie einfach ebenfalls dort ein und kopiere sie dann nach C, das ist die unkomplizierteste Lösung!

Keine passende Antwort gefunden?

Fragen Sie die Community