Frage von AMLUH, 62

Excel Formel "Wenn" führt zu Fehler WERT! ?

Moin zusammen,

aktuell verzweifele ich an Excel. Ich hab viele Spalten soweit hinbekommen, aber ich habe eine Spalte, die heißt Gesamt und bei der sollen die Gesamtstunden angezeigt werden.

Nun gibt es in Spalte C in einer Liste die Punkte Urlaub und Krank. Wenn dies ausgewählt, werden gibt es eien Spalte Urlaub und Krank, wo ich es hinbekommen habe, dass wenn Urlaub und Krank ausgewählt wird, die Zahl 8 eingetragen wird.

Nun krieg ich aber das nicht hin, dass in der Spalte Gesamt, unabhängig wie lange gearbeitet wurde, ob 10 oder 4 Stunden, die Zahl 8 angezeigt wird.

Meine Formel sieht so aus (nur anhand des Beispiels Urlaub nun): =WENN(C36="Urlaub";"8";"");WENN(C36="Gastfahrt";WENN(G36="";"";(WENN(G36>H36;1-G36+H36;H36-G36))24/2);(WENN(G36="";"";(WENN(G36>H36;1-G36+H36;H36-G36)24))))

Aber Excel gibt mir dann immer #WERT!

Hat jemand eine Idee, wie das zu beheben ist?

Danke im Vorraus

Antwort
von iMPerFekTioN, 26

Hallo,

kurz zu Erklärung einer verschachtelten WENN()-Funktion,

Eine WENN()-Funktion besteht aus 3 Teilen

1. Überprüfung
2. WENN die Bedingung erfüllt ist, was soll DANN passieren?
3.Was soll SONST passieren wenn die Bedingung nicht erfüllt wurde?


So, eine normale WENN()-Funktion:
=WENN(A1="1";"Hier steht eine 1";"Hier steht keine 1")

Ausgeschriebene Erklärung:
WENN in A1 eine "1" steht, DANN schreibe in meine Zelle "Hier steht eine 1" SONST, in allen anderen Fällen wo in A1 keine "1" steht, schreibe in meine Zelle "Hier steht keine 1"

Okay, soweit zur normalen WENN()-Funktion.....
Dann kommen wir einen Schritt weiter, die verschachtelte WENN()-Funktion.

Was bedeutet denn eigentlich "verschachtelt"?

In etwa etwas wie "ineinander gefügt", oder "ineinander geschoben" wirkend.

So, was bedeutet das für deine Funktion?

Im übertragenen Sinne, wenn man deine Funktion einmal aussprechen würde, würde diese so lauten:

=WENN(C36="Urlaub";"8";"");WENN(C36="Gastfahrt";WENN(G36="";"";(WENN(G36>H36;1-G36+H36;H36-G36))24/2);(WENN(G36="";"";(WENN(G36>H36;1-G36+H36;H36-G36)24))))

Wenn in C36 "Urlaub" steht, trage in meine Zelle eine "8" ein, sonst wenn etwas anderes als "Urlaub" drin steht, lass meine Zelle leer "" WENN C36 "Gastfahrt" enthält Dann schreibe wenn C36 nichts enthält, nichts in meine Zelle, ansonsten, wenn C36 größer ist als H36 berechne 1 minus den Wert aus G36 + H36, ansonsten wenn der wert aus G36 nicht größer ist als H36 oder gleich ist, rechne H36 minus G36 und dividieren 24/2. Wenn G36 leer ist dann schreibe nichts in meine Zelle "" ansonsten, wenn G36>H36 dann berechne 1 minus G36+H36, ansonsten wenn der Wert nicht größer ist rechne H36 minus G36, 24.

Also, echt durcheinander.....

So, eine Verschachtelte WENN()-Funktion muss also so aufgebaut sein, das eine WENN()-Funktion innerhalb einer weiteren WENN()-Funktion aufgerufen wird.

Dein Vorhaben wäre ausgesprochen das:

Wenn in C36 "Urlaub" steht, soll in meine Zelle eine "8" eingetragen werden ansonsten wenn dort "Gastfahrt" steht, soll was anderes passieren.

Du siehst, du hast hier einen SONST-WENN Wert..

D.h. für dich, du musst deine 2. WENN()-Funktion an der Stelle starten, wo bei deiner 1.WENN()-Funktion der SONST-Wert stehen sollte.

Also anstatt dem hier:

=WENN(C36="Urlaub";"8";"");WENN(C36="Gastfahrt";

das hier

=WENN(C36="Urlaub";"8";WENN(C36="Gastfahrt";[MachWasAnderes];""))

Du hast hier also nur einen kleinen Fehler gemacht, indem du die erste WENN()-Funktion vollständig abgeschlossen hast.

Zudem ist in deiner Funktion aber noch einiges anderes Zeugs drin was mir sehr durcheinander vorkommt.

Kannst du mal erläutern was du mit deiner Funktion genau erreichen willst?


Zusatzinfos:
Wenn du eine WENN()-Funktion verschachtelt aufrufen willst, brauchst du die 2. WENN()-Funktion nich mit einer "(" aufrufen.

Du hast das immer so gemacht:

...(WENN(G36>H36;1-G36+H36;H36-G36))24/2);(WENN(G36="";"";(WENN(G36>H36;1-G36+H36;H36-G36)24))))

Die kannst du weglassen!

Ich hoffe ich konnte das etwas erklären, auch wenn ich denke das du grob weißt wie die WENN()-Funktion funktioniert, wollte ich das einfach auch für andere Leute erklären die evtl. nicht so ganz in der Materie drin sind :)

Die anderen haben ja auch schon gezeigt was Falsch ist, ich wollte das nur nochmal ausführlich erklären :p

Grüße,

iMPerFekTioN

Expertenantwort
von Oubyi, Community-Experte für Excel, 35

Du hast da eine abgeschlossene WENN Funktion:
=WENN(C36="Urlaub";"8";"")
auf die eine weitere WENN-Verschachtelung folgt, ohne dass eine Verbindung dazu besteht. Das klappt so nicht.
Vielleicht meinst Du es so?!:


=WENN(C36="Urlaub";"8";WENN(C36="Gastfahrt";WENN(G36="";"";(WENN(G36>H36;1-G36+H36;H36-G36))*24/2);(WENN(G36="";"";(WENN(G36>H36;1-G36+H36;H36-G36)*24)))))

P.S.: Ich habe mich jetzt nicht weiter darin vertieft, warte erstmal Deine Antwort ab.

Kommentar von AMLUH ,

Danke, dass hat es echt gemacht. Das hätte ich nicht gedacht, dass es daran gescheitert ist. Vielen Dank!

Kommentar von AMLUH ,

Wie krieg ich denn nun aber noch in die Formel rein, dass wenn C36="Krank" ist, dass auch eine 8 dann in der Spalte steht? Ich kriege immer fehler

Kommentar von Oubyi ,

=WENN(ODER(C36="Urlaub";C36="Krank");"8";WENN(C36="Gastfahrt";WENN(G36="";"";(WENN(G36>H36;1-G36+H36;H36-G36))*24/2);(WENN(G36="";"";(WENN(G36>H36;1-G36+H36;H36-G36)*24)))))

Expertenantwort
von Iamiam, Community-Experte für Excel, 43

Da ist nur das ;"") im ersten Wenn zuviel, streich das raus, und es steht 8 in der Zelle!

ich würde die Wenns übrigens nicht so hoch verschachteln, da in C36 nur ENTWEDER Urlaub ODER was anderes drinstehen kann, kannst du zwei getrennte Wenns mit + aneinanderhängen (bei Texten mit & )

Kommentar von Iamiam ,

Die Formel kann m.E. auch sonst nicht stimmen: die Zahlen in G und H36 bewirken nichts. Ich hab mir die Formel mal auf Plausibilität durchesehen, da ich aber nicht weiß, was genau Du rechnen willst, ist diese Form nur ein Denkanstoß:

=WENN(G36="";"";(WENN(C36="Urlaub";8;"")+WENN(C36="Gastfahrt";"bei + muss leer oder Zahl rein!")+WENN(G36>H36;1-G36+H36;H36-G36))*24/2)+N("WENN(G36>H36;1-G36+H36;H36-G36)*24)<=das ist doch doppelt?(ausser /2, aber bei gleicher Bedingung!??")

+N("Text") ergibt übrigens 0 und erlaubt es, Kommentare an eine Zahlenformel direkt anzuhängen. - sonst nichts!

Bei dieser Fassung bewirken gleiche Zahlen in G u. H auch nichts, Differenzen werden mit 24/2 je 1Diff gerechnet. recht unklar!

Antwort
von Kito101, 37

vor > oder < muss ein "

Also "<" oder ">"

Kommentar von Iamiam ,

wir sind hier nicht in Zählenwenn bzw Summewenn! Da wäre es so.

Kommentar von Oubyi ,

FALSCH!
Bevor Du etwas behauptest, bei dem Du Dir nicht sicher bist, solltest Du es erstmal selber ausprobieren.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten