Frage von tsingelnstein, 41

Excel Formel Wenn Dann Wert addieren?

Eine etwas knifflige Excel Frage, siehe dazu den Bildanhang. Ich möchte an der Seite gerne eine Formel schreiben, die z.B. alle Einnahmen zusammen addiert. Dazu muss ich prüfen, ob im Bereich D3-D100 Werte größer als 0 vorhanden sind UND ob im Bereich G3-G100 NICHT "Monatliche Einlage" steht, wenn beides wahr ist, dann soll der Wert mit den anderen übereinstimmenden addiert werden.

Das ist wahrscheinlich ein Fall für Excel-Profis, deshalb die zweite Variante etwas einfacher: Ich möchte an der Seite alle Ausgaben zusammen addieren, muss also prüfen, ob im Bereich B3-B100 "Ausgabe" steht, wenn ja, dann soll der dazu gehörende Wert addiert werden.

Ich scheitere an dem letzten Teil, wie sage ich Excel, dass wenn die Bedingung erfüllt ist, er den Wert addieren soll?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Oubyi, Community-Experte für Excel, 33

=SUMMENPRODUKT((D3:D100>0)*(G3:G100<>"Monatliche Einlage")*(D3:D100))

=SUMMENPRODUKT((B3:B100="Ausgabe")*(D3:D100))

Es gibt auch Lösungen mit SUMMEWENN(S), aber ich ziehe diese vor, da sie imho übersichtlicher und zudem flexibler ist.

Kommentar von tsingelnstein ,

Vielen Dank! :)

Kommentar von Oubyi ,

Gern geschehen 😉
Danke fürs

Expertenantwort
von schmiddi1967, Community-Experte für Excel, 22

DH! Oubyi

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten