Frage von tom233a, 50

Excel Formel wenn Dann Buchstabe in + oder - umwandeln?

Hallo, ich brauche eine Excel Formel wenn in der Zeile A das Vorzeichen der Zahl Zeile B ist ( S gleich + H gleich -) Wie kann ich in Zeile C das Vorzeichen mit dem Betrag ausweisen .

Also Wenn Zeile A gleich "S" dann zeile B mal 1 in Zeile C Wenn Zeile A gleich "H" Dann Zeile B mal-1 in Zeile C Gruß Thomas

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 25

Du bringst Zeilen und Spalten durcheinander. A, B, C,... sind Spalten. Zeilen werden 1,2,3,4,... durchnummeriert.

Wenn etwas in Spalte A steht, soll + gerechnet werden, wenn in Spalte B, dann soll der Betrag negiert werden? Oder willst du den Saldo berechnen?

Dann würde ich zuerst Summe Soll berechnen SUMME(...), dann Summe Haben.
Nehmen wir an, Die Summen stünden in A10 und B10.

A11: =WENN(A10>B10;A10-B10;"")
B11: =WENN(A10<=B10;B10-A10;"")

Ich hoffe, dass ich nicht zuviel hinein interpretiert habe.

Expertenantwort
von Oubyi, Community-Experte für Excel, 21

Also Wenn Zeile A gleich "S" dann zeile B mal 1 in Zeile C Wenn Zeile A gleich "H" Dann Zeile B mal-1 in Zeile C

=WENN(A1="S";B1;B1*-1)

oder, "ausführlicher":

=WENN(A1="S";B1;WENN(A1="H";B1*-1;"???"))

Allerdings hätte ich eher gedacht, dass "S" den Wert negativ macht.
Aber das musst Du wissen.


Antwort
von tom233a, 20

Hallo,

vielen dank für die schnelle Hilfe.

ich muss zuhause nach sehen ob s + oder - ist .

Aber wenn es falsch ist tausche ich das S mit dem H aus. :)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten