Frage von OlsenEgon74, 67

Wie kann ich eine Excel Formel mit WENN ODER ODER erstellen?

Hallo, ich arbete gerade an einer Excel Tabelle zur Erfassung von Arbeitszeiten. Ich möchte gern, dass in Zelle G3 die Gesamzeit, Feiertag oder "-" ausgegeben wird.

Ich habe dazu zwei Formeln die ich kombinieren möchte, weiß aber nicht wie...

Mit dieser Formel gebe ich die tägliche Gesamtarbeitszeit aus, wenn der Tag kein Samstag oder Sonntag ist:

=WENN(ODER(WOCHENTAG($B3-1)>=6;D3-C3+F3-E3<0);"-";D3-C3+F3-E3)

Ich möchte aber, dass wenn der Tag ein Feiertag ist, dass dann in diesem Feld der jeweilige Feiertag steht. Ich habe dafür eine Tabelle mit den jeweiligen Feiertagen angelegt und möchte diese mit dem folgendem SVERWEIS ausgeben:

=SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0)

Sollte kein Wochenende oder Feiertag sein und es wurde keine Zeit eingetragen, soll in der Zelle "-" erscheinen.

Alles einzeln bekomme ich hin,aber die Kombination nicht. Ich habe schon an eine ISTFEHLER Funktion gedacht, was ich aber leider nicht hinbekomme...

Ich stelle es mir so vor:

WENN A3 ein Feiertag ist; DANN gib aus wlecher; SONST prüfe ob Wochenende ODER die Arbeitszeit <0 ist; DANN gib aus "-"; ANSONSTEN D3-C3+F3-E3

;-) wie gesagt, so stelle ich es mir vor...

Die Arbeitszeit kann geringer als 0 sein, weil jeder Mitarbeiter mit -8 Minuten beginnt (nicht fragen warum)...

Lg SV

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 67
=WENNFEHLER(SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0);WENN(ODER(WOCHENTAG($B3-1)>=6;D3-C3+F3-E3<0);"-";D3-C3+F3-E3))

Funktioniert der SVERWEIS in der bisherigen Form? Ich hab deine Formel einfach in die Wennfehler Prüfung eingesetzt und nicht näher nachgestellt.

Wenn auf das Tabellenblatt Feiertage verwiesen wird wäre es eher sverweis(A3;Feiertage!$A$2:$B$30 etc

Kommentar von DeeDee07 ,

Open- und LibreOffice verwenden einen Punkt als Trennzeichen zwischen Tabelle und Bereich (noch so eine Inkompatibilität zu Excel).

Kommentar von Ninombre ,

ah, das ist gut zu wissen

Kommentar von Iamiam ,

anstatt Wochentag verwende ich lieber =Rest(Datum;7)

Wochentage ohne Sa&So ist =Rest(Datum;7)>=2

Wochenende Sa&So ist =Rest(Datum;7)<2

Der Sa ist nämlich 0, der So 1 (zufällig, aber immer, da der 1.1.1900 ein So war (nach xl-Logik*), 1Tag davor,  also der 31.12.1899 ein Sa ist)

Das ist Kontinent-übergreifend einheitlich, im Ggs zu Wochentag, wo die Europäer eine Extrawurst braten (seit vllt 40 Jahren ist da der Mo der 1. Wochentag, nicht mehr der So)

zum *: Da xl (und vllt auch andere vorher) im Jahr 1900 einen Schalttag vermuteten (der fällt bei glatten Hundertern ja aus, ausser bei glatten 400ern), stimmt die Zuordnung vor dem 1.März 1900 nicht. Allenfalls für Astronomen oder Historiker von Bedeutung.

Kommentar von OlsenEgon74 ,

Danke, funtkioniert auch fast ;-)


Ich habe die Formel wie folgt umgeschrieben...

=WENN(ISTFEHLER(SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0));WENN(ODER(WOCHENTAG($B3-1)>=6;D3-C3+F3-E3<0);"-";D3-C3+F3-E3))

Das Problem ist, dass es WENNFEHLER nicht im Open Office gibt und ich die Funktion WENN(ISTFEHLER) nutzen muss.

Leider gibt mir die Formel nicht das Ergebniss des SVERWEIS ausgibt.

Kommentar von OlsenEgon74 ,

Habe jetzt alles fertig... funktioniert alles super!

Antwort
von OlsenEgon74, 33

Ich glaub jetzt hab ich es...

WENN Der Tag ein Feiertag ist, erhalt eich den Namen des Feiertages, WENN der Tag ein Sa oder So ist erhalte ich "Wochenende" und WENN die Arbeitszeit geringer als 0 Stunden ist erhalte ich "-", sollte die Arbeitszeit höher als die "Vorlaufzeit" sein, erhalte ich die Zeit...

=WENN(UND(ISTFEHLER(SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0));WOCHENTAG($B3-1)>=6);"Wochenende";WENN(ISTFEHLER(SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0));WENN(D3-C3+F3-E3-(Übersicht.$B$4+Übersicht.$B$5+Übersicht.$B$6)<0;"-";D3-C3+F3-E3-(Übersicht.$B$4+Übersicht.$B$5+Übersicht.$B$6)) ;SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0)))

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten