Frage von zikzuk, 58

Excel Formel mit Suchfunktion gesucht?

Ich muss in eine Datei die Rechnungsnummer und Datum eintragen, von Kunden, die bei uns eingezahlt haben. Dann möchte ich, dass nach der Rechnungsnummer in einer anderen Datei gesucht wird und da als bezahlt abgehackt werden. ZB. In der Datei Konto, Tabelle Dezember Bank A, trage ich in eine Zelle A3 das Datum 01/01/2015, in B3, die Rechnungsnummer 2222. Dann will ich, dass excel automatisch in eine andere Datei "Debitoren" - ALLE Tabellen, 12, für jeden Monat jeweils eine, durchsucht und da wo er die Rechnungsnummer findett zB Zelle B4, in der Tabelle November, in die gleiche Zeile, einfache aber in Zelle G4 das Datum von der Zelle A3 einträgt und dann in die danebengehende Zelle G5 "Bank A" eingibt. Das muss ich dann auch für die Kunden für die Datei Bank B einstelle. Es ist das gleiche es wird nur Bank B eingegeben. Danke!!!! Wie soll die Formel Ausschauen? Müssen die beiden Dateien geöffnet sein? Können die an zwei verschiedenen Rechnern laufen. Danke!

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 58

Ich würde andersherum herangehen.

Schaue in der Datei Konto, ob du die dort angegebenen Rechnungsnummern in der Datei findest, in der du die Eingaben tätigst.

Dafür kannst du die Vergleichsfunktion nutzen. Das funktioniert auch arbeitsmappenübergreifend.

Beispiel:

=WENN(ISTZAHL(VERGLEICH(A1;'E:\tmp\[Test1.xlsx]Tabelle1'!A:A;0));"x";"")

Excel arbeitet grundsätzlich so, dass eine Änderung einer Zelle sich auf Formeln auswirken, die diese Zelle verwenden.

Wenn du durch eine Änderung in einer Zelle eine Aktion auslösen willst, kommst du nicht um eine Programmierung herum.

Excel ist quasi so aufgebaut, dass es sich die Daten holt, nicht a"uslöseorientiert".

Kommentar von Iamiam ,

Können die an zwei verschiedenen Rechnern laufen

  Wenn beide Dateien im gleichen Ordner stehen, sucht xl zunächst mal nach der Datei im selben Ordner, unabhängig vom vorhergehenden Verzeichnisbaum.

Könnte sein, dass das nur gilt, wenn du alles mit der Maus zeigst, glaube aber nicht. Vllt weiß da noch i'jemand Genaueres?

Antwort
von Sawascwoolf, 46

Du hast zwar sehr viel Information in deine Frage gepackt, aber da durchzublicken wird sehr schwer.

Mit Hilfe der Formel SVERWEIS solltest du etwas auf die Beine stellen können.

Die Dateien müssen dazu nicht geöffnet sein.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten