Frage von xAskYouX, 36

Excel-Formel , Schularbeits-Statistik ?

Hallo:) Wir müssen in Excel den Notendurchschnitt einer Klasse ausrechnen. In die Klasse gehen 26 Schüler und 5 haben ein Sehr gut, 5 ein Gut, usw... Jetzt brauche ich eine Formel, nur wie sage ich jetzt Excel dass Sehr gut eins bedeutet und Gut 2 und so weiter? Danke!

Antwort
von Antitroll1234, 36

Legst dir am besten eine Hilfsspalte an, wenn die Noten z.B. in Spalte B stehen, dann folgende Formel zum Umrechnen, beginnend in meinem Beispiel in B1:

=WENN(B1="sehr gut";1;WENN(B1="gut";2;WENN(B1="befriedigend";3;WENN(B1="ausreichend";4;WENN(B1="mangelhaft";5;WENN(B1="ungenügend";6;""))))))

Antwort
von Ortogonn, 17

Angenommen, die Namen der Schüler stehen in Spalte A untereinander und ihre Noten in Worten "sehr gut", "gut", ... in Spalte B untereinander.

Weiter angenommen, es können unterschiedlich viele Schüler, aber maximal 50 sein.

Die Formel, um direkt den Durchschnitt zu berechnen, ist dann

=SUMMENPRODUKT((B1:B50="sehr gut")*1+(B1:B50="gut")*2+(B1:B50="befriedigend")*3+(B1:B50="genügend")*4+(B1:B50="ungenügend")*5)/ANZAHL2(B1:B50)
Expertenantwort
von Iamiam, Community-Experte für Excel, 22

=VERGLEICH(a1;{"sehr gut";"gut";"befriedigend";"ausreichend";"mangelhaft";"ungenügend"};0)

Mit dieser von Vergleich gelieferten "Positionsziffer" kannst Du weiterrechnen als Note.


Antwort
von xAskYouX, 35

in die*

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten