Frage von decentr, 76

Excel Experten gesucht !!! Warum summiert Excel nicht? ?

Als angehängte Datei (Screenshot) sieht man schon, das Excel in der Zelle nicht summiert wie ich will,

Wo mache ich Fehler???

zum Kopieren Formel:

=WENN(IDENTISCH(Tabelle1!A1;"A");Tabelle1!A1;"")&WENN(IDENTISCH(Tabelle1!E1;"A");Tabelle1!A1;"")&WENN(IDENTISCH(Tabelle1!I1;"A");Tabelle1!A1;"")

Danke im Voraus

Expertenantwort
von DeeDee07, Community-Experte für Excel, 35

Sobald du in einer Formel Werte mit & verkettest, wird der Inhalt als Text formatiert (ein Schnell-Indiz ist die Linksbündigkeit). Texte werden bei der Berechnung als 0 gewertet.

Wenn ich das richtig sehe, willst du in A4 "A" stehen haben, wenn es in Zeile 1 gefunden wird. In den nächsten willst du die Zahl an 1. (2. und 3.) Stelle rechts vom gefundenen A ausgeben. Dazu würde ich in A4 folgende Formel verwenden:

=WENN(ISTFEHLER(INDEX(1:1;1;VERGLEICH("A";1:1;0));"";"A")

In B4 dann:

=WENN($A4="";"";INDEX(1:1;1;VERGLEICH("A";1:1;0)+SPALTE(A1)))

Diese Formel sucht in der 1. Zeile nach "A" und gibt den Wert rechts daneben aus.

Diese Formel kannst du nach rechts bis D4 kopieren, dann wird in C4 der 2. Wert neben dem gefundenen A in Zeile 1, in D4 der 3. Wert ausgegeben.

Kommentar von decentr ,

A , 1, 2, 3 tippe ich selber.. Wenn ich So tippe, unten von B4 wir A erkannt, somit fangt zum summieren an Also hier =6 Angenommen A1= A B1= 3,00 C1= 30,00 D1=300,00 D4 soll summe 333,00

Kommentar von DeeDee07 ,

So habe ich das auch verstanden und das sollen die Formeln leisten. Die Summenformel in E4 hast du bereits.

Kommentar von decentr ,

woher bist du?

Kommentar von decentr ,

ich glaube, du liest mein Formel nicht genau.. dass ich in der zelle bis L daten hab, hat ein zweck..

=

Sobald du in einer Formel Werte mit & verkettest, wird der Inhalt als Text formatiert (ein Schnell-Indiz ist die Linksbündigkeit). Texte werden bei der Berechnung als 0 gewertet.
= Das ist mein Hauptproblem. 

Kommentar von DeeDee07 ,

Wenn du den Index-Bereich der Formel begrenzen willst, dann tu das. Du musst dafür statt der ganzen Zeile 1:1 den tatsächlichen Bereich währlen, also $A1:$L1

Das dürfte aber keinen Unterschied machen, wenn die Zellen nach L1 leer sind.

Kommentar von DeeDee07 ,

PS:

Alternativ kannst du deine jetztige Bandwurmformel behalten und die Funktion WERT drumherum bauen. Dann ist es wieder eine Zahl. Also

=WERT(WENN(IDENTISCH(Tabelle1!A1;"A");Tabelle1!A1;"")&WENN(IDENTISCH(Tabelle1!E1;"A");Tabelle1!A1;"")&WENN(IDENTISCH(Tabelle1!I1;"A");Tabelle1!A1;""))

Ich persönlich finde solche Bandwurmformel als schlechten Stil. Falls sich Bereiche ändern, z.B. weitere Zellen in Zeile1 dazukommen, musst du so eine Formel immer mit ändern. Das musst du bei meiner Formel nicht, zudem ist sie kürzer.

Antwort
von Antitroll1234, 39

Wo mache ich Fehler?

Durch & wird kein "Wert" erzeugt.

Sollte aber so lösbar sein:

=Summe(B4+C4+D4)

oder

=B4+C4+D4

Antwort
von Flash8acks, 41

Ich würde die Formel etwas umschreiben und die Funktion "WENNS" nutzen. Hiermit hast du alle Bedingungen zusammen in einer Formel.

https://support.office.com/de-de/article/WENNS-Funktion-36329a26-37b2-467c-972b-...

Oder "SUMMEWENNS":

https://support.office.com/de-de/article/SUMMEWENNS-Funktion-c9e748f5-7ea7-455d-...


Kommentar von decentr ,

excel 2016? Gibt es diese Wenns auch bei 2007?

Kommentar von Flash8acks ,

Versuch es mal mit:

=SUMMEWENN(A1:E1;B3;A1:E1)+SUMMEWENN(A1:E1;C3;A1:E1)+SUMMEWENN(A1:E1;D3;A1:E1)

Kommentar von Flash8acks ,

Oder diese Formel mit der Prüfung des "A" in der Zelle A1:

=WENN(A1="A";SUMMEWENN(A1:E1;B3;A1:E1)+SUMMEWENN(A1:E1;C3;A1:E1)+SUMMEWENN(A1:E1;D3;A1:E1);)

Kommentar von Flash8acks ,

Du hast in der Formel "B4" ja einen Fehler, hier wäre ja ein Zirkelbezug auf sich selbst... also irgendwie werde ich nicht schlau draus was du zusammenzählen willst, sorry.

Die Formel die ich dir gegegeen habe prüft ob die A in der ersten Zeile steht, wenn ja, dann suche den Wert aus B4 und addiere Sie in der Zeile 1:1, genauso mit C4 und D4. Ich glaube wir reden aneineinader vorbei ;-)

Versuch es mit SUMMEWENN...

Kommentar von decentr ,

Flasch8acks, Oberen Formel ist 100% Funktionfähig; ich will nicht alles summieren, Wenn in A1; A steht sol 1 2 3 nehmen summe= 6 das wars

Kommentar von decentr ,

Ich versuch mal

Kommentar von Flash8acks ,

Das ist doch eigentlich recht einfach so wie du es erklärst:

=WENN(A1="A";SUMME(B4:D4);)

Kommentar von decentr ,

Nein, funktioniert nicht

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten