Frage von Koellemann, 42

Excel Diagramm mit String?

Hallo zusammen,

ich bins mal wieder mit einer Frage zu Excel. Und zwar ist die Ausgangslage folgende:

In einer Spalte habe ich die Zahlen 1-13, diese sollen die x-Achse bilden, in einer anderen Spalte habe ich 13 zufaellige Wochentage stehen.

Ich moechte jetzt gerne ein Diagramm erstellen in der die y-Achse mit Montag-Sonntag beschriftet ist und mir dann in Form eines Balken anzeigt bei welchem x-Wert welcher Wochentag auftritt.

Muss ich den Wochentagen erst zahlen zuweisen oder gibt es eine Moeglichkeit diese auch direkt ins Diagramm einfliessen lassen zu koennen?

LG, Koellemann

Expertenantwort
von Iamiam, Community-Experte für Excel, 39

zu Zahlen umsetzen musst Du das schon, geht aber per Fo (also nicht manuell):

=VERGLEICH(A1;{"Sa";"So";"Mo";"Di";"Ni";"Do";"Fr"})

liefert die Pos von A1 im {Vektor}, akzeptiert auch die Langform Dienstag

(Vorgabe ist nämlich VERGLEICH(A1;{"Sa";"So";"Mo";"Di";"Ni";"Do";"Fr"};1) und es gilt Di<Dienstag<Mi

Umgekehrt kannst Du das wieder in Index=Wochentag wiedergeben:

=INDEX({"Sam";"Son";"Mon";"Die";"Mit";"Don";"Fre"};VERGLEICH("Dienstag";{"Sa";"So";"Mo";"Di";"Ni";"Do";"Fr"}))

Das liefert nun definitiv die 3-Buchstabenform.

Die Reihe hab ich deshalb mit Sam beginnen lassen, weil

Rest(Datum(=Datumszelle oder "30.11.15");7)+1 die Zahl für Index liefern kann(also anstatt Vergleich)

Steht noch eine Zeit dabei, dann =Ganzzahl(Rest(Datum(=Datumszelle);1)+1)

Kommentar von Koellemann ,

Puh tut mir leid das versteh ich nicht so wirklich, trotzdem danke fuer deine Muehe! 

Kommentar von Iamiam ,

Da Du die Positionen Deiner Werte nicht geschrieben hast, konnte ich  leider nur allgemein auf die Formeln eingehen!

Kommentar von Iamiam ,

hab Dir aber auch eine falsche Formel geliefert: Bei Vergleich ohne dritten Parameter (xl-Vorgabe: Vergleich(;;1) ) wird eine alphabetisch geordnete Liste gefordert. Damit sie richtig funktioniert, muss die Formel so heissen:

=Index({"Die";"Don";"Fre";"Mit";"Mon";"Sam";"Son"};Vergleich("Montag";{"Di";"Do";"Fr";"Mi";"Mo";"Sa";"So"}))

gleichbedeutend: =Index({"Die";"Don";"Fre";"Mit";"Mon";"Sam";"Son"};Vergleich("Montag";{"Di";"Do";"Fr";"Mi";"Mo";"Sa";"So"};1))

Auch oben ist dieselbe Anordnung nötig, nicht aber bei Vergleich(;;0) und Zweibuchstaben-Tag-Angabe, ;0 kommt auch mit un(=0)geordeneten Listen zurecht, findet aber nur genaue Treffer.

Auch wenn Du das nicht verstehst (woran könnte es liegen?), will ich die falsche Antwort doch nicht unkorrigiert stehen lassen.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten