Excel Datei. 2 Listen mit Namen. Namen der Liste 1 mit denen der Liste 2 vergleichen, ob schon vorhanden. 1500 Positionen. Wie vorgehen? welche Formel/Funkt?

... komplette Frage anzeigen

3 Antworten

Wenn ich es richtig verstehe, geht es jeweils um eine Spalte, die abgeglichen werden soll. Wenn Dir als Ergebnis vorhanden / nicht vorhanden reicht, geht es mit zählenwenn (wenn Du stattdessen einen Wert aus einer anderen Spalte der 2. Liste übernehmen wolltest wäre sverweis richtig)

also:
=ZÄHLENWENN(Tabelle2!A:A;A1) und in die weiteren Zeilen runterziehen
Den Namen des Tabellenblatts und die Spalten musst Du anpassen.

Zählenwenn liefert eine 0 wenn nichts gefunden wurde, sonst die Anzahl der Treffer. Wenn es sprechender sein soll, kannst Du noch eine Wenn-Abfrage verwenden

=wenn(ZÄHLENWENN(Tabelle2!A:A;A1)>0;"gefunden";"nicht gefunden")

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von QuickNick123456
14.09.2016, 09:34

Hi, danke für deine Reaktion/Hilfe. Jetzt kann ich wenigstens ein paar Zeilen mehr schreiben. :)

Also, ich habe eine Excel-Datei mit 2 Tabellenblättern.

In dem ersten Tabellenblatt habe ich eine Tabelle mit potenziellen Kunden (Name, Anschrift etc...)!

In dem zweiten Tabellenblatt habe ich eine Tabelle mit bereits vorhandenen Kunden.

Wir sprechen hier von knapp 1500 Kunden auf beiden Listen

Ich würde gerne wissen, welche Formel ich in Tabellenblatt 1 anwenden muss, um herauszufinden, ob einige Firmen aus Tabellenblatt 1 bereits in den vorhandenen Kunden aufgezeichnet sind.

Dazu habe ich eine weitere Spalte in Tabellenblatt 1 angelegt und will einfach per Zeile wissen, ob JA oder NEIN. 

Ich hoffe, das war irgendwie verständlich. Vielen Dank für die erste Antwort. Hab mich sehr drüber gefreut.

0

ich habe in meinem Kommentar zu Ninombre die Tücken der Teilnamenssuche  veranschaulicht. Mir ist jetzt doch noch was dazu eingefallen:

Wechsle ALLE bekannten Firmentypen, zuletzt auch & und leer aus gegen NICHTS: (Leer hat vor -und Nachteile!)

der O. Meyer als Firmenname sei in A1 und gleichzusetzen mit Oskar Meyer GmbH, dann erst mal

=Wechseln(Wechseln(beliebig oft(Wechseln(A1;" GmbH";"");" AG";"");...);"&";""),

das dann eingerahmt in

=links(A1;1)&"*"&rechts(Wechseln(...Bandwurm..);5)&"*"

das ist zumindest etwas spezifischer, die Oskar Meyer GmbH findest Du dann gerade noch in der O. Meyer GmbH, aber immer noch auch Ole Meyer KG. Und Ole Sparmeyer OHG kannst Du von Obermeyer AG auch schon nicht mehr unterscheiden

Man könnte sich in einer Formel von Leerzeichen zu Leerzeichen hangeln, aber das würde so kompliziert, das tu ich mir (und Dir) jetzt nicht an! (da weiß ich auch zu wenig über die Normgerechte Schreibung von Firmentypen

also -allzugroß ist die Verbesserung auch nicht, man kann sich aber stufenweise weiter vortasten.

Antwort bewerten Vielen Dank für Deine Bewertung

Wenn du einfach nur wissen willst, welche Namen doppelt
vorkommen, dann kannst du das mit der „ZÄHLENWENNS“ Funktion machen. Sie gibt eine Zahl aus, welche dir sagt, wie häufig dieser Name in der ersten Liste vorkommt.

Antwort bewerten Vielen Dank für Deine Bewertung