Frage von JackJack11, 54

Excel Buchstaben zusammenzählen?

Ist es vll möglich zu sagen wenn in Spalte C das Wort "S" vorkommt diese in Spalte D1 zusammenzuzählen? geht das auch wenn in einem Feld in Spalte C mehrere Buchstaben stehen?

wenn das oben genannte möglich ist ist es vll möglich zu sagen nur dann die Buchstaben "S" in Spalte C zusammenzählen wenn in Spalte B der Buchstabe "H" steht?

habs mit =SUMMEWENNS versucht aber klappt net

könnt ihr mir bitte weiterhelfen?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Oubyi, Community-Experte für Excel, 26

nur dann die Buchstaben "S" in Spalte C zusammenzählen wenn in Spalte B der Buchstabe "H" steht?

=ZÄHLENWENNS(B1:B30;"H";C1:C30;"S")

oder wenn zusätzlich gilt:

geht das auch wenn in einem Feld in Spalte C mehrere Buchstaben stehen?

=ZÄHLENWENNS(B1:B30;"*H*";C1:C30;"*S*")

Kommentar von JackJack11 ,

hab versucht die Formel etwas zu verkomplizieren

ich möchte gerne zusätzlich sagen das es nur die "S" zusammenzählen soll wenn "H" in Spalte B steht und der Wert aus Spalte E größer ist als H4 und kleiner oder gleich groß I4 

kannst du mir bitte sagen wo mein Fehler ist?

=ZÄHLENWENNS(B1:B30;"*H*";C1:C30;"*S*";E37:E125;">H4";E37:E125;"<=I4")

Kommentar von Oubyi ,

Deine Bereiche stimmen nicht überein!
Wahrscheinlich hast Du vergessen, das 1:30 aus meiner Formel anzupassen.
Zudem muss das > / <= anders in die Formel eingebaut werden.
Teste mal das hier:

=ZÄHLENWENNS(B37:B125;"*H*";C37:C125;"*S*";E37:E125;">"&H4;E37:E125;"<="&I4)

Kommentar von Oubyi ,

Danke fürs

Kommentar von JackJack11 ,

ich wollte eine weitere Bedingung einfügen, jedoch klapp es nicht ganz
einmal die grundformel 

=ZÄHLENWENNS(B1:B30;"*H*";C1:C30;"*S*")

nun soll gezählt werden wenn D1>E1

=ZÄHLENWENNS(B1:B30;"*H*";C1:C30;"*S*";D1:D30;">"&E1:E30)

wenn ich D30 und E30 weglasse geht es
es soll aber auf die Spalte D und E bezogen sein

wo ist mein Fehler

hab schon einiges ausprobiert aber es will einfach nicht klappen

Kommentar von Oubyi ,

Ich denke, DA bist Du an die Grenzen von ZÄHLENWENNS gestoßen (Ich nutze das sowieso nur, wollte aber auf Deinen SUMMEWENNS-Versuch eingehen).
Da hilft meine Lieblings-Funktion SUMMENPRODUKT, die sehr mächtig, aber für Einsteiger oft etwas verwirrend ist. In diesem Fall geht die so (ist etwas aufwendiger, da sie leider keine Wildcards akzeptiert):

=SUMMENPRODUKT(NICHT(ISTFEHL(SUCHEN("H";B1:B30)))*NICHT(ISTFEHL(SUCHEN("S";C1:C30)))*(D1:D30>E1:E30))

Du kannst die Frage aber auch gerne nochmal neu stellen, vielleicht weiß jemand eine einfachere Lösung.

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 22

Versuch es mit ZÄHLENWENN oder ZÄHLENWENNS.

Antwort
von gfntom, 15

Wie ich es lösen würde:
Ich schreibe in Spalte D eine Funktion, die mir auswertet, ob diese Zeile gezählt werden soll.

etwa

=WENN (UND (C1="S"; B1="H");1;0)

Dann brauchst du nur eine Summe über die relevanten D-Zeilen bilden und hast das Ergebnis.

Antwort
von chewbacca55, 12

Kurz und schmerzlos:

=ZÄHLENWENN(C:C;"*s*")

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten