Frage von 13R41N, 883

Excel Bezug immer auf Zelle in vorherigen Tabellenblatt?

Hallo,

ich habe eine Exceltabelle, in der ich mir für mehrere Personen Arbeitszeiten ausrechnen lasse und monatlich übertrage.

Nun mein Problem: Es ist so, dass positive Überstunden übertragen werden, negative aber nicht. Am Beispiel des Bildes heißt demnach die Formel für Dezember: =WENN('Nov15'!AP3:AP4>0;'Nov15'!AP3:AP4;0).

Es werden also die Gesamtstunden aus dem vorherigen Tabellenblatt übernommen, wenn sie > 0 sind.

Alllerdings muss ich nach und nach immer neue Blätter hinzufügen und wollte nun wissen, ob es eine Möglichkeit gibt, dass der Bezug =WENN('immer vorheriges Tabellenblatt' !AP3:AP4>0;'immer vorheriges Tabellenblatt' !AP3:AP4;0)

was muss ich für 'immer vorheriges Tabellenblatt' eintragen? Kann mir jemand helfen? Ich bin mit meinem Latein am Ende :/

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 765

Um den Namen des aktuellen Tabellenblatts und des Vormonats heraus zu bekommen, kannst du den Namensmanager verwenden

Formeln → Namens-Manager → Neu...

In meinem Beispiel gehe ich davon aus, dass deine Tabellenblätter alle vom Format "MMM JJ" sind. Beispiel "Dez 15", "Okt 12", ...

Lege einen Namen "AktuellesTabellenblatt" für die Arbeitsmappe mit folgender Formel an:

=WECHSELN(ZELLE.ZUORDNEN(32;INDIREKT("A1"));"["&ZELLE.ZUORDNEN(66;INDIREKT("A1"))&"]";"")

Dann lege einen zweiten Namen "VorherigesTabellenblatt" an:

=TEXT(EDATUM(WERT(AktuellesTabellenblatt);-1);"MMM JJ")

Die Namen kannst du ganz normal wie benamte Bereiche verwenden. Schreibe zum Beispiel in eine Zelle =AktuellesTabellenblatt oder =VorherigesTabellenblatt.

Jetzt kannst du mit der INDIREKT-Formel auf das vorherige Blatt zugreifen. Zum Beispiel auf A1:

=INDIREKT("'"&VorherigesTabellenblatt&"'!A1")
Kommentar von 13R41N ,

Danke, hat funktioniert. :) Super

Kommentar von Suboptimierer ,

Bitteschön!

Kommentar von Suboptimierer ,

Du kannst natürlich auch den Namen des vorherigen Blatts einfach einmalig in einer Zelle auf jedem Tabellenblatt festhalten. ;)

Antwort
von SunnySonja19, 584

Das geht angeblich nur mit VBA...bist du mit Makro-Programmierung vertraut? Da ist es nämlich tatsächlich nicht sehr schwer.

http://www.office-loesung.de/ftopic172688_0_0_asc.php

Kommentar von 13R41N ,

Mit Makros kenn ich mich leider garnicht aus :/ Da steht für mich nur Bahnhof Bahnhof Bahnhof :(

Ich dachte, dass es vielleicht einen direkten Begriff für "Datenblatt -1" gibt :/

Das heißt, dass, wenn ich das Datenblatt kopiere( ans Ende stelle), nicht das eigentliche Blatt, sondern, das Blatt direkt davor genutzt wird.

Kommentar von 13R41N ,

ich habe das gefunden, aber weiß ehrlich gesagt nicht genua, was ich damit anfangen soll für meinen speziellen Fall:
http://www.excelformeln.de/formeln.html?welcher=392

Keine passende Antwort gefunden?

Fragen Sie die Community