Frage von Aleksej10,

Excel Berechnung der tage zwischen zwei Daten

Hallo,ich habe folgendes Problem, dass ich die anzahl der Tage und die Stundenanzahl ohne Wochenende zwischen zwei Datumsangaben mit Uhrzeit berechnen lassen will mit Excel. Und bekomme wenn dann ganze Tagesanzahlen ohne Wochenende, brauche aber Tage mit einer Kommazahl. z.B.7,8 Tage

Ich hab z.B.erste Spalte 18.5.2011 20:11 zweite 30.05.2011 05:00 Und möchte eine Anzahl der Tage haben dazwischen hier im Beispiel als Ergebnis = 7,36 Tage und bei Nettoarbeitstage bekomme ich 9 Tage raus. Und die 9 Tage als ganze tage .

Hilfreichste Antwort von Iamiam,

muss leider etwas ausführlicher sein: Deine Datümer stehen in A1 (Anfang) und in B1. Am anschaulichsten Benutzerdefiniertes Format TTT, TT.MM.JJ hh:mm Damit nun nicht xl penetrant jede Zahl ins Datumsformat umwandelt, hab ich erst mal in A2 =A1 und in B2: =B1 stehen und die Formate in A2,B2 gelöscht. Die folgenden Formeln beziehen sich also auf A2, B2.

Zum Aufbau:
Ich hab die Zeiträume getrennt: in Kernwochen (ganze Wochen) mit 5 Arbeitstagen, in jeweils die ganzen Tage der End- und der Anfangswoche sowie in die Tagebruchteile des ersten und des letzten Tages.
Glücklicherweise ergibt in xl-Dadumms die Teilung durch 7 einen Rest 0 für Sa, 1 für So, bis 6 für Fr. Rest(Mo, zB.30.5.11;7) ist also 2. Damit kanns losgehen: Die Anzahl der Tage in den ganzen Wochen innerhalb des Zeitraums sind:

=(GANZZAHL(B2)-REST(GANZZAHL(B2);7)-(GANZZAHL(A2)+7-REST(GANZZAHL(A2);7)))/7*5

ganze Tage in Folgewoche: =WENN(REST(B2;7)>1;GANZZAHL(REST(B2;7))-2;0)
ganze Tg in Anfangswoche: =WENN(REST(A2;7)>1;7-GANZZAHL(REST(A2;7))-1;0)

Bruchteil Endtag: =WENN(REST(B2;7)>1;REST(B2;1);0)
Bruchteil Anf.tag: =WENN(REST(A1;7)>1;1-REST(A2;1);0)

Du kannst diese Einzel-Formeln untereinanderschreiben und summieren, du kannst sie aber auch in einer einzigen Zelle mit + aneinanderhängen, xl macht das klaglos. Ist nur schwieriger, sie nachzuvollziehen. Am besten, Du kopierst den Kern der Antwort in ein Textfeld, dann hast Du auch immer alle Erklärungen parat.. Probier sie aus, bei meinen Testwerten ging alles!

Kommentar von Iamiam,

ich hab aber doch Zweifel, dass deine Aufgabenstellung inhaltlich richtig ist: Rechnest Du wirklich den Arbeitstag mit 24 h und Teile davon mit Teilen von 24h?

Wenn nicht, müssten wenigstens nur die beiden letzten Teilformeln aufwändiger angepasst werden, was aber gar nicht so einfach wäre!
Bei den drei Ganztagesformeln würde die Multiplikation mit Stunden/Tag reichen.

Kommentar von Iamiam,

in der Formel ist übrigens unterstellt, dass Anfangs- und Endtag nicht im Wochenende liegen. Feiertage musst Du übrigens manuell berechnen: wenn die Abfahrt am Pfingstmontag ist, und die Rückkunft an Fronleichnam, gibts ein ziemliches Durcheinander, ansonsten ziehst du eben für jeden Feiertag einen Tag ab.

Kommentar von Aleksej10,

Vielen dank für die Hilfe

Kommentar von Iamiam,

gern, mag solche Knobelaufgaben! Und danke für den Stern!

Antwort von Oubyi,
1 Mitglied fand diese Antwort hilfreich

Angenommen Dein Anfangsdatum steht in A1, Dein Enddatum in A2.
Dann teste bitte mal diese Formel GANZ AUSFÜHRLICH, ich bin nämlich nicht 100% sicher, dass sie in jedem Fall richtig ist, habe im Moment aber keine Zeit mehr:
=(A2-A1)-((AUFRUNDEN(A2-A1;0)+1)-(NETTOARBEITSTAGE(A1;A2)))
Klappt es?

Kommentar von Oubyi,

Teste auch mal diese Formel ausführlich:
=(A2-A1)-((AUFRUNDEN(A2-A1;0)+1)-(NETTOARBEITSTAGE(A1;A2)))+((REST(A2;1)-REST(A1;1))>0)*1
Ich bin nicht sicher, welche Deine Anforderungen besser erfüllt.
Sie unterscheiden sich, wenn die AnfangsUHRZEIT später liegt, als die EndUHRZEIT.

Kommentar von Aleksej10,

Hi, hab beide ausprobiert haben, aber sie haben nicht geklappt. Hab es mit jedem Format versuch wenn ich hhmm nehme dann kommt ############################ als Ergebniss

Kommentar von Oubyi,

Das kann ich nicht nachvollziehen.
Mache mal eine ganz neue Excel Datei auf.
Dann KOPIERE die beiden Datümer, die Du oben angegeben hast in A1 und A2:
A1: 18.05.2011 20:11:00
A2: 30.05.2011 05:00:00
(Excel formatiert diese Eingabe automatisch richtig)
Dann füge irgendwo anders in dem Blatt meine beiden Formel ein, und beide sollten Dir:
7,367361111
anzeigen.

Keine passende Antwort gefunden?

Weitere Fragen mit Antworten

Fragen Sie die Community