Frage von Aleksej10 20.05.2011

Excel Berechnung der tage zwischen zwei Daten

  • Hilfreichste Antwort von Iamiam 20.05.2011

    muss leider etwas ausführlicher sein: Deine Datümer stehen in A1 (Anfang) und in B1. Am anschaulichsten Benutzerdefiniertes Format TTT, TT.MM.JJ hh:mm Damit nun nicht xl penetrant jede Zahl ins Datumsformat umwandelt, hab ich erst mal in A2 =A1 und in B2: =B1 stehen und die Formate in A2,B2 gelöscht. Die folgenden Formeln beziehen sich also auf A2, B2.

    Zum Aufbau:
    Ich hab die Zeiträume getrennt: in Kernwochen (ganze Wochen) mit 5 Arbeitstagen, in jeweils die ganzen Tage der End- und der Anfangswoche sowie in die Tagebruchteile des ersten und des letzten Tages.
    Glücklicherweise ergibt in xl-Dadumms die Teilung durch 7 einen Rest 0 für Sa, 1 für So, bis 6 für Fr. Rest(Mo, zB.30.5.11;7) ist also 2. Damit kanns losgehen: Die Anzahl der Tage in den ganzen Wochen innerhalb des Zeitraums sind:

    =(GANZZAHL(B2)-REST(GANZZAHL(B2);7)-(GANZZAHL(A2)+7-REST(GANZZAHL(A2);7)))/7*5

    ganze Tage in Folgewoche: =WENN(REST(B2;7)>1;GANZZAHL(REST(B2;7))-2;0)
    ganze Tg in Anfangswoche: =WENN(REST(A2;7)>1;7-GANZZAHL(REST(A2;7))-1;0)

    Bruchteil Endtag: =WENN(REST(B2;7)>1;REST(B2;1);0)
    Bruchteil Anf.tag: =WENN(REST(A1;7)>1;1-REST(A2;1);0)

    Du kannst diese Einzel-Formeln untereinanderschreiben und summieren, du kannst sie aber auch in einer einzigen Zelle mit + aneinanderhängen, xl macht das klaglos. Ist nur schwieriger, sie nachzuvollziehen. Am besten, Du kopierst den Kern der Antwort in ein Textfeld, dann hast Du auch immer alle Erklärungen parat.. Probier sie aus, bei meinen Testwerten ging alles!

  • Antwort von Oubyi 20.05.2011
    1 Mitglied fand diese Antwort hilfreich

    Angenommen Dein Anfangsdatum steht in A1, Dein Enddatum in A2.
    Dann teste bitte mal diese Formel GANZ AUSFÜHRLICH, ich bin nämlich nicht 100% sicher, dass sie in jedem Fall richtig ist, habe im Moment aber keine Zeit mehr:
    =(A2-A1)-((AUFRUNDEN(A2-A1;0)+1)-(NETTOARBEITSTAGE(A1;A2)))
    Klappt es?

Du kennst die Antwort? Frage beantworten
Bitte noch eine Antwort ... Frage erneut stellen

Verwandte Fragen

Fragen Sie die Community –

anonym und kostenlos!