Frage von sue0815, 257

Excel bedingte Formatierung mit Formel - 2 Werte vergleichen und wenn übereinstimmend + zusätzlich werte > 0 farblich markieren Wie?

Hallo zusammen,

ich brauche Hilfe, ich versuch dies mal so genau wie möglich zu beschreiben....

Ich habe 1 Excel Datei mit 2 Arbeitsmappen Beide Arbeitsmappen enthalten Pivottabellen (müssen bleiben, da regelmäßige Aktualisierung erforderlich)

Dennoch sind die Daten in beiden Tabellen fast (!!!) identisch.

Mein Ziel ist:

  1. Arbeitsmappe 1 - Zelle D1 = Nummer Arbeitsmappe 2 - Zelle B1 = Nummer

Abgleich ob D1 aus Tabelle 1 auch in Spalte B der Tabelle 2 zu finden ist

  1. Wenn das der Fall ist, muss geprüft werden ob die Spalte B in Tabelle 2 einen Wert grösser als 0 enthält

  2. Wenn ja, dann farbliche Markierung der Zelle D1 in Tabelle 1

So.... hoffe dies ist verständlich erklärt?! Wenn nicht, fragt gerne nach mehr Details.

Da es sich um eine Pivot Tabelle handelt und diese nicht als "normale" Tabelle kopiert werden soll, würde ich dies gerne über eine bedingt Formatierung machen... Ob DAS allerdings funktioniert, keinen Schimmer...

Würde mich freuen, wenn mir jemand Aufschluss gibt, ob und wie das möglich ist.

Gruss Sue

Expertenantwort
von Ninombre, Community-Experte für Excel, 212

Der erste Abgleich funktioniert so über bedingte Formatierung
=ZÄHLENWENN(Tabelle2!B$1:B$10;D1)>0

Den Bereich (hier Tabelle2 B1:B10) musst Du anpassen, ich habe nicht genau verstanden, wo gesucht werden soll. Den Gültigkeitsbereich der bedingten Formatierung entsprechend erweitern.

Zum zweiten Abgleich habe ich allerdings nicht nachvollziehen können, was geprüft wird. Ist D1 schon eine Zahl? Dann kann man ja direkt abfragen, ob D1 > 0 ist oder soll irgendein Wert in Spalte B (tabelle2) größer 0 sein?

Die Logik ist mir nicht klar: D1 ist eine Nummer (4711) - die wird in Spalte B gefunden. Damit gibt es ja auf jeden Fall eine Zahl größer 0 mit dem Treffer.

Ansonsten wäre die Abfrage
=ZÄHLENWENN(Tabelle2!B1:B10;">0")

Als bed. Formatierung zusammengesetzt:

=UND(ZÄHLENWENN(Tabelle2!B$1:B$10;D1)>0;ZÄHLENWENN(Tabelle2!B1:B10;">0")>0)

Kommentar von DeeDee07 ,

Übrigens, falls die Excel-Version etwas älter ist (ich weiß aber nicht genau bis zu welcher), dann werden in der BF keine Formeln verwendet werden können, die über mehrere Tabellenblätter hinausgehen. Das muss man dann über die Namensvergabe oder die INDIREKT-Krücke umgehen, wie hier beschrieben http://www.excelformeln.de/tips.html?welcher=109

Keine passende Antwort gefunden?

Fragen Sie die Community