Frage von AlOnKpt, 73

Excel Bedingte Formatierung für Liste?

Hallo Leute,

ich möchte mir in Excel eine Liste erstellen hab aber nicht das richtig Know-How. Kann mir jemand helfen? Ein genaues Beispiel hab ich als Foto angehängt. Danke für eure Hilfe!

Lg AlOnKpt

Expertenantwort
von Iamiam, Community-Experte für Excel, 19

meiner Meinung nach brauchst du doch gar keine bedingte Formatierung, sondern Formeln, die automatisch ein - eintragen, wenn in der anderen Zelle eine Zahl eingetragen wurde?

(oder willst Du rot färben, wenn irrtümlich zwei Zahlen eingetragen wurden?)

Die Formel in A1 heißt:

=WENN(ISTZAHL(B1);"-";"") und in B1 =WENN(ISTZAHL(A1);"-";"")

beide Zellen färben oder durch Rahmen kenntlich machen, ein paar Zeilen runterziehen.

Da siehst du erst mal gar nichts, weil je "" nicht zu sehen ist, aber sofort eine Zirkelbezugswarnung: Die beiden Zellen verweisen ja gegenseitig aufeinander.

Du kannst das erst mal ignorieren (Warnung mit ok wegklicken, aber es nervt.

Nach dem Eintragen einer Zahl in A oder B (Formel wird dadurch überschrieben) zeigt sich das entsprechende "-" in der Zelle,

Ich empfehle Dir deshalb eine andere Lösung: Füge eine Süalte zwischen A und B ein und mache sie sehr schmal. Schreib in diese neue B diese Formel:

=WENN(ISTZAHL(A1);".10xLeerzeichen --";"")&WENN(ISTZAHL(C1);"--
10xLeerzeichen .";"")

richte die Zellen in Spalte B mittig aus (Icon ≣ im Ribbon Start)

Das sieht optisch ähnlich aus: Evtl Schrift Arial Rounded MT bold

kopiere die Formel nach unten.

bei korrektem Eintrag erscheint in der jeweils anderen Zelle ein "--"

Steht sowohl in A wie in C eine Zahl, erscheint in B recht auffällig  "----" (der Rest wird von den Einträgen überdeckt.

Ist weder in A noch in B eine Zahl eingetragen, erscheint alles optisch leer

Expertenantwort
von Oubyi, Community-Experte für Excel, 22

Ich sehe da keine Anwendung für eine Bedingte Formatierung
Auch über Formeln sehe ich da keinen Weg, da die Eingabe eines Wertes in eine Zelle die Formel unwiederbringlich überschreibt.
Beides wäre höchstens für eine einmalige Anwendung zu gebrauchen.
Ich denke, das kann dauerhaft nur über einen VBA-Code gelöst werden. Den kann ich Dir zwar schreiben, würde Dir als Anfänger aber davon abraten.
Versuche eher das Problem durch einen anderen Aufbau zu lösen.

Antwort
von vitus64, 35

Bedingte Formatierung mit der Bedingung
=wenn(und(a1<>0;b1<>0);wahr;)
Format wählen
Format mit dem Formatpinsel nach unten kopieren

Kommentar von AlOnKpt ,

Muss ich bei der bedingten Formatierung "Formel zur Ermittlung der zu formatierenden Zellen verwenden" auswählen?

Was bedeutet wahr in Deiner Formel?

Sry bin ein Anfänger...

Kommentar von vitus64 ,

"Muss ich bei der bedingten Formatierung "Formel zur Ermittlung der zu formatierenden Zellen verwenden" auswählen?"
Ja.

Wahr bedeutet, dass das gewählte Format verwendet wird, wenn die Bedingung (und(...))erfüllt ist und nur dann.

Wichtig ist auch das Semikolon hinter 'wahr'.

Kommentar von Oubyi ,

Als Formel für die Bedingte Formatierung würde imho durchaus reichen:
=ISTZAHL(B1)
Aber welche Formatierung willst Du einstellen, sodass ein "-" angezeigt wird, wenn B1 leer ist?
(Bei Werten in B1 habe ich damit kein Problem).

Keine passende Antwort gefunden?

Fragen Sie die Community