Excel automatischer ablauf?

... komplette Frage anzeigen

3 Antworten

Soo hallo,

ich schalte mich hier auch mal ein =):

Alsooo, zu aller erst brauchst du einen Fixen =HEUTE() Wert, der sich am nächsten Tag nicht mehr ändert, sodass du die Tage zählen kannst, die verstrichen sind.

Aufbau der Tabelle:

A1 schreibst du "Nummer"
B1 schreibst du "Tag"
C1 schreibst du "€"
D1 schreibst du "Endwert"
E1 schreibst du "Datum"

In Spalte A, werden die Nummern er jeweiligen Aktion eingetragen, sprich da gibst du (Manuell die Zahlen von 1 bis xxxxx ein)

Wenn du nichts machen willst, lässt du die Zelle einfach leer.

Sobald du eine Zahl eingibst, wird die Operation zum berechnen des aktuellen Datums gestartet, das Datum wird dann fix eingetragen und ändert sich auch nicht mehr beim neu laden der Datei oder beim aktualisieren (F9).

Dazu gibst du jetzt in E2 folgende Formel ein:

=WENN(A2="";"";WENN(ZELLE("TYPE";G2)="v";G2;HEUTE()))

So, in B2 kommt diese Formel:

=WENN(E2="";"";WENN(E2=HEUTE();1;TAGE(HEUTE();E2)))

Soo, in C2 kannst du jetzt eine beliebe Summe eingeben, der Wert in D2 ändert sich nach 150 Tagen.

Dazu diese Formel in D2 eintragen:

=WENN(B2<150;C2;WENN(B2=150;B2-10;"0"))

Angenommen wir schreiben 10€ in C2:

Wenn noch keine 150 Tage verstrichen sind, sprich der Wert in B2 ist > 150, steht in D2 10€, wenn der Wert in B2 = 150 ist, steht in D2 C2-10,

Also in unserem Fall dann 10€ - 10 = 0.

Wenn der Wert in B2 > 150 ist, wird einfach eine eingetragen, weil die Tage überfällig sind.

Die Formeln sind Kopierbar und du kannst sie einfach nach unten ziehen (kleines schwarzes Viereck unten rechts an der Zelle wenn du sie anklickst)

Bei Fragen, melde dich =)

Grüße,

iMPerFekTioN

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von nickboy
21.04.2016, 11:07

Hierzu ersteinmal hier der downloadlink:
https://www.dropbox.com/s/5kzhcj8xk4...ator.xlsx?dl=0

damit ist es wesendlich einfacher zu erklären

also es geht um die Spalte wo Hier steht

in der zelle F245 seht ihr das da -100 steht diese 100 bezihen sich auf zelle E20

es wird da -100 gerechnet weil die 100 bis diesen zeitpunkt 225% +
gemacht hat ich möchte aber zu der jetzigen berechnung noch dazu haben
das sobald 150 tage ereicht sind das dan schon -100 bzw. zahl x
abgezogen wird egal ob diese nun 225% oder nur 150% gebracht haben

also im endeffekt möchte ich das das x- gerechnet wird endweder sobald 150tage ereicht sind oder wen die 225% ereicht sind

In der spalte B die zahlen die da drine stehen das sind tage

ich hoffe hier ist jemand der mir helfen kann

1

Ich habe nicht den Hauch einer Ahnung was du machen möchtest :-(

Antwort bewerten Vielen Dank für Deine Bewertung

Ich würde das so lösen:

Zelle A1: "10"
B1: "20.04.2016" (also immer das Datum, wo sie eingetragen wird)

C1: "=WENN(B1<HEUTE()-150;A1-10;A1)"

Die Spalten A und B kann man dann ausblenden.

Auch wenn du das per Makro lösen würdest, müsste irgendwo das Datum zwischengespeichert werden. Ginge eventuell noch auf einem separaten Arbeitsblatt, was ausgeblendet ist und per Makro jeweils mit dem Eintragsdatum gefüllt wird.

Wenn das oben beschriebene dir zu "unelegant" ist, kann ich mir aber auch mal Gedanken zu einem Makro machen ;-)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von nickboy
20.04.2016, 23:01

das ganze müste ohne makro gelöst werden und das ganze ist eine tabelle  mein ansaz ist wen zellex kleiner als x*x%;dann forme x;-zellex wo minus gerechnet werden muss aber so ganz klappt das noch nicht :(

0