Frage von JackJack11, 58

Excel automatisch Buchstaben eintragen?

Hallo

Excel soll selber erkennen ob der Buchstabe S U oder V in C1 eingetragen werden soll wenn A1 > B1 dann bei C1 "S" eintragen wenn A1 < B1 dann bei C1 "U" eintragen wenn A1 = B1 dann bei C1 "V" eintragen

irgendetwas stimmt an meiner Formel net WENN(A1>B1;C1"S";WENN(A1>B1;C1"U");WENN(A1>B1;C1"V")

könnt ihr mir bitte weiterhelfen

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von pythonpups, 23

Du musst das C1 da nicht reinschreiben sondern die ganze Formel in der Zelle C1 eintragen. Probier mal: 

=WENN(A1>B1;"S";WENN(A1<B1;"U";"V"))

Den Vergleich A1=B1 brauchst Du ja nicht, weil das die letzte übriggebliebene Möglichkeit ist.

Kommentar von diewoelfin0815 ,

Dann stünde dort aber auch immer ein V, wenn in A1 und B1 gar keine Zahlen wären.

Kommentar von pythonpups ,

Das ist richtig. Das habe ich leichtsinnigerweise vorausgesetzt. Dann ist Deine letzte Formel sicherer.

Antwort
von gfntom, 25

du musst diese Formel in die Zelle C1 schreiben und alle "C1" aus deiner Formel entfernen!

Kommentar von gfntom ,

WENN(A1>B1;"S";WENN(A1<B1;"U";"V"))

Kommentar von pythonpups ,

OK, Du warst deutlich schneller. Wurde beim Tippen abgelenkt. ;)

Kommentar von JackJack11 ,

hab das gemacht aber geht noch immer nicht

v

WENN(A1>B1;"S";WENN(A1>B1;"U");WENN(A1>B1;"V")

Kommentar von gfntom ,

Mach ein '=' davor und nimm meine Formel. Deine ist falsch (Klammern falsch gesetzt, der "sonst"-Zweig fehlt teilweise)

Antwort
von diewoelfin0815, 33

Hallöle JackJack11,

wenn Du es wirklich so da drin stehen hast, stehen einfach nur die falschen Rechenzeichen drin (3x >, statt >, <, =) und das C1 ist auch immer zuviel, die Formel steht ja korrekter Weise in der Zelle C1 drin. 

So ist's richtig:

WENN(A1>B1;"S";WENN(A1<B1;"U");WENN(A1=B1;"V")

Wohlgelaunte Grüße,

wölfin

Kommentar von pythonpups ,

Das klappt nicht, Deine Klammern sind falsch geschachtelt, oder?

Kommentar von gfntom ,

Und je nach Klammernsetzung fehlt mindestens ein "sonst"-Zweig.

Kommentar von diewoelfin0815 ,

Upps, Flüchtigkeitsfehler - sorry. So hier noch mal korrekt:

=WENN(A1>B1;"S";WENN(A1<B1;"U";WENN(A1=B1;"V")))

Bitteschön, hier noch die beiden umgesetzten Klammern!

Antwort
von JackJack11, 24

Ist es vll möglich zu sagen

wenn in Spalte C das Wort "S" vorkommt diese in Spalte D1 zusammenzuzählen?

geht das auch wenn in einem Feld in Spalte C mehrere Buchstaben stehen?

Kommentar von diewoelfin0815 ,

Ist quasi das gleiche in grün! 

Kleiner Tipp: Klick doch einfach die Zelle an, in der Deine Formel rein soll und nutz dann einfach den "fx"-Button, links gleich neben der Zellen-Bearbeitungsleiste. Klick dann auf die Funktion WENN und den Rest muss man nur noch (ggf. nach Bedarf hilfegestützt) eingeben. Wenn irgendwas nicht passt, meldet Excel es und bietet meist schon sofort Verbesserungsvorschläge an, die es selbst " erledigt".

Expertenantwort
von Oubyi, Community-Experte für Excel, 12

Teste mal diese Formel in Zelle C1:

=WENN(A1>B1;"S";WENN(A1<B1;"U";WENN(A1=B1;"V")))

Kommentar von skychecker ,

Da fehlt auf jeden Fall noch ein Sonst-Ableger...

Kommentar von DeeDee07 ,

Der Dann- und Sonst-Wert bei einer Wenn-Funktion sind optional. Wenn sie nicht gesetzt sind, wird WAHR bzw. FALSCH ausgegeben. Es fehlt ja auch die Vorgabe des Fragestellers, was passieren soll, wenn A1 weder größer, gleich noch kleiner als B1 ist (z.B. bei Text oder Fehlern).

Kommentar von Oubyi ,

Da fehlt auf jeden Fall noch ein Sonst-Ableger...

Es wird abgefragt, ob A1 größer, gleich oder kleiner als B1 ist.
Da gibt es keine weitere Möglichkeit, die mit "sonst" gelöst werden müsste.

Also fehlt da imho NICHTS.
Oder?

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten