Frage von juhaafrage, 47

Excel: Aus Tabelle A etwas in Tabelle B suchen und eine Zelle aus B wiedergeben, kann wer helfen?

Hallo,

ich möchte gerne, dass meine Formel folgendes kann: in Tabelle A habe ich in Spalte E etwas stehen und dies entscheidet sich von Zeile zu Zeile. Genau dieser Inhalt ist auch in Tabelle B Spalte B. Den Wert, die Zeile, die ich wiedergeben möchte ist in Spalte M.

Info: In Tabelle A taucht dieser Zelleninhalt öfters auf, ab und zu 4 mal. In Tabelle B gibt es diesen nur einmal.

Habs mit WVerweis versucht, aber irgendwie holt der sich aus der Zeile M immer etwas falsches..

Wäre für Hilfe dankbar!

Antwort
von Xarna, 43

Hallo, die ERklärung ist leider etwas schwierig nachzuvollziehen.

Kannst du eventuell zeigen, wie du es bisher versuchst?

Du möchtest in Tabelle A etwas drin haben, dieses dann in Tabelle B finden und Spalte M aus Tabelle B wiedergeben?

Kommentar von juhaafrage ,

=SVERWEIS(E21;infra!A:L;12;WAHR)

so hab ich es bisher. Er gibt mir auch was aus der gesuchten Spalte raus, allerdings was falsches.. Spalte A wurde durch E ersetzt. hab gerade die aus Zeile 21 rauskopiert.Im Prinzip kann da auch E2 stehen

Kommentar von juhaafrage ,

die Tabellen sind nicht sortiert, da diese permanent aktuallisiert wird und eine Sortierung nicht sinnig wäre

Expertenantwort
von Ninombre, Community-Experte für Excel, 25

=sverweis(A1;TabelleB!B:M;12;falsch) sollte gehen.

Kommentar von juhaafrage ,

habs jetzt so =SVERWEIS(E21;infra!A:L;12;WAHR)

die richtige Spalte wird durchsucht, gibt allerdings was falsches wieder. Spalte A wurde durch E ersetzt

Kommentar von juhaafrage ,

die Tabellen sind nicht sortiert, da diese permanent aktuallisiert wird und eine Sortierung nicht sinnig wäre

Kommentar von Ninombre ,

dann sollte der letzte Parameter aber auf "falsch" stehen, d.h. exakte Suche. Wahr wäre eine ungefähre Suche, die wiederum nur bei sortierten Werten Sinn macht.

Kommentar von juhaafrage ,

da kommt dann #NV

Kommentar von Ninombre ,

Das heißt, dass der Suchbegriff nicht gefunden wurde. Überprüf mal die Zellformatierungen und -inhalte. Ein Suchbegriff mit und ohne Leerzeichen ist nicht das gleiche auch eine Zahl wird nicht gefunden, wenn sie mal als Zahl und mal als Text formatiert ist. Gerade bei Zahlen darauf schauen, was tatsächlich in der Zelle steht. Über Zellformatierung kann man bspw. runden, so dass oberflächlich eine 2 angezeigt wird, in Wirklichkeit aber 2,01 drin steht.

Keine passende Antwort gefunden?

Fragen Sie die Community