Frage von Spotix, 83

Excel 3 Variablen/ Formel?

Ich suche eine Formel die 3 Variablen erfüllt. =SVERWEIS(G5;WENN(A1:A38 =G3;WENN(C1:C38=G4;A1:E38;““);““);4) diese Formel funktioniert nur wenn ich statt Brot irgendeine Zahl eintippe. Komme nicht weiter. Bitte drigend um Hilfe. Danke :) Hier ein Bild: http://img4web.com/view/7CX8

Antwort
von Jackie251, 35

habe mir deine Formel nochmal angesehen, die Funktioniert ansicht auch.

Der Hauptfehler ist, dass du als Suchkriterium Die Nummer (Spalte B) verwendest, dann aber Mit A1;E38 die Erste Spalte als A definierst.
Die gesuchte Zahl 1136 kann daher in Brot/Apfel/Brot nicht gefunden werden.

Wenn man das ändert und die nicht erforderlichen Dinge einkürzt (zB braucht es keine 2 Wenn Funktionen, nur weil 2 Dinge wahr sein sollen und man braucht in diesem Fall in der Wenn Funktion, keine Oderangabe.
erhält man

=SVERWEIS(G3;WENN((B1:B38 =G5)*(C1:C38=G4);A1:E38);4)

das funktionert dann (nach abschluss mit strg-shift-enter) auch

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 38

Ist es schlimm, wenn ich das etwas anders aufziehe? Die Syntax empfinde ich als zu verkrampft.

Da die Rechnungsnummern numerisch sind und ich mal davon ausgehe, dass alle Kriterien maximal auf einen Datensatz zutreffen, könntest du es so probieren:

=SUMMEWENNS(D2:D4;A2:A4;G3;B2:B4;G5;C2:C4;G4)
Kommentar von Spotix ,

danke. Guter Lösungsvorschlag. hat mir auch geholfen

Kommentar von Suboptimierer ,

Mit der INDEX-Funktion könntest du das so lösen:

=INDEX($A$1:$D$38;MAX(ZEILE(A2:A38)*(A2:A38=$G$3)*(B2:B38=$G$5)*(C2:C38=$G$4));4)

Die Eingabe dieser Formel musst du mit Strg + Shift + Enter abschließen.

Ach, sehe gerade, dass Jackie längst mit INDEX gearbeitet hat...

Expertenantwort
von Oubyi, Community-Experte für Excel, 21

Man kann das Ganze auch - recht einfach -  mit Verkettungen lösen:

{=INDEX(D1:D10;VERGLEICH(G3&G5&G4;A1:A10&B1:B10&C1:C10;0))}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Klappt es?

Antwort
von offeltoffel, 49

Deine Formel wirft schon ein paar Fragen auf.

SVERWEIS ist folgendermaßen aufgebaut:

=SVERWEIS(Suchkriterium; Matrix; Spaltenindex; [Bereich_Verweis])

Deine Formel lautet:

=SVERWEIS(G5;WENN(A1:A38 =G3;WENN(C1:C38=G4;A1:E38;““);““);4)

Bei dir steht in der Matrix eine Wenn-Abfrage. In der Wenn-Abfrage steht im "Dann"-Bereich eine weitere Wenn-Abfrage. Einen Fall, wo "A1:A38=G3" gibt es nicht, denn du fragst nach einem Wert, der in einer ganzen Matrix stehen soll.

Ich drösel mal deine Formel auf, damit du merkst, was da schief läuft:

Suche nach der Nr. aus G5 in folgendem Bereich: Wenn A1 bis A38 gleich Brot, dann Wenn der Bereich C1 bis C38 gleich 02. Juni, dann A1 bis E38, ansonsten nichts, ansonsten nichts. Nimm die vierte Spalte.

P.S.: bei mir funktioniert die Formel nicht mal bei einer Zahl. Kann ja auch gar nicht. Kannst du vielleicht mal in eigene Worte fassen, was genau die Formel tun soll?

Kommentar von Spotix ,

Hast du die Formel auch mit STRG+Umschalt + enter beendet? Nimm eine Zahl bei G3 + A4 suche mehrere Variablen. Die einer Lösung zuzuordnen sind.

Antwort
von Jackie251, 32

verwende diese Formel in G7:

=INDEX(D2:D4;VERGLEICH(G3;WENN(($B$2:$B$4=G5)*($C$2:$C$4=G4);$A$2:$A$4);0))

Du musst dann die Zelle mit Strg+Shift+Enter abschließen, da es sich um eine Matrixformel handelt

Kommentar von Spotix ,

Danke das hat mir geholfen!!!!!!

Kommentar von Jackie251 ,

gern

Antwort
von WilliPuhdlich, 37

Ich würde die Formel so nehmen:

=SVERWEIS($G$3;A$1:D$38;1;FALSCH)
Kommentar von WilliPuhdlich ,

Und statt "1" dann sukzessive 2 bis 4 wählen, wenn ich die Nr. das Datum oder die Rechnungsnummer anzeigen lassen will.

Kommentar von Jackie251 ,

Das wird wohl kaum funktionieren. Wenn man in der Liste Brot suchen lässt, wird IMMER der erste Treffer verwendet. Also immer Zeile 2.
Man erhält dann also Brot mit Nummer 1134 vom 2. Juni mit Rechnungsnummer 1163
Es ist daher nicht möglich die gesuchte Zeile 4 zu finden (Nummer 1136)

Kommentar von WilliPuhdlich ,

Das ist richtig.

Kommentar von Spotix ,

hat auch nicht funktioniert. Lösung von jakie hat mir geholfen :)

Sie kennen die Antwort?

Fragen Sie die Community

Weitere Fragen mit Antworten