Frage von Reneiiii, 46

Excel 2013: Ein Suchkriterium, mehrere Suchergebnisse?

Hallo zusammen,

meine Excel-Tabelle sieht etwa wie folgt aus:

In Spalte A stehen einige Namen: Kim, Tim, Tom, Lily und Andre

In Spalte B stehen einige Zahlen: 2, 3, 3, 1, 0

In Spalte C steht eine MAX-Funktion: MAX(B2:B6) --> Ergebnis ist 3

Nun die Frage. Wenn ich nun gucken möchte, welche Person die Zahl 3 zugeordnet ist, würde bei einem SVerweis nur Tim ausgegeben werden. Tom wäre aber genauso richtig. Wie würde eine Funktion aussehen, die mir Tom und Tim anzeigt, von mir aus auch in mehrere Zellen?

Vielen Dank für eure Hilfe!

Expertenantwort
von Iamiam, Community-Experte für Excel, 21

erstelle eine Hilfsspalte(sei H) beginnend mit der Formel in 

H1: =B1+Zeile()*10^-7

(sofern es Ganze Zahlen sind, bei Dezimalzahlen noch höhere Potenzen)

Sodann Formel (Liste zB in i2 beginnend)

i2: =GANZZAHL(KGRÖSSTE(H:H;ZEILE()-1))&": "&INDEX(A:A;VERGLEICH(KGRÖSSTE(H:H;ZEILE()-1);J:J;0))

Der erste Teil der Formel dient der Wiedergabe der Zahl (damit Du siehst, wann sie wechselt), der Zweite liest den Wert(Namen) nach Größenzuordnung aus, unterste zuerst..

Willst Du den obersten zuerst, musst Du in der ersten Formel - anstatt + setzen, dann aber Ganzzahl(..+1).

Zeile()-1: das -1 korrigiert die Zeile je nach Anfang der Liste, damit der erste Wert für K (von K-grösste auch wirklich 1 ergibt. Diese Formel generiert einen nach unten fortlaufenden Index,

Du darfst diesen Formelblock aber nicht nach unten verschieben (waagrecht schon!), sonst musst Du die -1 korrigieren.

Klar?

Die 10^-7 reichen übrigens, um alle >1Mio Zeilen des Blattes zu unterscheiden, ohne die Ganzzahl zu beeinflussen


Kommentar von Iamiam ,

Da hab ich die Korrektur einer Adresse übersehen: anstatt J:J "natürlich" H:H ! also:
i2: =GANZZAHL(KGRÖSSTE(H:H;ZEILE()-1))&": "&INDEX(A:A;VERGLEICH(KGRÖSSTE(H:H;ZEILE()-1);H:H;0))


Kommentar von Iamiam ,

Noch was:

da ich hier auf ganze Spalten referenziere, darfst Du A:A und H:H auch nur als ganze Spalten versetzen. Ansonsten fallen die Einträge aus den genannten Spalten raus und alles liefert Unsinn!

Ganze Spalten versetzt man so:

am Spaltenkopf markieren, dann erst an der Umrandung mit der rechten Maustaste verschieben , je nach Sachlage: Kontextmenü: "Ausschneiden und nach rechts verschieben".

In einfachen Fällen tuts auch die linke MT, aber gewöhne Dir den Umgang mit der rechten gut an!.

Expertenantwort
von Ninombre, Community-Experte für Excel, 30

mit der "altbewährten" Formel:
http://www.excelformeln.de/formeln.html?welcher=28

Kommentar von Reneiiii ,

Danke, aber die funktioniert leider nicht... Vermutlich weil in der Ergebnisspalte keine Zahlen, sondern Wörter stehen

Kommentar von Ninombre ,

sorry, das ist etwas knapp mit der Fehlermeldung - welche Formel, welcher Fehler?

=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(B$2:B$6=MAX(B$2:B$6);ZEILE($2:$6));ZEILE(A1)));"")

und diese als Matrixformel mit STRG+SHIFT+Enter abschließen.
Runterziehen in die nächste Zeile und das liefert Tim und Tom.

Mir fällt jetzt auf: Die Formel in Spalte C macht mit MAX keinen Sinn - das steht ja bei jedem Namen der Maximalwert, der zwischen B2 und B6 steht.

Keine passende Antwort gefunden?

Fragen Sie die Community