EXCEL 2010: mittels 2 Faktoren passenden Datensatz ausgeben?

... komplette Frage anzeigen

3 Antworten

Wie im letzten Kommentar erwähnt, kann zumindest ich da keine Lösung bieten und halte auch die Art der Daten als Monatstabellen quer auf dem Tabellenblatt verteilt nicht für geeignet um sinnvoll auszuwerten.

Sauberer wäre es die Werte in Spalten zu führen: Dem letzten Kommentar nach geht es um Datum, Auto, Fahrer und Kilometer.
Im Screenshot wäre ein einfaches Beispiel abgebildet (das Datum in getrennten Spalten, könnte auch in eine).
Die Daten werden dann natürlich anders erfasst. Verwenden mehrere Fahrer das selbe Auto bzw. fährt ein Fahrer in verschiedenen Fahrzeugen entstehen mehrere Zeilen. Das lässt sich aber in der Auswertung zusammenführen.

Gelb markiert sind die Felder, die Du über Dropdown o.ä. auswählst. Auf jeden Fall das Datum, es könnten aber auch die Fahrernamen und Fahrzeugkennungen beliebig sortiert werden.
In B13 steht folgende Formel:
=SUMMENPRODUKT(($A$2:$A$8=$B$9)*($B$2:$B$8=$B$10)*($C$2:$C$8=$A13)*($D$2:$D$8=B$12)*($E$2:$E$8))
die kann in die anderen Felder gezogen werden.

Wenn das Thema mit der Erfassung aus Deiner Sicht problematisch ist: Irgendwo müssen ja die Rohdaten für Deine bisherigen Monatstabellen herkommen. Vermutlich wird jede Fahrt einzeln erfasst. Die Formel lässt sich so anpassen, dass die auch direkt auf den Rohdaten arbeiten kann.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Gipfelstuermer
02.12.2015, 13:01

und wegen dem Beispiel wechsel, war Absicht, damit kann jeder was anfangen als einfach Zeilen und Spalten die beliebig beschriftet sind, außerdem redet man da weniger leicht aneinander vorbei.
ich bedanke mich schonmal und probiere mich mal daran, melde mich aber nochmal wie gut es geklappt hat vielleicht ist deine idee nicht schlecht.

0

Ein Lösungsansatz:
In B1=WENN(A1="A";0;7)
In B2=WENN(A2="A";9;18)

In die gelbe Tabelle in Zelle B4:
=INDIREKT(ADRESSE(ZEILE(B4)+$B$2;SPALTE(B4)+$B$1))
Das runter und rüber kopieren

Wenn ich die Funktion von A und B richtig interpretieren, wird ja nur die Position verändert, von der gelesen wird. Der erste Wert steuert die Spalte, der zweite die Zeilen. Über die Werte in B1 und B2 wird mitgegeben, um wieviel sich die Spalte/Zeile verschiebt, aus der gelesen werden muss.
Am konkreten Fall für B4: Wenn B/B gesetzt ist, soll aus braun gelesen werden. Also muss die Spalte um 7 nach rechts verschoben werden und die Zeile um 18, damit man im braunen Bereich landet.
Ich hoffe, ich habe das richtig verstanden.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Gipfelstuermer
01.12.2015, 16:10

hey spitze, das hilft mir sicher weiter, allerdings würde ich das Problem jetzt gerne weiter spinnen, ich habe keine 4 Auswahl so wie hier in diesem beispiel sondern 19 Tabellen hintereinander und 12 unterinander (also eine Tabellen Matrix von 12x19 = 228 Tabellen) dort würde ich gerne das gleiche Prinzip anwenden, ich glaube die WENN Formel wäre damit etwas überfordert oder ;-)

0

Wird das Dropdownmenü aus einer anderen Tabelle gefüttert? Das wäre doch ggf. eine Grundlage um in diese Tabelle die Werte für Spalte und Zeile zu hinterlegen und wiederum mit einem SVERWEIS in B1 bzw. B2 zu ziehen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
01.12.2015, 16:34

mist, das gehört zur anderen Antwort als Kommentar

0