Frage von Chobulu, 51

Excel 2010: Bei der Summierung einer Werteliste Einzelposten ein- und ausschalten?

Hallo,

ich habe mit Excel eine Haushaltsliste erstellt, in welcher ich Einzelposten wie Fixkosten (Miete etc.) und Laufkosten (einzelne Einkäufe etc.) manuell eintrage und eine Autosumme ausgeben lasse (Kontostand nach Abzügen).

Der Planung halber trage ich dort auch Werte ein, die noch nicht von meinem Kontoabgebucht wurden. Dadurch kann ich sehen, wie mein Kontostand am Ende des Monats aussieht. Möchte ich aber einen aktuellen Kontostand simulieren, muss ich noch nicht abgebuchte Beträge aus der Liste löschen.

Ich möchte Einzelposten stattdessen "deaktiveren", damit sie nicht in die Gesamtrechnung aufgenommen werden, ohne jedoch die manuell eingetragenen Werte löschen zu müssen.

Ich habe das mit einer Checkbox-Lösung versucht (Checkbox an Zelle gebunden und die Einzelwerte per Summenprodukt addiert, abhängig davon, ob die Checkbox aktiv ist oder nicht.). Das Problem hierbei ist jedoch, dass Checkboxen nicht "dynamisch" kopiert werden können. D.h., ich muss für jeden Posten eines jeden Monats mühselig eine neue Checkbox einfügen. Schöner wäre eine einfache copy-paste-Lösung.

Von Makros und VB habe ich keine Ahnung. Ich habe auch schon viel gesucht, aber konnte keine Lösung finden.

Gibt es keinen einfacheren Weg hierfür? Beispiel für das, was ich möchte, im angehängten Bild. Danke für Eure Antwort!!

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Antitroll1234, 51

Markiere doch einfach die bereits abgebuchten Ausgaben mit einem x in Spalte A.

Und dann eine Formel für den tatsächlichen Kontostand:

=SUMMEWENN(A3:A6;"x";D3:D6) 

Als Formel für den voraussichtlichen Kontostand verwendest Du dann einfach:

=SUMME(D3:D6)

Kommentar von Chobulu ,

Perfekt, so einfach und doch genau auf den Punkt!!

Ich habe links neben die Auflistungsspalten einfach eine Spalte für das Datum der Bezahlung eingefügt und dann nach Deinem Beispiel statt einer x-Markierung einfach der Verfügbarkeit des Zahlungsdatums gefragt:

=SUMMEWENN(A3:A6;"<>";D3:D6)

-----------Gesamt | Summe (Formel)
Datum | Position | Kosten

-----------Gesamt | 500
01.       | Miete     | 515

            | Strom   | 50 

03.       | Handy   | 15

So werden nur Positionen berechnet, für die ein Zahlungsdatum vorhanden ist.

Danke sehr!!

Antwort
von iMPerFekTioN, 40

Wie wärs denn damit?:

https://www.dropbox.com/s/6geuzvtao5hsw60/Beispiel%20Kontorechunung1.xlsx?dl=0

Die Tabelle sollte am besten runter geladen werden, sonst funktionieren die Steuerelemente nicht richtig!

Grüße,


iMPerFekTioN


Kommentar von Chobulu ,

Danke, dass Du Dir sogar die Mühe gemacht, eine Excel-Datei zu erstellen.

Letztlich erweisen sich Checkboxen bei der Anzahl an Positionen als nicht ideal, weil sie sich nicht dynamisch kopieren lassen. Aber Deine Methode ist, was ich ursprünglich gewollt hatte.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten