Frage von Dennisthek1nq, 69

Excel 2007 --> Verschachtelte Wenn-Formel mit Datumsabfrage?

Hallo zusammen,

Ich habe mal wieder eine Excel-Frage:

Ich brauche eine Formel die folgendes für mich erledigt.

Ich habe bespielsweise Zellen mit Städten (ACHTUNG die Städte können auch doppelt vorkommen, also bitte die Formel nicht auf eine Zelle begrenzen)

A1: Dortmund
A2: Gelsenkirchen
A3: München
A4: Berlin

Dann habe ich in Spalte B stehen, wann ich dort hinreise und in C, wann ich zurück komme:

B1: 01.01.2016                   C1: 03.01.2016
B2: 01.08.2016                   C2: 05.08.2016
B3: 01.09.2016                   C3: 05.09.2016
B4: 02.09.2016                   C3: 06.09.2016

Nun soll er für jeden Ort prüfen, ob ich dort hin aktuell auf Reise bin und dann "Ja" oder "Nein" ausgeben

Also in meinem Fall:

D1: NEIN
D2: NEIN        
D3: JA
D4: JA

Besten Dank im Voraus!

Antwort
von mirolPirol, 46

Die Formel wäre 

D1: =WENN(HEUTE()=$C1;"JA";"NEIN")

D2: =WENN(HEUTE()=$C2;"JA";"NEIN")
D3: =WENN(HEUTE()=$C3;"JA";"NEIN")
D4: =WENN(HEUTE()=$C4;"JA";"NEIN")

Dazu 2 Fragen: Bist du immer genau nur einen Tag in einer Stadt? Dann könnte in D3 und D4 nur dann ein "JA" stehen, wenn du an einem Tag in beiden Städten bist, was ja laut C3 und C4 nicht der Fall ist.

Kommentar von Dennisthek1nq ,

Das hätte ich auch selber gekonnt. Problem ist, dass ich nicht nur einen Tag weg bin, sondern über einen Zeitraum (B=Hinreise, C=Rückreise).

Außerdem bin ich auch öfters in einer Stadt. Das heißt er muss alle Daten mit beispielsweise der Stadt Dortmund prüfen.

Es kann also in A1 Dortmund mit Daten in B1 und C1 stehen, aber zusätzlich auch noch in A6 mit Daten in B6 und C6 ;)

Kommentar von mirolPirol ,

Dann musst du eben den Zeitraum zwischen B1 und C1 abprüfen, ist doch (fast) das Gleiche! Du brauchst neben der WENN()-, auch noch die UND()-Funktion:

=WENN(UND(HEUTE()>=B1;HEUTE()<=C1);"JA";"NEIN")

Antwort
von augsburgchris, 33

D1: =WENN(UND(B1>=HEUTE();C1<=HEUTE());"Ja";"Nein")

Runterziehen fertig.

Kommentar von Dennisthek1nq ,

Leider Nein, so ist ebenfalls das Problem nicht behoben, wenn ein Datensatz mehrfach vorhanden ist.

Z.B. wenn ich zweimal nach Dortmund fahre, kann ich deine Formel aber nur auf eine Reise beschränken.

Kommentar von Funfroc ,

Hallo,

zum einen müssten in der Formel von augsburgchris die <> andersrum sein. Die Formel analysiert so Abreise nach heute, Rückreise vor heute.

Dann hilft die Formel auch. Die Formel führst du ja in jeder Zeile aus. Wenn also 10x Dortmund vorkommt und davon 3x der Zeitraum passt, wirst du 3x Ja für Dortmund stehen haben.

Wenn das nicht ist, was du willst, dann ist die Fragestellung für mich nicht verständlich.

LG, Chris

Kommentar von azmd108 ,

Laut deiner Fragestellung ist das die Formel die benötigst, ansonsten pass deine Frage an.

Kommentar von Oubyi ,

Ich denke ich habe das Problem des FS verstanden (allerdings leider keine Zeit mehr, eine Lösung zu suchen, da ich zur Arbeit muss).
Wenn in Zeile 1 steht , dass er nächsten Monat nach Dortmund reist, aber in Zeile 6 steht, dass er HEUTE in Dortmund ist, dann soll nicht nur in D6 "JA" stehen, sondern auch in D1.
Sodass er sieht, dass er heute schon an dem Ort ist, den er nächsten Monat besuchen will.
Richtig?
Zu lösen müsste das recht einfache sein, indem man zusätzlich zu Chris´ Formel noch eine Abfrage drumherum baut, ob irgendwo in der Tabelle bei Dortmund ein "JA" steht)

Kommentar von DeeDee07 ,

Falls die Frage so gemeint war wie von Oubyi interpretiert, würde ich folgendes machen:

In D1 augsburgchris' Formel und runterkopieren (Spalte D ggf. später ausblenden, ist nur eine Hilfsspalte).

In E1:
=WENN(D1="Ja";"Ja";WENN(ZÄHLENWENNS(A:A;A1;D:D;"Ja")>0;"Ja";"Nein"))

(ungetestet)

Kommentar von DeeDee07 ,

Sehe gerade, in E1 müsste auch reichen:

=WENN(ZÄHLENWENNS(A:A;A1;D:D;"Ja")>0;"Ja";"Nein")

Kommentar von Oubyi ,

JETZT hatte ich Zeit und es war doch nicht ganz so einfach, wie ich gedacht hatte. Ohne Hilfsspalte sollte es so klappen:

{=WENN(SUMME(($B$1:$B$12<=HEUTE())*($C$1:$C$12>=HEUTE())*($A$1:$A$12=A1))>0;"Ja";"Nein")}

**ACHTUNG!** Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Klappt es?

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten