Frage von MurkelB 21.02.2013

Excel 2003 Zahl aus Liste suchen und nebenstehenden Namen ausgeben

  • Hilfreichste Antwort von thommi12 22.02.2013

    Mit der Funktion SVERWEIS, vgl. in Excel-Hilfe. Der letzte Parameter muss WAHR sein, damit auch ein Ergebnis bei nicht exakter Übereinstimmung gefunden wird. Die erste Spalte enthält schön sortiert (wichtig) aufsteigend die Postleitzahlen-Grenzen der Bezirke.

    Hier ein Beispiel (die Zelle A1 enthält hier den Text 'PLZ') mit den Zellinhalten A1 bis D8, wobei in Zelle c1 der Eingabewert beispielsweise 27705 ist, und als Ergebnis 'Max Mustermann' aus Zelle b3 in Zelle D1 angezeigt wird:

    1: PLZ ORT 27705 Max Mustermann

    2: 22222 b
    3: 27700 Max Mustermann
    4: 27730 Nächster
    5: 33333 c
    6: 44444 keiner
    7: 55555 e
    8: 66666 d

    Die verwendete Formel in Zelle D1 ist:

    =SVERWEIS($C$1;A2:B8;2;WAHR)

    Dabei:

    $C$1 definiert das Eingabefeld (hier mal als absoluter Feldbezug mit den $-Zeichen),

    A2:B8 ist die Tabelle (Matrix), deren erste Spalte durchsucht wird,

    2 gibt an, dass der korrepondierende Zellinhalt der zweiten Spalte der Matirx zurückgegeben wird.

    WAHR gibt an, dass immer der Wert zurückgegeben wird, der kleiner oder gleich dem Suchriterium ist. Dies erfordert eine streng aufsteigende Sortierung der ersten Spalte!

    So wird im Beispiel von 27700 bis einschließlich 27729 der Wert Max Mustermann zurückgeliefert.

  • Antwort von MrProcess 22.02.2013

    Würde ich mit Vergleich() und Index() lösen, weil der Verweis für was anderes gedacht ist (Bereichszuordnung, nicht exakter Match).

    Angenommen A1:A10 enthält Postleitzahlen B1:B10 enthält Ortsnamen in C1 steht eine zu suchende PLZ In D1 dann eine Formel wie

    =vergleich(c1 ; $a$1:A4$10 ; 0) In Worten: suche nach der PLZ die in C1 steht, durchsuche den Bereich von a1 bis a10. Das letzte 0 bedeutet suche exakt. Es kommt ein Fehlerwert raus, wenn die PLZ nicht vorhanden wäre.

    Als Ergebnis kommt da ein Indexwert raus. Sagen wir 2 wenn die gesuchte PLZ in a2 stünde. Oder 5 wenn die PLZ in a5 wäre.

    Eine weitere Formel mit Index holt den passenden Text/Ort, etc. raus =index($b$1: 4b;$10; bezugaufvorherigezelle ; 1)

    Beispiel ist mal absichtlich einfach gehalten um das Prinzip nachvollziehbar zu machen.

Du kennst die Antwort? Frage beantworten
Bitte noch eine Antwort ... Frage erneut stellen

Verwandte Fragen

Fragen Sie die Community –

anonym und kostenlos!