Frage von paule72, 65

Excel -Wenn Suchwert(C) auf mehrere Werte(A) passt, soll der Minimum wert von (B) ausgeben werden?

Hi, C=Suchwert; D = Ergebnis

A __ B___ C __ D


a __ 1 __ d _ (4)

b _ 2 _ f _ (2)

c _ 3 _ e _ (3)

d _ 4 _ b _(2)

e _ 5

f _6

e _3

f _2

c _ 5

Ich habe in Spalte A Zahlen und in Spalte B dazugehörige Zahlenwerte. In Spalte C stehen Zahlen die in Spalte A gesucht werden sollen. In Spalte D sollen die minimal Werte aus Spalte B eingetragen werden, wenn C in A gefunden wurde ist. Es kann sein, dass C öfters in A gefunden wird und es soll deshalb der Minimum wert ausgegeben werden.

Nochmal anders beschrieben: Wenn ein Suchwert(C) auf mehreren Werte passt(In diesem Fall in A) und man dann noch von den Werten in (B) das Minimum ausgegeben haben möchte?

Ich hoffe es ist verständlich ausgedrückt.

Gruß

Antwort
von Pucky99, 35

Eine ganz unelegante Variante wäre die Tabelle aufsteigend nach Spalte B zu sortieren und dann den Sverweis zu nehmen. Da nimmt er nämlich immer den ersten Wert den er in der Suchmatrix findet, dies wäre dann immer der niedrigste. Formeln in C dann durch Werte ersetzen, dann kannst du wieder umsortieren. Wenn du es variabel brauchst, kann ich momentan leider mit keiner Ideee behilflich sein.

Kommentar von paule72 ,

Ok, hab es jetzt mal mit deiner Variante ausprobiert. Ich komm mit Sverweis nicht zurecht. Hab nach L sortiert. Er gibt mir nur #WERT! zurück. 

A=Suchwert;N=Matrix; L=Ausgabewert

=SVERWEIS(A2;$N$1:$N$4395;$L$1:$L$4395)

Kommentar von Pucky99 ,

für Spalte 2 folgende Formel =SVERWEIS(C2;A:B;2;0)

Kommentar von paule72 ,

Sry aber das verstehe ich nicht. Spalte 2? 

In deiner Formel C2= Suchwert; A:B= Matrix; und 2=?;0=? Hier kommt nur #NV raus. 

Kommentar von Pucky99 ,

ohne die Datei ist es echt schwierig, die formel zu bennenen vielleicht verstehe ich auch etwas falsch. vielleicht lädst du die datei mal hoch, dann schau ich es mir an http://www.filehosting.at/

Kommentar von paule72 ,

Funktioniert. Kommt das gleiche raus wie bei der anderen Funktion. Hängt wo an meinen Werten. 

Antwort
von Funfroc, 43

Hallo,

das funktioniert mit dieser Formel:

{=MIN(WENN(A1:A100=C2;B1:B100))}

Es handelt sich um eine Matrixformel. Die Eingabe muss ohne {} erfolgen und mit STRG + ALT + ENTER bestätigt werden.

Wenn der Bereich größer als Zeile 1 - 100 ist, Formel entsprechend anpassen. Der Bereich A und B muss gleich groß festgelegt sein.

LG, Chris

Kommentar von paule72 ,

Klappt schon ganz gut! Danke! Hab aber glaub ich noch ein paar Fehler. Meine beiden Spalten A und B haben 4408 Zeilen. Ich hab mal gelesen Min nimmt nur 255 Zeilen auf? 

Kommentar von Funfroc ,

Hallo,

nein das trifft hier nicht zu. Du meinst etwas anderes.

MIN kann maximal 255 Argumente verarbeiten. die Formel, die ich MIN hier gebe ist aber 1 Formel, und somit 1 Argument.

Min den 255 Argumenten hast du ein Problem, wenn du eine Formel so aufbaust:

=MIN(A1;A2;A3;A4;A5;...;...;...)

Ein Argument ist jeweils durch Semikolon getrennt.

Wenn du das gleiche abfragst, aber so aufbaust.

=MIN(A1:A100) 

Dann hast du nur 1 Argument.

LG, Chris

Kommentar von paule72 ,

OK. Danke für die Erklärung! Also theoretisch muss deine Formel ja stimmen, aber iwi hab ich so viele Ausreißer nach oben. 

Er sucht sich ja alle zahlen die so groß sind wie der Suchwert, speichert sie unter und nimmt von diesen den Minimalwert und gibt ihn aus. 

Kann man evtl. noch einfügen das er noch einen Bereich um die Zahl sucht? Also wenn ich eine Zahl hab mit Nachkommastelle dann die zweite Nachkommastelle? 

Kommentar von Funfroc ,

da komme ich gerade nicht mehr mit.

Ich weiß nicht, ob verweisen auf andere Forun hier ungern gesehen ist, aber ich bin selbst noch bei office-lösung.de unterwegs.

Da kannst du auch eine Datei hochladen. ohne Datei wird das schwierig genau zu sagen, woran es liegt.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten